aboutsummaryrefslogtreecommitdiff
path: root/games/gnubg/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-10-01 13:32:10 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-10-01 13:32:10 +0000
commit35516e70f75e62be6f3dfa3a4a6a3c40cd6e420e (patch)
tree4f77aadd6b2438029a3187125a5848e853bf84ce /games/gnubg/Makefile
parent42a465abfde805c8c150addda6a5849c4af89cb5 (diff)
downloadports-35516e70f75e62be6f3dfa3a4a6a3c40cd6e420e.tar.gz
ports-35516e70f75e62be6f3dfa3a4a6a3c40cd6e420e.zip
Notes
Diffstat (limited to 'games/gnubg/Makefile')
-rw-r--r--games/gnubg/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/games/gnubg/Makefile b/games/gnubg/Makefile
index b6b2f8f8ca57..bce9dbc0bd14 100644
--- a/games/gnubg/Makefile
+++ b/games/gnubg/Makefile
@@ -28,8 +28,8 @@ LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
WRKSRC= ${WRKDIR}/gnubg
-OPTIONS= ESOUND "Enable sound support" ON \
- NLS "Enable gettext support" ON
+OPTIONS_DEFINE= ESOUND NLS
+OPTIONS_DEFAULT=ESOUND NLS
CONFIGURE_ARGS= --with-board3d
@@ -42,15 +42,15 @@ USE_AUTOTOOLS= libtool automake
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_ESOUND)
+.if ${PORT_OPTIONS:MESOUND}
USE_GNOME+= esound
.else
CONFIGURE_ENV+= ac_cv_path_AUDIOFILE_CONFIG=no ac_cv_path_ESD_CONFIG=no
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
CONFIGURE_ARGS+= --enable-nls
@@ -78,4 +78,4 @@ post-patch:
pre-configure:
cd ${WRKSRC} && ./autogen.sh
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>