aboutsummaryrefslogtreecommitdiff
path: root/games/gnubg/Makefile
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2014-08-31 13:46:37 +0000
committerCarlo Strub <cs@FreeBSD.org>2014-08-31 13:46:37 +0000
commit96015ab9d0870319d7c50b0da365bd7624038779 (patch)
tree2f286883d5635d451fffd2d45b58e5cc61d68df5 /games/gnubg/Makefile
parent73f1eecacb79757ace8fa893bffa68eafe199a5b (diff)
downloadports-96015ab9d0870319d7c50b0da365bd7624038779.tar.gz
ports-96015ab9d0870319d7c50b0da365bd7624038779.zip
Notes
Diffstat (limited to 'games/gnubg/Makefile')
-rw-r--r--games/gnubg/Makefile42
1 files changed, 16 insertions, 26 deletions
diff --git a/games/gnubg/Makefile b/games/gnubg/Makefile
index 5af8380be426..4d416c0c461d 100644
--- a/games/gnubg/Makefile
+++ b/games/gnubg/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gnubg
PORTVERSION= 1.03.001
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.c-s.li/ports/ \
http://files.gnubg.org/media/sources/
@@ -16,45 +17,34 @@ LICENSE= GPLv3
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
RUN_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
- libgtkextra-x11-2.0.so:${PORTSDIR}/x11-toolkits/gtkextra2 \
- libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext
-
-OPTIONS_DEFINE= ESOUND NLS DOCS
-OPTIONS_DEFAULT=ESOUND NLS
-
-CONFIGURE_ARGS= --with-board3d --with-sqlite --with-python
+ libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext \
+ libcanberra-gtk.so:${PORTSDIR}/audio/libcanberra
+CONFIGURE_ARGS= --with-board3d --with-sqlite --with-python=${LOCALBASE}/bin/python
CONFIGURE_ENV= ac_cv_path_ARTSC_CONFIG=no ac_cv_path_LIBART_CONFIG=no
-
-INSTALLS_ICONS= yes
-USE_GNOME= libxml2
-USES= gmake libtool pathfix shebangfix python
-USE_AUTOTOOLS= automake libtoolize
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+INSTALL_TARGET= install-strip
+USES= gmake libtool pathfix shebangfix python pkgconfig
+USE_AUTOTOOLS= aclocal automake libtoolize
+USE_GNOME= glib20
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= NLS DOCS
+OPTIONS_DEFAULT=NLS
-.if ${PORT_OPTIONS:MESOUND}
-USE_GNOME+= esound
-.else
-CONFIGURE_ENV+= ac_cv_path_AUDIOFILE_CONFIG=no ac_cv_path_ESD_CONFIG=no
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
-CONFIGURE_ARGS+= --enable-nls
.else
PLIST_SUB+= NLS="@comment "
CONFIGURE_ARGS+= --disable-nls
.endif
-INFO= gnubg
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-pre-configure:
- cd ${WRKSRC} && ./autogen.sh
+#pre-configure:
+# cd ${WRKSRC} && ./autogen.sh
.include <bsd.port.mk>