aboutsummaryrefslogtreecommitdiff
path: root/games/gnuchess
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>2002-10-07 10:28:09 +0000
committerMark Murray <markm@FreeBSD.org>2002-10-07 10:28:09 +0000
commitadb3ec414382f9b1716d551534b23fdc0a46da37 (patch)
tree65741f2bb999c57069ad75a3071d23874982fc77 /games/gnuchess
parentaa14624568fe27a2ddd8a8ab9501f24ce44f0d1e (diff)
downloadports-adb3ec414382f9b1716d551534b23fdc0a46da37.tar.gz
ports-adb3ec414382f9b1716d551534b23fdc0a46da37.zip
Notes
Diffstat (limited to 'games/gnuchess')
-rw-r--r--games/gnuchess/Makefile13
-rw-r--r--games/gnuchess/distinfo2
-rw-r--r--games/gnuchess/files/patch-aa116
-rw-r--r--games/gnuchess/pkg-descr21
-rw-r--r--games/gnuchess/pkg-plist11
5 files changed, 7 insertions, 156 deletions
diff --git a/games/gnuchess/Makefile b/games/gnuchess/Makefile
index 3915988703ed..8abd119e3713 100644
--- a/games/gnuchess/Makefile
+++ b/games/gnuchess/Makefile
@@ -6,18 +6,13 @@
#
PORTNAME= gnuchess
-PORTVERSION= 4.0.80
+PORTVERSION= 5.04
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= gnuchess
-DISTNAME= gnuchess-4.0.pl80
+MASTER_SITE_SUBDIR= chess
-MAINTAINER= markm@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-HAS_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
-#CONFIGURE_SCRIPT= src/configure
-#CONFIGURE_ARGS= -sde -Dprefix=${PREFIX}
-MAN6= game.6 gnuan.6 gnuchess.6 postprint.6
+GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/games/gnuchess/distinfo b/games/gnuchess/distinfo
index b644606f9caa..4b13a863813b 100644
--- a/games/gnuchess/distinfo
+++ b/games/gnuchess/distinfo
@@ -1 +1 @@
-MD5 (gnuchess-4.0.pl80.tar.gz) = 833110654ec086b4ace45e037612033e
+MD5 (gnuchess-5.04.tar.gz) = ddf0a80e857abaef65cac94d1d62c000
diff --git a/games/gnuchess/files/patch-aa b/games/gnuchess/files/patch-aa
deleted file mode 100644
index 736554348e09..000000000000
--- a/games/gnuchess/files/patch-aa
+++ /dev/null
@@ -1,116 +0,0 @@
-diff -udr ../../gnuchess-4.0.pl79/src/dspcom.c ./src/dspcom.c
---- ../../gnuchess-4.0.pl79/src/dspcom.c Mon Sep 28 08:41:19 1998
-+++ ./dspcom.c Thu Dec 10 23:40:57 1998
-@@ -1099,14 +1099,14 @@
- #ifdef NONDSP
- s[0] = sx[0] = '\0';
- while (!sx[0])
-- (void) gets (sx);
-+ (void) fgets (sx, 80, stdin); sx[79] = '\0';
- #else
- fflush (stdout);
- #ifdef MSDOS
- s[0] = '\0';
- eof = ( gets (sx) == NULL );
- #else
- eof = ( getstr (sx) == ERR );
- #endif
- #endif
- sscanf (sx, "%s", s);
-diff -udr ../../gnuchess-4.0.pl79/src/gnuan.c ./src/gnuan.c
---- ../../gnuchess-4.0.pl79/src/gnuan.c Mon Sep 28 08:41:21 1998
-+++ ./gnuan.c Thu Dec 10 23:39:26 1998
-@@ -1348,12 +1348,12 @@
- fpout = stderr;
- fprintf (fpout, "Input the file with the algebraic moves of the game.\n");
- fflush (fpout);
-- gets (infilename);
-+ fgets (infilename, 255, stdin); infilename[255] = '\0';
- fprintf (fpout, "\n");
- do
- {
- fprintf (fpout, "Input the search depth you want to use. (1 to 29)(- for depth from file)\n");
-- gets (inbuf);
-+ fgets (inbuf, 256, stdin); inbuf[255] = '\0';
- search_depth = atoi (inbuf);
- if (search_depth < 0)
- {
-@@ -1369,7 +1369,7 @@
- do
- {
- fprintf (fpout, "Input the maximum number of minutes per move you want to use.\n");
-- gets (inbuf);
-+ fgets (inbuf, 256, stdin); inbuf[255] = '\0';
- max_minutes = atoi (inbuf);
- if (max_minutes < 0)
- {
-@@ -1379,7 +1379,7 @@
- }
- while ((max_minutes + max_seconds) < 1);
- fprintf (fpout, "Post the search results(y/n).\n");
-- gets (inbuf);
-+ fgets (inbuf, 256, stdin); inbuf[255] = '\0';
- if (inbuf[0] == 'y')
- flag.post = true;
- else
-@@ -1559,7 +1559,8 @@
- while (true)
- {
- printf (">");
-- gets (GNUANinbuf1);
-+ fgets (GNUANinbuf1, 128, stdin);
-+ GNUANinbuf1[127] = '\0';
- p = GNUANinbuf1;
- q = GNUANinbuf;
- while (true)
-diff -udr ../../gnuchess-4.0.pl79/src/nondsp.c ./src/nondsp.c
---- ../../gnuchess-4.0.pl79/src/nondsp.c Mon Sep 28 08:41:22 1998
-+++ ./nondsp.c Thu Dec 10 23:39:26 1998
-@@ -264,10 +264,11 @@
-
- NewGame ();
-
-- gets (s); /* skip "setup" command */
-+ fgets (s, 80, stdin); /* skip "setup" command */
-+ s[79] = '\0';
- for (r = 7; r >= 0; r--)
- {
-- gets (s);
-+ fgets (s, 80, stdin); s[79] = '\0';
- for (c = 0; c <= 7; c++)
- {
- ch = s[c];
-@@ -617,7 +618,7 @@
- if (!T[0])
- {
- printz (CP[61]);
-- gets (T);
-+ fgets (T, 64, stdin); T[63] = '\0';
- }
- strcat (T, "XX");
- /* skip whitespace */
-diff -udr ../../gnuchess-4.0.pl79/src/search.c ./src/search.c
---- ../../gnuchess-4.0.pl79/src/search.c Mon Sep 28 08:41:23 1998
-+++ ./search.c Thu Dec 10 23:39:26 1998
-@@ -174,7 +174,7 @@
- while (true)
- {
- printf ("debug?");
-- gets (b);
-+ fgets (b, 32, stdin); b[31] = '\0';
- if (b[0] == 'p')
- traceply = atoi (&b[1]);
- else if (b[0] == '\0')
-diff -udr ../../gnuchess-4.0.pl79/src/uxdsp.c ./src/uxdsp.c
---- ../../gnuchess-4.0.pl79/src/uxdsp.c Mon Sep 28 08:41:25 1998
-+++ ./uxdsp.c Thu Dec 10 23:41:35 1998
-@@ -773,9 +773,9 @@
- refresh ();
- #ifdef MSDOS
- T[0] = '\0';
- gets (T);
- #else
- getstr (T);
- #endif
- }
- strcat (T, "XX");
diff --git a/games/gnuchess/pkg-descr b/games/gnuchess/pkg-descr
index f993cb911982..65e09baddfef 100644
--- a/games/gnuchess/pkg-descr
+++ b/games/gnuchess/pkg-descr
@@ -2,23 +2,6 @@
plays against itself.
Gnuchess is an updated version of the GNU chess playing
- program. It has a simple alpha-numeric board display, an
- IBM PC compatible interface, or it can be compiled for use
- with the chesstool program on a SUN workstation or with
- the xboard program under X-windows. To invoke the program
- gnuchess
- - simple curses based version
+ program. It has a simple alpha-numeric board display.
- gnuchessn
- - fancy version using curses and inverse video on
- UNIX, or IBM PC cursor controls and characters on
- MSDOS
-
- gnuchessr
- - ASCII based version
-
- gnuchessc
- - chesstool compatible version
-
- gnuchessx
- - xboard compatible version
+WWW: http://savannah.gnu.org/projects/chess/
diff --git a/games/gnuchess/pkg-plist b/games/gnuchess/pkg-plist
index ac742d71fea8..66891ed42559 100644
--- a/games/gnuchess/pkg-plist
+++ b/games/gnuchess/pkg-plist
@@ -1,12 +1 @@
bin/gnuchess
-bin/gnuchessr
-bin/gnuchessn
-bin/gnuchessx
-bin/gnuchessc
-bin/postprint
-bin/gnuan
-bin/game
-lib/gnuchess.lang
-lib/eco.pgn
-lib/gnuchess.data
-lib/gnuchess.eco