aboutsummaryrefslogtreecommitdiff
path: root/games/gnurobbo/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-28 00:46:09 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-28 00:46:09 +0000
commit4eeb461d1668c5373b124a229bdab5e9667c8f71 (patch)
treec64905d25b083895b4ef12ac9a267914b9f64e8f /games/gnurobbo/Makefile
parentc0d0be9781199f3abc3e0573d82d9356cb74f041 (diff)
downloadports-4eeb461d1668c5373b124a229bdab5e9667c8f71.tar.gz
ports-4eeb461d1668c5373b124a229bdab5e9667c8f71.zip
Notes
Diffstat (limited to 'games/gnurobbo/Makefile')
-rw-r--r--games/gnurobbo/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/games/gnurobbo/Makefile b/games/gnurobbo/Makefile
index 165fe2975783..fb01c2c84522 100644
--- a/games/gnurobbo/Makefile
+++ b/games/gnurobbo/Makefile
@@ -11,22 +11,22 @@ EXTRACT_SUFX= -source.tar.gz
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Reimplementation of LK Avalon's Robbo for the Atari XE/XL
-USE_GMAKE= yes
+USES= gmake
USE_SDL= sdl ttf mixer image
MAKE_ENV= PACKAGE_DATA_DIR="${DATADIR}" \
BINDIR="${PREFIX}/bin" \
DOCDIR="${DOCSDIR}"
+PLIST_FILES= bin/${PORTNAME}
PORTDOCS= *
+PORTDATA= *
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e '/define DEBUG_DUMP_VM_USAGE/ d' ${WRKSRC}/game.c
-.if ! ${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -e '/DOCDIR/ d' ${WRKSRC}/Makefile
-.endif
+ @${REINPLACE_CMD} -e '/^install:/,$$ s|$$([A-Z_]*DIR)|${STAGEDIR}&| g' \
+ ${WRKSRC}/Makefile
.include <bsd.port.mk>