aboutsummaryrefslogtreecommitdiff
path: root/games/gnurobots
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-02-02 14:08:17 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-02-02 14:08:17 +0000
commit76e010042efbc7e16b11a16045c08b66f0a3d47d (patch)
tree15cde1468c90a7700bc0fbbc65154e132d75cb62 /games/gnurobots
parentfb1a81fde21dbed748cb3561f190e0e0cce4940d (diff)
- Bump PORTREVISION
- Change master sites and add icon - Take maintainership - Add license (GPLv3) - Use the new format for LIB_DEPENDS - Disable all warnings with -w - Support STAGEDIR - Change DOCS, add DOCS Option - Add files/pkg-install.in and files/pkg-message.in - Remove pkg-message - Add Desktop entry file - Change pkg-plist, add icon, remove DOCS PR: ports/174022 Submitted by: nemysis (self)
Notes
Notes: svn path=/head/; revision=342296
Diffstat (limited to 'games/gnurobots')
-rw-r--r--games/gnurobots/Makefile47
-rw-r--r--games/gnurobots/distinfo2
-rw-r--r--games/gnurobots/files/pkg-install.in17
-rw-r--r--games/gnurobots/files/pkg-message.in12
-rw-r--r--games/gnurobots/pkg-message5
-rw-r--r--games/gnurobots/pkg-plist9
6 files changed, 66 insertions, 26 deletions
diff --git a/games/gnurobots/Makefile b/games/gnurobots/Makefile
index 8b354cd42c39..c9638ed6276b 100644
--- a/games/gnurobots/Makefile
+++ b/games/gnurobots/Makefile
@@ -3,34 +3,55 @@
PORTNAME= gnurobots
PORTVERSION= 1.2.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= games
-MASTER_SITES= GNU
+MASTER_SITES= GNU \
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= GNU diversion wherein Scheme-coded robots explore a world
-LIB_DEPENDS= guile.21:${PORTSDIR}/lang/guile
+LICENSE= GPLv3
+
+LIB_DEPENDS= libguile.so:${PORTSDIR}/lang/guile
USES= pkgconfig
USE_GNOME= vte
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} -w
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-NO_STAGE= yes
+PORTDOCS= *
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= AUTHORS ChangeLog NEWS README THANKS TODO
+
+DOCSRCDIR2= ${WRKSRC}/doc
+DOCSDIR2= ${DOCSDIR}/doc
+DOC_FILES2= Robots-HOWTO contrib
+
+OPTIONS_DEFINE= DOCS
+
+SUB_FILES= pkg-install pkg-message
+
+DESKTOP_ENTRIES="GNU Robots" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
+
post-patch:
@${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|#include <pty.h>||g' ${WRKSRC}/src/ui-cmdwin.c
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for f in AUTHORS ChangeLog NEWS README THANKS doc/Robots-HOWTO doc/contrib
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.endif
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
.include <bsd.port.mk>
diff --git a/games/gnurobots/distinfo b/games/gnurobots/distinfo
index 5dfa27259d5a..430bf1b6c095 100644
--- a/games/gnurobots/distinfo
+++ b/games/gnurobots/distinfo
@@ -1,2 +1,4 @@
SHA256 (gnurobots-1.2.0.tar.gz) = 8b6f4f0d40bef5cfdfb7eb7c82ea1402d2747c37b2c7b7aa92faff55351df11d
SIZE (gnurobots-1.2.0.tar.gz) = 176642
+SHA256 (gnurobots.png) = b5b422f26cd8a380a7891a3d894b5bac1cad744e5d1f29d32ff024b7c019158b
+SIZE (gnurobots.png) = 3052
diff --git a/games/gnurobots/files/pkg-install.in b/games/gnurobots/files/pkg-install.in
new file mode 100644
index 000000000000..1f27f8d50017
--- /dev/null
+++ b/games/gnurobots/files/pkg-install.in
@@ -0,0 +1,17 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+echo "This example maps you can use:"
+echo ""
+
+ls -x %%DATADIR%%/maps
+echo ""
+
+echo "This example robots you can use:"
+echo ""
+
+ls -x %%DATADIR%%/scheme
+echo ""
+echo ""
diff --git a/games/gnurobots/files/pkg-message.in b/games/gnurobots/files/pkg-message.in
new file mode 100644
index 000000000000..4a1562b10a33
--- /dev/null
+++ b/games/gnurobots/files/pkg-message.in
@@ -0,0 +1,12 @@
+===============================================================================
+
+GNU Robots has been installed.
+
+Where to find things
+
+ - A place to start: %%DOCSDIR%%/doc/Robots-HOWTO
+ - Example maps: %%DATADIR%%/maps/
+ - Example robots: %%DATADIR%%/scheme/
+ - Binaries: gnurobots
+
+===============================================================================
diff --git a/games/gnurobots/pkg-message b/games/gnurobots/pkg-message
deleted file mode 100644
index c07a6ac3ba11..000000000000
--- a/games/gnurobots/pkg-message
+++ /dev/null
@@ -1,5 +0,0 @@
-Where to find things
- - A place to start: $PREFIX/share/doc/gnurobots/Robots-HOWTO
- - Example maps: $PREFIX/share/gnurobots/maps/
- - Example robots: $PREFIX/share/gnurobots/scheme/
- - Binaries: gnurobots
diff --git a/games/gnurobots/pkg-plist b/games/gnurobots/pkg-plist
index 8d8a9b5dcdd7..aedf0e90a6fa 100644
--- a/games/gnurobots/pkg-plist
+++ b/games/gnurobots/pkg-plist
@@ -1,11 +1,4 @@
bin/gnurobots
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/Robots-HOWTO
-%%PORTDOCS%%%%DOCSDIR%%/THANKS
-%%PORTDOCS%%%%DOCSDIR%%/contrib
%%DATADIR%%/maps/maze.map
%%DATADIR%%/maps/pattern.map
%%DATADIR%%/maps/small.map
@@ -15,7 +8,7 @@ bin/gnurobots
%%DATADIR%%/scheme/simple.scm
%%DATADIR%%/scheme/stop.scm
%%DATADIR%%/scheme/zap.scm
+share/pixmaps/gnurobots.png
@dirrm %%DATADIR%%/scheme
@dirrm %%DATADIR%%/maps
@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%