aboutsummaryrefslogtreecommitdiff
path: root/games/gnushogi
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-19 19:23:34 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-19 19:23:34 +0000
commit7a86eee182588a70fb782878ba75599ac55b3d94 (patch)
tree257c8821799569f8e4021172826ed457302e461d /games/gnushogi
parentbd13f9cb9d357a40b8e251097933495a3f8f3104 (diff)
downloadports-7a86eee182588a70fb782878ba75599ac55b3d94.tar.gz
ports-7a86eee182588a70fb782878ba75599ac55b3d94.zip
Notes
Diffstat (limited to 'games/gnushogi')
-rw-r--r--games/gnushogi/Makefile62
-rw-r--r--games/gnushogi/Makefile.common11
-rw-r--r--games/gnushogi/distinfo4
-rw-r--r--games/gnushogi/files/patch-aa53
-rw-r--r--games/gnushogi/files/patch-doc::gnushogi.texinfo13
-rw-r--r--games/gnushogi/pkg-plist50
6 files changed, 94 insertions, 99 deletions
diff --git a/games/gnushogi/Makefile b/games/gnushogi/Makefile
index 82accab99448..180931de77df 100644
--- a/games/gnushogi/Makefile
+++ b/games/gnushogi/Makefile
@@ -5,43 +5,51 @@
# $FreeBSD$
#
-PORTNAME= gnushogi
-PORTVERSION= 1.2.3
+PORTNAME= ${GNUSHOGI_PORTNAME}
+PORTVERSION= ${GNUSHOGI_PORTVERSION}
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= gnushogi
-DISTNAME= gnushogi-1.2p03
+MASTER_SITES= ${GNUSHOGI_MASTER_SITES}
+MASTER_SITE_SUBDIR= ${GNUSHOGI_MASTER_SITE_SUBDIR}
+DISTNAME= ${GNUSHOGI_DISTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= GNU version of Shogi
-DOCFILES= BOOKFILES CHANGES CONTRIB COPYING GENERAL INSTALL PORTING \
- README-FIRST listserv.ref shogi.rules tutorial1.gam tutorial2.gam
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-x --without-xshogi
+
MAN6= gnushogi.6
+INFO= gnushogi
+
+.include "${.CURDIR}/../../games/gnushogi/Makefile.common"
+.include <bsd.port.pre.mk>
+
+post-extract:
+ -@${RM} ${WRKSRC}/doc/gnushogi.info*
-post-configure:
- ${ECHO_CMD} "DISTDIR=${WRKDIR}" >> ${WRKSRC}/src/${MAKEFILE}
- ${ECHO_CMD} "prefix=${PREFIX}" >> ${WRKSRC}/src/${MAKEFILE}
+post-patch:
+ @${REINPLACE_CMD} -e 's|/lib/gnushogi|/share/gnushogi|g' \
+ ${WRKSRC}/gnushogi/Makefile.in
-do-build:
- (cd ${WRKSRC}/src; \
- ${MAKE} gnushogir; \
- ${MAKE} gnushogi.bbk; \
- ${MAKE} gnushogi; \
- ${MAKE} gnushogix )
+pre-build:
+ cd ${WRKSRC}/doc && makeinfo --no-split gnushogi
do-install:
- @${MKDIR} ${PREFIX}/share/gnushogi
- ${INSTALL_PROGRAM} ${WRKSRC}/src/gnushogi ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/src/gnushogir ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/src/gnushogix ${PREFIX}/libexec
- ${INSTALL_DATA} ${WRKSRC}/src/gnushogi.bbk ${PREFIX}/share/gnushogi
- ${INSTALL_MAN} ${WRKSRC}/doc/gnushogi.1 ${PREFIX}/man/man6/gnushogi.6
+ ${INSTALL_PROGRAM} ${WRKSRC}/gnushogi/gnushogi ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/gnushogi.6 ${MANPREFIX}/man/man6
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/gnushogi/gnushogi.bbk ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/gnushogi.info ${PREFIX}/info
+ install-info ${PREFIX}/info/gnushogi.info ${PREFIX}/info/dir
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/gnushogi
-.for doc in ${DOCFILES}
- ${INSTALL_DATA} ${WRKSRC}/doc/${doc} ${PREFIX}/share/doc/gnushogi
-.endfor
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/BOOKFILES ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/PORTING ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.gam ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.ref ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.rules ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/gnushogi/Makefile.common b/games/gnushogi/Makefile.common
new file mode 100644
index 000000000000..ccfa18fff8bb
--- /dev/null
+++ b/games/gnushogi/Makefile.common
@@ -0,0 +1,11 @@
+#
+# $FreeBSD$
+#
+
+GNUSHOGI_PORTNAME= gnushogi
+GNUSHOGI_PORTVERSION= 1.3
+GNUSHOGI_MASTER_SITES= ${MASTER_SITE_GNU}
+GNUSHOGI_MASTER_SITE_SUBDIR= ${PORTNAME}
+GNUSHOGI_DISTNAME= ${GNUSHOGI_PORTNAME}-${GNUSHOGI_PORTVERSION}
+
+MD5_FILE= ${.CURDIR}/../../games/gnushogi/distinfo
diff --git a/games/gnushogi/distinfo b/games/gnushogi/distinfo
index 8ce952987209..14448d1aa087 100644
--- a/games/gnushogi/distinfo
+++ b/games/gnushogi/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnushogi-1.2p03.tar.gz) = 242571d1c9e6c20fff646a0e5b0bca10
-SIZE (gnushogi-1.2p03.tar.gz) = 188078
+MD5 (gnushogi-1.3.tar.gz) = 592e9f3993ed483525b3c1bcd48b1ef9
+SIZE (gnushogi-1.3.tar.gz) = 558642
diff --git a/games/gnushogi/files/patch-aa b/games/gnushogi/files/patch-aa
deleted file mode 100644
index bfcd7cf359d3..000000000000
--- a/games/gnushogi/files/patch-aa
+++ /dev/null
@@ -1,53 +0,0 @@
---- src/Makefile.orig Wed May 24 07:05:26 1995
-+++ src/Makefile Sun Apr 29 21:39:00 2001
-@@ -41,22 +41,22 @@
- DIST= ../README-$(VERS) ../doc ../misc ../src
-
- # Installation directory
--prefix=/usr/local
-+#prefix=/usr/local
- #prefix=/public/projects/shogi
-
- # Change these to something less transitory, like /usr/games, and then
- # compile. Ask your system admin / unix guru to put gnushogi.{hsh,lng,tbk}
- # in $(LIBDIR).
- # Where the binaries live.
--BINDIR= $(prefix)/games
-+BINDIR= $(prefix)/bin
- #BINDIR=/public/projects/shogi/bin
-
- # Where language description, our book, and the persistent hash live.
--LIBDIR= $(prefix)/games/lib/gnushogi
-+LIBDIR= $(prefix)/share/gnushogi
- #LIBDIR=/public/projects/shogi/lib
-
- # Distribution directory
--DISTDIR=/public/projects/shogi
-+#DISTDIR=/public/projects/shogi
-
- # Programs being distributed
- PROGS=gnushogi-$(VERS)
-@@ -76,7 +76,7 @@
- #CC= c89 $(OPT) $(GENOPT)
- # Use this if you are lucky enough to have GNU CC.
- #CC= /usr/pub/bin/gcc -fsigned-char $(OPT) $(GENOPT)
--CC= gcc -W -fsigned-char $(OPT) $(GENOPT)
-+CC+= -W -fsigned-char $(OPT) $(GENOPT)
- #CC= cc $(OPT) $(GENOPT)
-
- # Miscellaneous CFLAGS. Uncomment the one you need and comment the other
-@@ -96,7 +96,8 @@
- #CFLAGS= -O2 -funroll-loops -traditional-cpp -DNO_STRING_INCLUDE -DNOFIONREAD # gnu cc 2.00 (hawk)
- #CFLAGS= -O2 -funroll-loops -DSEVENBIT # djgpp
- #CFLAGS= -g -funroll-loops # gnu cc 2.00 on SunOS with debug
--CFLAGS= -O2 -funroll-loops # gnu cc 2.00 on SunOS
-+#CFLAGS= -O2 -funroll-loops # gnu cc 2.00 on SunOS
-+CFLAGS+=-fno-strength-reduce
-
- # flags for DJGPP package
- #COFF2EXE= coff2exe $(GNUSHOGI)
-@@ -454,3 +455,4 @@
- -rm -f $(DISTDIR)/gnushogi-$(VERS)/src/gnushogi.bbk
- -find $(DISTDIR)/gnushogi-$(VERS) \( -name '*.o' -o -name '*~' -o -name 'CL*' -o -name 'PATCH*' -o -name '#*#' -o -name '%*%' -o -name '*orig' -o -name 'CL*' -o -name '*prt' -o -name '*bak' -o -name '*BAK' \) -exec rm -f {} \;
-
-+DISTDIR=/net/freefall/a/obrien/ports/games/gnushogi/work
diff --git a/games/gnushogi/files/patch-doc::gnushogi.texinfo b/games/gnushogi/files/patch-doc::gnushogi.texinfo
new file mode 100644
index 000000000000..5ff9faa55db1
--- /dev/null
+++ b/games/gnushogi/files/patch-doc::gnushogi.texinfo
@@ -0,0 +1,13 @@
+--- doc/gnushogi.texinfo.orig Sat Apr 27 00:42:22 2002
++++ doc/gnushogi.texinfo Mon Mar 15 20:19:37 2004
+@@ -3,6 +3,10 @@
+ @c % ** Start of header.
+ @setfilename gnushogi.info
+ @settitle GNU Shogi manual
++@dircategory
++@direntry Games
++* GNUShogi: (gnushogi). GNU Shogi.
++@end direntry
+ @c % ** End of header.
+
+ @setchapternewpage odd
diff --git a/games/gnushogi/pkg-plist b/games/gnushogi/pkg-plist
index 40baf83f8cf5..a4ed6baf86e1 100644
--- a/games/gnushogi/pkg-plist
+++ b/games/gnushogi/pkg-plist
@@ -1,18 +1,34 @@
bin/gnushogi
-bin/gnushogir
-libexec/gnushogix
-share/doc/gnushogi/BOOKFILES
-share/doc/gnushogi/CHANGES
-share/doc/gnushogi/CONTRIB
-share/doc/gnushogi/COPYING
-share/doc/gnushogi/GENERAL
-share/doc/gnushogi/INSTALL
-share/doc/gnushogi/PORTING
-share/doc/gnushogi/README-FIRST
-share/doc/gnushogi/listserv.ref
-share/doc/gnushogi/shogi.rules
-share/doc/gnushogi/tutorial1.gam
-share/doc/gnushogi/tutorial2.gam
-share/gnushogi/gnushogi.bbk
-@dirrm share/doc/gnushogi
-@dirrm share/gnushogi
+%%PORTDOCS%%%%DOCSDIR%%/BOOKFILES
+%%PORTDOCS%%%%DOCSDIR%%/PORTING
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_1.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_10.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_11.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_12.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_13.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_14.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_15.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_16.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_17.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_18.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_19.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_2.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_20.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_21.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_22.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_3.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_4.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_5.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_6.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_7.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_8.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_9.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_stoc.html
+%%PORTDOCS%%%%DOCSDIR%%/gnushogi_toc.html
+%%PORTDOCS%%%%DOCSDIR%%/listserv.ref
+%%PORTDOCS%%%%DOCSDIR%%/shogi.rules
+%%PORTDOCS%%%%DOCSDIR%%/tutorial1.gam
+%%PORTDOCS%%%%DOCSDIR%%/tutorial2.gam
+%%DATADIR%%/gnushogi.bbk
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%