aboutsummaryrefslogtreecommitdiff
path: root/games/gomoku
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-08-06 06:05:44 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-08-06 06:05:44 +0000
commitdc4e7a2e62b31ddbb1919569554a034d3b61512e (patch)
tree9ad27927be812228f4a4a84a566cc9bfcf93954f /games/gomoku
parentc07f18f52f0bc5716378f165f44baefa33765f6f (diff)
downloadports-dc4e7a2e62b31ddbb1919569554a034d3b61512e.tar.gz
ports-dc4e7a2e62b31ddbb1919569554a034d3b61512e.zip
Notes
Diffstat (limited to 'games/gomoku')
-rw-r--r--games/gomoku/Makefile24
-rw-r--r--games/gomoku/distinfo2
-rw-r--r--games/gomoku/pkg-descr17
-rw-r--r--games/gomoku/pkg-plist53
4 files changed, 96 insertions, 0 deletions
diff --git a/games/gomoku/Makefile b/games/gomoku/Makefile
new file mode 100644
index 000000000000..4b47bf5485c0
--- /dev/null
+++ b/games/gomoku/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Gomoku
+# Date created: 19 Sep 2000
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gomoku
+PORTVERSION= 1.2.9
+CATEGORIES= games gnustep
+MASTER_SITES= http://www.gnustep.it/nicola/Applications/Gomoku/
+DISTNAME= Gomoku-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= GNUstep Gomoku game
+
+LICENSE= GPLv2
+
+USE_GNUSTEP= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+
+.include <bsd.port.mk>
diff --git a/games/gomoku/distinfo b/games/gomoku/distinfo
new file mode 100644
index 000000000000..be786136b97d
--- /dev/null
+++ b/games/gomoku/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Gomoku-1.2.9.tar.gz) = 1d3680559747deb7fbf35dc67d08e99e979961f146676cca1259a7e25185c5a2
+SIZE (Gomoku-1.2.9.tar.gz) = 88825
diff --git a/games/gomoku/pkg-descr b/games/gomoku/pkg-descr
new file mode 100644
index 000000000000..9d750dbfb74f
--- /dev/null
+++ b/games/gomoku/pkg-descr
@@ -0,0 +1,17 @@
+Gomoku.app is an extended TicTacToe game for GNUstep.
+You win the game if you are able to put 5 of your pieces
+in a row, column or diagonal. You loose if the computer
+does it before you. You can play the game on boards of different
+size; the default size is 8 but 10 is also nice to play.
+Pass the size of the board as argument of Gomoku.app. For example, to
+play on a 10x10 board, you can start Gomoku with:
+
+openapp Gomoku.app 10
+
+Warning: board size must be >= 8.
+
+BUGS: Please mail them to <n.pero@mi.flashnet.it>
+
+LICENSE: GPL2 or later
+
+WWW: http://www.gnustep.it/nicola/Applications/Gomoku/
diff --git a/games/gomoku/pkg-plist b/games/gomoku/pkg-plist
new file mode 100644
index 000000000000..a9c815f59203
--- /dev/null
+++ b/games/gomoku/pkg-plist
@@ -0,0 +1,53 @@
+GNUstep/Local/Applications/Gomoku.app/Gomoku
+GNUstep/Local/Applications/Gomoku.app/Resources/Computer.png
+GNUstep/Local/Applications/Gomoku.app/Resources/ComputerBottom.png
+GNUstep/Local/Applications/Gomoku.app/Resources/ComputerBottomLeft.png
+GNUstep/Local/Applications/Gomoku.app/Resources/ComputerBottomRight.png
+GNUstep/Local/Applications/Gomoku.app/Resources/ComputerLeft.png
+GNUstep/Local/Applications/Gomoku.app/Resources/ComputerRight.png
+GNUstep/Local/Applications/Gomoku.app/Resources/ComputerTop.png
+GNUstep/Local/Applications/Gomoku.app/Resources/ComputerTopLeft.png
+GNUstep/Local/Applications/Gomoku.app/Resources/ComputerTopRight.png
+GNUstep/Local/Applications/Gomoku.app/Resources/Empty.png
+GNUstep/Local/Applications/Gomoku.app/Resources/EmptyBottom.png
+GNUstep/Local/Applications/Gomoku.app/Resources/EmptyBottomLeft.png
+GNUstep/Local/Applications/Gomoku.app/Resources/EmptyBottomRight.png
+GNUstep/Local/Applications/Gomoku.app/Resources/EmptyLeft.png
+GNUstep/Local/Applications/Gomoku.app/Resources/EmptyRight.png
+GNUstep/Local/Applications/Gomoku.app/Resources/EmptyTop.png
+GNUstep/Local/Applications/Gomoku.app/Resources/EmptyTopLeft.png
+GNUstep/Local/Applications/Gomoku.app/Resources/EmptyTopRight.png
+GNUstep/Local/Applications/Gomoku.app/Resources/English.lproj/Localizable.strings
+GNUstep/Local/Applications/Gomoku.app/Resources/French.lproj/Localizable.strings
+GNUstep/Local/Applications/Gomoku.app/Resources/German.lproj/Localizable.strings
+GNUstep/Local/Applications/Gomoku.app/Resources/Gomoku.desktop
+GNUstep/Local/Applications/Gomoku.app/Resources/Gomoku.png
+GNUstep/Local/Applications/Gomoku.app/Resources/Human.png
+GNUstep/Local/Applications/Gomoku.app/Resources/HumanBottom.png
+GNUstep/Local/Applications/Gomoku.app/Resources/HumanBottomLeft.png
+GNUstep/Local/Applications/Gomoku.app/Resources/HumanBottomRight.png
+GNUstep/Local/Applications/Gomoku.app/Resources/HumanLeft.png
+GNUstep/Local/Applications/Gomoku.app/Resources/HumanRight.png
+GNUstep/Local/Applications/Gomoku.app/Resources/HumanTop.png
+GNUstep/Local/Applications/Gomoku.app/Resources/HumanTopLeft.png
+GNUstep/Local/Applications/Gomoku.app/Resources/HumanTopRight.png
+GNUstep/Local/Applications/Gomoku.app/Resources/Hungarian.lproj/Localizable.strings
+GNUstep/Local/Applications/Gomoku.app/Resources/Info-gnustep.plist
+GNUstep/Local/Applications/Gomoku.app/Resources/Italian.lproj/Localizable.strings
+GNUstep/Local/Applications/Gomoku.app/Resources/Norwegian.lproj/Localizable.strings
+GNUstep/Local/Applications/Gomoku.app/Resources/Spanish.lproj/Localizable.strings
+GNUstep/Local/Applications/Gomoku.app/Resources/Swedish.lproj/Localizable.strings
+GNUstep/Local/Applications/Gomoku.app/Resources/TraditionalChinese.lproj/Localizable.strings
+GNUstep/Local/Applications/Gomoku.app/stamp.make
+GNUstep/Local/Tools/Gomoku
+@dirrm GNUstep/Local/Applications/Gomoku.app/Resources/TraditionalChinese.lproj
+@dirrm GNUstep/Local/Applications/Gomoku.app/Resources/Swedish.lproj
+@dirrm GNUstep/Local/Applications/Gomoku.app/Resources/Spanish.lproj
+@dirrm GNUstep/Local/Applications/Gomoku.app/Resources/Norwegian.lproj
+@dirrm GNUstep/Local/Applications/Gomoku.app/Resources/Italian.lproj
+@dirrm GNUstep/Local/Applications/Gomoku.app/Resources/Hungarian.lproj
+@dirrm GNUstep/Local/Applications/Gomoku.app/Resources/German.lproj
+@dirrm GNUstep/Local/Applications/Gomoku.app/Resources/French.lproj
+@dirrm GNUstep/Local/Applications/Gomoku.app/Resources/English.lproj
+@dirrm GNUstep/Local/Applications/Gomoku.app/Resources
+@dirrm GNUstep/Local/Applications/Gomoku.app