aboutsummaryrefslogtreecommitdiff
path: root/games/gracer
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2013-09-27 16:36:58 +0000
committerJuergen Lock <nox@FreeBSD.org>2013-09-27 16:36:58 +0000
commitde0c514e7c7d82df4aa7cbb234faa74a921b6376 (patch)
tree903987cc192a2b20bd137fd5850ee3d1e2790858 /games/gracer
parent724db15514e45517d8f30ed3d308694d5fd95bd4 (diff)
Notes
Diffstat (limited to 'games/gracer')
-rw-r--r--games/gracer/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/games/gracer/Makefile b/games/gracer/Makefile
index 392ae618ef0f..944908081a84 100644
--- a/games/gracer/Makefile
+++ b/games/gracer/Makefile
@@ -3,28 +3,25 @@
PORTNAME= gracer
PORTVERSION= 0.1.5
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= games
MASTER_SITES= SF
MAINTAINER= nox@FreeBSD.org
-COMMENT= A 3D motor sport simulator
+COMMENT= 3D motor sport simulator
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
-LIB_DEPENDS= gif.5:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif:${PORTSDIR}/graphics/giflib \
png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- tcl84.1:${PORTSDIR}/lang/tcl84
+ jpeg:${PORTSDIR}/graphics/jpeg
USE_GL= glut
-USES= perl5
+USES= gmake perl5 tcl:84
USE_PERL5= build
USE_AUTOTOOLS= autoconf213
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
- CPPFLAGS="${CPPFLAGS}"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include \
- -I${LOCALBASE}/include/tcl8.4
-USE_GMAKE= yes
+ -I${TCL_INCLUDEDIR}
NO_STAGE= yes
# for plib (sound):
CONFIGURE_ARGS+= --with-plib=${LOCALBASE}/plib