aboutsummaryrefslogtreecommitdiff
path: root/games/gti
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2013-05-14 13:31:42 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2013-05-14 13:31:42 +0000
commitce0b06fd98a199085288318e1bc61ad5200086d3 (patch)
tree93e9968bc6c134c8bbb8c098a11a4b364e221310 /games/gti
parentfc91a4724e4a5694db74b05f89ac22d6a06f4525 (diff)
downloadports-ce0b06fd98a199085288318e1bc61ad5200086d3.tar.gz
ports-ce0b06fd98a199085288318e1bc61ad5200086d3.zip
Notes
Diffstat (limited to 'games/gti')
-rw-r--r--games/gti/Makefile22
-rw-r--r--games/gti/distinfo4
-rw-r--r--games/gti/pkg-descr2
3 files changed, 17 insertions, 11 deletions
diff --git a/games/gti/Makefile b/games/gti/Makefile
index 5e2eea7f94dd..68765f1259cc 100644
--- a/games/gti/Makefile
+++ b/games/gti/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: gti
-# Date created: 2012-08-16
-# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
-#
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gti
-PORTVERSION= 1.0.4
+PORTVERSION= 1.1.0
CATEGORIES= games
MAINTAINER= tota@FreeBSD.org
@@ -15,16 +11,26 @@ COMMENT= Just a silly git launcher, basically. Inspired by sl
USE_GITHUB= yes
GH_ACCOUNT= rwos
GH_TAGNAME= v${PORTVERSION}
-GH_COMMIT= e16ca0b
+GH_COMMIT= 5afb520
-ALL_TARGET= ${PORTNAME}
+MAN6= ${PORTNAME}.6
PLIST_FILES= bin/${PORTNAME}
+GTI_SPEED?= 50
+CFLAGS+= -DGTI_SPEED=${GTI_SPEED}
+
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} " You can change the speed of the car at compile time."
+ @${ECHO_MSG} " For example: \"make GTI_SPEED=100\" # default is 50"
+ @${ECHO_MSG}
+
do-build:
@${CC} ${CFLAGS} -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.c
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${MAN6} ${MANPREFIX}/man/man6
.include <bsd.port.mk>
diff --git a/games/gti/distinfo b/games/gti/distinfo
index 44d650faa4e5..d6906c56aa99 100644
--- a/games/gti/distinfo
+++ b/games/gti/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gti-1.0.4.tar.gz) = 72fdc62d1977052567944d709e31ac41bfdf7a179a3ac6a71a8e1c67ff2102ed
-SIZE (gti-1.0.4.tar.gz) = 1617
+SHA256 (gti-1.1.0.tar.gz) = 6cfb137dc9cedcf54202182d424ed394ed55c93c0109d4464a0d4fcf81b0050b
+SIZE (gti-1.1.0.tar.gz) = 2454
diff --git a/games/gti/pkg-descr b/games/gti/pkg-descr
index db992e6f4232..0a1b1b9390e1 100644
--- a/games/gti/pkg-descr
+++ b/games/gti/pkg-descr
@@ -10,4 +10,4 @@ This whole thing is heavily inspired by sl, which displays a steam
locomotive. However, gti is actually nicer than sl as it at least
executes git after the animation. :-)
-WWW: http://r-wos.org/hacks/gti
+WWW: http://r-wos.org/hacks/gti