aboutsummaryrefslogtreecommitdiff
path: root/games/gtkradiant
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/gtkradiant
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'games/gtkradiant')
-rw-r--r--games/gtkradiant/Makefile7
-rw-r--r--games/gtkradiant/files/patch-plugins__imagepng__plugin.cpp41
-rw-r--r--games/gtkradiant/files/patch-tools__quake3__q3map2__image.c19
3 files changed, 62 insertions, 5 deletions
diff --git a/games/gtkradiant/Makefile b/games/gtkradiant/Makefile
index 09f26805dd1c..abee847cc3a9 100644
--- a/games/gtkradiant/Makefile
+++ b/games/gtkradiant/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gtkradiant
PORTVERSION= 1.5.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_IDSOFTWARE:S|$|source/:id|} \
http://www.bsd-geek.de/FreeBSD/distfiles/:fb
@@ -23,7 +23,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/libsvn/__init__.py:${PORTSDIR}/devel/py-subversion
LIB_DEPENDS= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext \
mhash.2:${PORTSDIR}/security/mhash \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/GPL/GtkRadiant
@@ -38,9 +38,6 @@ DATADIR= ${PREFIX}/lib/${PORTNAME}
post-patch:
@${REINPLACE_CMD} -e 's/-ldl//' ${WRKSRC}/SConscript
- @${REINPLACE_CMD} -e 's/png_infopp_NULL/NULL/' \
- -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
- ${WRKSRC}/plugins/imagepng/plugin.cpp
@${GREP} -Rl 'defined[[:blank:]]*([[:blank:]]*__linux__[[:blank:]]*) || defined[[:blank:]]*([[:blank:]]*__APPLE__[[:blank:]]*)' ${WRKSRC} | \
${XARGS} ${REINPLACE_CMD} -e \
's/\(defined[[:blank:]]*([[:blank:]]*__linux__[[:blank:]]*) || defined[[:blank:]]*([[:blank:]]*__APPLE__[[:blank:]]*)\)/\1 || defined (__FreeBSD__)/'
diff --git a/games/gtkradiant/files/patch-plugins__imagepng__plugin.cpp b/games/gtkradiant/files/patch-plugins__imagepng__plugin.cpp
new file mode 100644
index 000000000000..c06c1abd68ea
--- /dev/null
+++ b/games/gtkradiant/files/patch-plugins__imagepng__plugin.cpp
@@ -0,0 +1,41 @@
+--- plugins/imagepng/plugin.cpp.orig 2006-02-10 23:01:20.000000000 +0100
++++ plugins/imagepng/plugin.cpp 2012-05-26 20:07:52.000000000 +0200
+@@ -41,7 +41,7 @@
+ void user_error_fn(png_structp png_ptr, png_const_charp error_msg)
+ {
+ globalErrorStream() << "libpng error: " << error_msg << "\n";
+- longjmp(png_ptr->jmpbuf, 0);
++ longjmp(png_jmpbuf(png_ptr), 0);
+ }
+
+ void user_read_data(png_structp png_ptr, png_bytep data, png_uint_32 length)
+@@ -87,9 +87,9 @@
+ }
+
+ // configure the read function
+- png_set_read_fn(png_ptr, (voidp)&p_fbuffer, (png_rw_ptr)&user_read_data);
++ png_set_read_fn(png_ptr, &p_fbuffer, (png_rw_ptr)&user_read_data);
+
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ png_destroy_read_struct(&png_ptr, &info_ptr,
+ &end_info);
+ return 0;
+@@ -108,7 +108,7 @@
+ png_set_palette_to_rgb(png_ptr);
+
+ if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+
+ if (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS))
+ png_set_tRNS_to_alpha(png_ptr);
+@@ -153,7 +153,7 @@
+ png_read_end(png_ptr, info_ptr);
+
+ /* free up the memory structure */
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+
+ free(row_pointers);
+
diff --git a/games/gtkradiant/files/patch-tools__quake3__q3map2__image.c b/games/gtkradiant/files/patch-tools__quake3__q3map2__image.c
new file mode 100644
index 000000000000..4b5d3d74507f
--- /dev/null
+++ b/games/gtkradiant/files/patch-tools__quake3__q3map2__image.c
@@ -0,0 +1,19 @@
+--- tools/quake3/q3map2/image.c.orig 2006-02-10 23:01:20.000000000 +0100
++++ tools/quake3/q3map2/image.c 2012-05-26 20:56:51.000000000 +0200
+@@ -35,6 +35,7 @@
+
+ /* dependencies */
+ #include "q3map2.h"
++#include "pngpriv.h"
+
+
+
+@@ -180,7 +181,7 @@
+ png->io_ptr = &pb; /* hack! */
+
+ /* set error longjmp */
+- if( setjmp( png->jmpbuf ) )
++ if( setjmp( png_jmpbuf(png) ) )
+ {
+ Sys_Printf( "WARNING: An error occurred reading PNG image\n" );
+ png_destroy_read_struct( &png, &info, &end );