aboutsummaryrefslogtreecommitdiff
path: root/games/gunfudeadlands
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-12-22 23:38:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-12-22 23:38:29 +0000
commit1486d6faa23e5edec693eef8e2843601b2b623db (patch)
tree67d06ccc1894799dd749ee939ec6f379c6f31977 /games/gunfudeadlands
parent4f93fed1c9c0bdbefdad194c4c524c28eb3689d1 (diff)
downloadports-1486d6faa23e5edec693eef8e2843601b2b623db.tar.gz
ports-1486d6faa23e5edec693eef8e2843601b2b623db.zip
Notes
Diffstat (limited to 'games/gunfudeadlands')
-rw-r--r--games/gunfudeadlands/Makefile40
-rw-r--r--games/gunfudeadlands/distinfo3
-rw-r--r--games/gunfudeadlands/files/gunfudeadlands.in3
-rw-r--r--games/gunfudeadlands/pkg-descr4
4 files changed, 50 insertions, 0 deletions
diff --git a/games/gunfudeadlands/Makefile b/games/gunfudeadlands/Makefile
new file mode 100644
index 000000000000..40940b0f4eca
--- /dev/null
+++ b/games/gunfudeadlands/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: gunfudeadlands
+# Date created: 21 Dec 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gunfudeadlands
+PORTVERSION= 1.00
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/GunFu%20Deadlands%20${PORTVERSION}/
+DISTNAME= GunFuDeadlands_${PORTVERSION:C/\.//}_src
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Far West themed 2D shooter featuring bullet time
+
+RUN_DEPENDS= love:${PORTSDIR}/games/love
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+SUB_FILES= gunfudeadlands
+
+PLIST_FILES= bin/gunfudeadlands \
+ %%DATADIR%%/GunFuDeadlands.zip
+PLIST_DIRS= %%DATADIR%%
+
+PORTDOCS= *
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} \
+ ${DATADIR}/GunFuDeadlands.zip
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/readme.txt ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/gunfudeadlands/distinfo b/games/gunfudeadlands/distinfo
new file mode 100644
index 000000000000..23089fcc6a97
--- /dev/null
+++ b/games/gunfudeadlands/distinfo
@@ -0,0 +1,3 @@
+MD5 (GunFuDeadlands_100_src.zip) = f49a1f959f2e32365b1dc437fbfd00ec
+SHA256 (GunFuDeadlands_100_src.zip) = f59feef34ac7deb6e0d3be600df8a44e17c305dcf9199531dc8b094b48a02911
+SIZE (GunFuDeadlands_100_src.zip) = 6189772
diff --git a/games/gunfudeadlands/files/gunfudeadlands.in b/games/gunfudeadlands/files/gunfudeadlands.in
new file mode 100644
index 000000000000..ac5779fc047a
--- /dev/null
+++ b/games/gunfudeadlands/files/gunfudeadlands.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec %%LOCALBASE%%/bin/love %%DATADIR%%/GunFuDeadlands.zip "$@"
diff --git a/games/gunfudeadlands/pkg-descr b/games/gunfudeadlands/pkg-descr
new file mode 100644
index 000000000000..75959d0de46d
--- /dev/null
+++ b/games/gunfudeadlands/pkg-descr
@@ -0,0 +1,4 @@
+GunFu Deadlands is a Far West themed 2D action shooter featuring
+bullet time a la Max Payne and the Matrix movies.
+
+WWW: http://gunfudeadlands.sourceforge.net/