aboutsummaryrefslogtreecommitdiff
path: root/games/halflifeserver/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-04-27 03:12:47 +0000
committerPatrick Li <pat@FreeBSD.org>2002-04-27 03:12:47 +0000
commitc97b1eec192bca6d54da1d62bcf430267f367656 (patch)
tree37db02d96973092434b4b267fc68e8bc32b54a3c /games/halflifeserver/Makefile
parent056a95abe868bf042aa1418d4bccfa5d0f43563d (diff)
downloadports-c97b1eec192bca6d54da1d62bcf430267f367656.tar.gz
ports-c97b1eec192bca6d54da1d62bcf430267f367656.zip
Notes
Diffstat (limited to 'games/halflifeserver/Makefile')
-rw-r--r--games/halflifeserver/Makefile64
1 files changed, 14 insertions, 50 deletions
diff --git a/games/halflifeserver/Makefile b/games/halflifeserver/Makefile
index abe119a6b8d5..a31ace90e145 100644
--- a/games/halflifeserver/Makefile
+++ b/games/halflifeserver/Makefile
@@ -6,16 +6,9 @@
#
PORTNAME= hlds
-PORTVERSION= 3.1.0.8.0a
-PORTREVISION= 1
+PORTVERSION= 3.1.0.9
CATEGORIES= games linux
-MASTER_SITES= http://www.carnage.q-net.net.au/downloads/server/halflife/linux/ \
- http://carnage.q-net.net.au/~carnage/server/halflife/linux/ \
- http://www.redphive.org/files/ \
- ftp://ftp.splatterworld.de/hl/official/server/ \
- http://files.ausgamers.com:81/half-life/linux/
-DISTFILES= hlds_l_3108_full.tar.gz \
- hlds_l_3108a_up.tar.gz
+DISTNAME= hlds_l_3109_full
MAINTAINER= pat@FreeBSD.org
@@ -24,7 +17,6 @@ USE_LINUX_PREFIX= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
WRKSRC= ${WRKDIR}/hlds_l
-STRIP=
PLIST_SUB= ${PLIST_SUB_FOR_THIS_PORT}
PLIST_SUB_FOR_THIS_PORT= HLDSDIR="${HLDSDIR:S/^\///}" LDCONFIG="${LDCONFIG_LINUX}"
@@ -32,43 +24,19 @@ INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
HLDSDIR= /usr/games/hlds_l/
-HL_PROGRAM= hlds_run
SORT?= /usr/bin/sort
# files which should be installed with executables perms
-EXECUTABLES= ${HL_PROGRAM} hltv
-
-.ifdef(WITH_PING_BOOSTER)
-MASTER_SITES+= http://www.udpsoft.com/booster/
-DISTFILES+= HLDSPingBooster-0.99.tar.gz
-
-BOOSTER_FILES= booster.so hlds_boost
-EXECUTABLES+= hlds_boost
-
-PLIST_SUB+= BOOSTER=""
-.else
-PLIST_SUB+= BOOSTER="@comment "
-.endif
-
-pre-everything::
-.ifndef(WITH_PING_BOOSTER)
- @${ECHO_MSG} '===>'
- @${ECHO_MSG} '===> Define WITH_PING_BOOSTER to enable HLDS Ping Booster.'
- @${ECHO_MSG} '===>'
- @${ECHO_MSG} '===> HLDS Ping Booster is a small tweak to the Half-Life Dedicated'
- @${ECHO_MSG} '===> Server that drastically reduces player pings and generally'
- @${ECHO_MSG} '===> makes the game much more responsive.'
- @${ECHO_MSG} '===> Besides defining this, instead of using hlds_run to start the'
- @${ECHO_MSG} '===> server, use hlds_boost. Clients do not have to install anything.'
- @${ECHO_MSG} '===> Check http://www.udpsoft.com/booster/ for additional information.'
- @${ECHO_MSG} '===>'
-.endif
-
-post-extract:
-.ifdef(WITH_PING_BOOSTER)
-.for file in ${BOOSTER_FILES}
- @${CP} ${WRKDIR}/${file} ${WRKSRC}
-.endfor
+EXECUTABLES= hltv hlds hlds_run libSteamValidateUserIDTickets.so \
+ libhlwon.so
+
+.include <bsd.port.pre.mk>
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= "Please download and execute ${DISTNAME}.bin to read valve\'s \
+ agreement and if you agree to the terms, then it will dump the \
+ tarball ${DISTNAME}${EXTRACT_SUFX} to your current directory. \
+ Finally, move ${DISTNAME}${EXTRACT_SUFX} to ${DISTDIR} and run \
+ make again"
.endif
pre-patch:
@@ -76,10 +44,6 @@ pre-patch:
@${FIND} -E ${WRKSRC} -type f \
-iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|lst|sc|scr|txt|rc)" \
-exec ${PERL} -pi -ne 's!\r\n!\n!' {} 1>/dev/null 2>&1 \;
-.ifdef(WITH_PING_BOOSTER)
- @${PERL} -pi -e 's|booster.so|${PREFIX}${HLDSDIR}booster.so|' \
- ${WRKSRC}/hlds_boost
-.endif
do-install: install-parse-plist install-run-scripts scan-libs
@@ -105,7 +69,7 @@ install-parse-plist: generate-plist
-e '}' \
-e '}' \
-e 'print FFILES ($$program_flag == 0) ? \
- "${INSTALL_DATA}" : "${INSTALL_PROGRAM}";' \
+ "${INSTALL_DATA:S/${SHAREMODE}/400/}" : "${INSTALL_SCRIPT:S/${BINMODE}/500/}";' \
-e 'print FFILES " ", "\"${WRKSRC}/$$file_partial\"", \
" ", "\"${PREFIX}/$$file\"", \
"\n";' \
@@ -131,4 +95,4 @@ scan-libs:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>