aboutsummaryrefslogtreecommitdiff
path: root/games/heretic/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-04-03 04:42:36 +0000
committerWill Andrews <will@FreeBSD.org>2000-04-03 04:42:36 +0000
commitab65eb212b8fffa641ac93f74f31c76f4a6a9e58 (patch)
tree2ee4a503164b1c7e7613e1f424f80fbcfebd2b6d /games/heretic/Makefile
parente87c8ad2dd283fe4ff316b2ec231ea698b1febb1 (diff)
downloadports-ab65eb212b8fffa641ac93f74f31c76f4a6a9e58.tar.gz
ports-ab65eb212b8fffa641ac93f74f31c76f4a6a9e58.zip
Notes
Diffstat (limited to 'games/heretic/Makefile')
-rw-r--r--games/heretic/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/games/heretic/Makefile b/games/heretic/Makefile
index 9481e9521c57..e0e5f2c63a03 100644
--- a/games/heretic/Makefile
+++ b/games/heretic/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= games
MASTER_SITES= http://www.raven-games.com/linuxheretic/heretic/src/ \
http://www.raven-games.com/linuxheretic/wad/
.if !defined(NO_WAD)
-DISTFILES+= heretic_share.wad.gz
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} heretic_share.wad.gz
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
.endif
@@ -21,12 +21,16 @@ MAINTAINER= will@FreeBSD.org
FETCH_BEFORE_ARGS+= -b
USE_X_PREFIX= yes
USE_GMAKE= yes
-ALL_TARGET= fastx11
MAKE_ENV= WANT_OGL="no" WANT_OGL_FULLSCREEN="no" WANT_NICE_OGL="no"
-BINARY= xaheretic
.if !defined(NO_WAD)
PLIST= ${PKGDIR}/PLIST.nowad
.endif
+ALL_TARGET= x11
+BINARY= xheretic
+.if defined(WANT_FASTX11)
+BINARY= xaheretic
+ALL_TARGET= fastx11
+.endif
do-install:
@${MKDIR} ${PREFIX}/share/heretic