aboutsummaryrefslogtreecommitdiff
path: root/games/heretic
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-30 04:55:45 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-30 04:55:45 +0000
commitcbc83e23f7f1beee0bcfba6b73121a6fa58d6f21 (patch)
tree55871af2ac934a369a1d366f857e11cac5e6c79b /games/heretic
parent03a5194a3b41273d10a8c7ac1d77170edf837553 (diff)
downloadports-cbc83e23f7f1beee0bcfba6b73121a6fa58d6f21.tar.gz
ports-cbc83e23f7f1beee0bcfba6b73121a6fa58d6f21.zip
Notes
Diffstat (limited to 'games/heretic')
-rw-r--r--games/heretic/Makefile3
-rw-r--r--games/heretic/files/patch-aa9
2 files changed, 7 insertions, 5 deletions
diff --git a/games/heretic/Makefile b/games/heretic/Makefile
index 0dee74e51641..e71b7595db2f 100644
--- a/games/heretic/Makefile
+++ b/games/heretic/Makefile
@@ -7,6 +7,7 @@
PORTNAME= heretic
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://heretic.linuxgames.com/heretic/src/ \
http://heretic.linuxgames.com/wad/
@@ -34,7 +35,7 @@ BINARY= xaheretic
ALL_TARGET= sdl
BINARY= sdlheretic
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
-LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl10
+LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12
MAKE_ENV+= SDL_CONFIG="${SDL_CONFIG}"
CFLAGS+= `${SDL_CONFIG} --cflags`
.endif
diff --git a/games/heretic/files/patch-aa b/games/heretic/files/patch-aa
index b4c475f130d0..a15e20fb9935 100644
--- a/games/heretic/files/patch-aa
+++ b/games/heretic/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.orig Tue May 2 03:57:07 2000
-+++ Makefile Thu Jan 10 19:33:45 2002
+--- Makefile.orig Mon May 1 22:56:45 2000
++++ Makefile Fri Aug 30 01:43:32 2002
@@ -1,19 +1,19 @@
# Makefile for Linux Heretic/GLHeretic
@@ -71,11 +71,12 @@
+X_LDFLAGS = -L${X11BASE}/lib
X11LIBS = -lXext -lX11
- GLLIBS = -lSDL -lpthread
+-GLLIBS = -lSDL -lpthread
++GLLIBS = `${SDL_CONFIG} --libs` ${PTHREAD_LIBS}
GGILIBS = -lggi -lm
VGALIBS = -lvga
-SDLLIBS = -lSDL -lpthread
-+SDLLIBS = -L${LOCALBASE}/lib -lSDL ${PTHREAD_LIBS}
++SDLLIBS = `${SDL_CONFIG} --libs` ${PTHREAD_LIBS}
OBJS = am_map.o ct_chat.o d_main.o d_net.o f_finale.o g_game.o \
p_ceilng.o p_doors.o p_enemy.o p_floor.o p_inter.o p_lights.o \