aboutsummaryrefslogtreecommitdiff
path: root/games/hex-a-hop
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2010-09-02 11:12:06 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2010-09-02 11:12:06 +0000
commitf992430347c4e7ff5da21d649658ae6d363436ef (patch)
treece071e25b703aeadd3b36dd155bcd35b66a04c5e /games/hex-a-hop
parentb60256e3a9907712a7b57626f93a7d225b87dd5a (diff)
downloadports-f992430347c4e7ff5da21d649658ae6d363436ef.tar.gz
ports-f992430347c4e7ff5da21d649658ae6d363436ef.zip
Notes
Diffstat (limited to 'games/hex-a-hop')
-rw-r--r--games/hex-a-hop/Makefile57
-rw-r--r--games/hex-a-hop/distinfo6
-rw-r--r--games/hex-a-hop/files/patch-Makefile.FreeBSD19
-rw-r--r--games/hex-a-hop/files/patch-hex_puzzzle.cpp11
-rw-r--r--games/hex-a-hop/files/patch-menus.h11
-rw-r--r--games/hex-a-hop/files/patch-src-i18n.h10
-rw-r--r--games/hex-a-hop/files/patch-src-system-relative.c20
-rw-r--r--games/hex-a-hop/files/patch-src-text.cpp11
-rw-r--r--games/hex-a-hop/files/patch-state.h11
-rw-r--r--games/hex-a-hop/pkg-descr3
-rw-r--r--games/hex-a-hop/pkg-plist41
11 files changed, 118 insertions, 82 deletions
diff --git a/games/hex-a-hop/Makefile b/games/hex-a-hop/Makefile
index b5497535d931..738b40aabcb1 100644
--- a/games/hex-a-hop/Makefile
+++ b/games/hex-a-hop/Makefile
@@ -6,29 +6,56 @@
#
PORTNAME= hex-a-hop
-PORTVERSION= 1.0.0
-PORTREVISION= 4
+PORTVERSION= 1.1.0
CATEGORIES= games
-MASTER_SITES= http://ftp.bishopston.net/freebsd/distfiles/ \
- ftp://ftp.bishopston.net/freebsd/distfiles/ \
- http://critical.ch/distfiles/
+MASTER_SITES= SF/${PORTNAME:S/-//g}/${PORTNAME}/${PORTVERSION}
MAINTAINER= jamie@bishopston.net
COMMENT= A puzzle game based on hexagonal tiles
USE_SDL= sdl
-MAKEFILE= Makefile.FreeBSD
-ALL_TARGET= ${PORTNAME}
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+OPTIONS= PANGO "Use sdl_pango instead of sdl_ttf" off \
+ SOUND "Compile sound support" on
-MAKE_ARGS+= SYSTEM_INSTALL_DIR="${DATADIR}/"
DESKTOP_ENTRIES="Hex-a-Hop" "A puzzle game based on hexagonal tiles" \
- "${DATADIR}/graphics/icon.bmp" \
+ "${DATADIR}/icon.bmp" \
"hex-a-hop" "Application;LogicGame;Game;" false
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hex-a-hop ${PREFIX}/bin
- ${MKDIR} ${DATADIR}/graphics
- ${INSTALL_DATA} ${WRKSRC}/graphics/* ${DATADIR}/graphics/
- ${INSTALL_DATA} ${WRKSRC}/levels.dat ${DATADIR}/
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ENV+= ac_cv_header_libintl_h=yes
+LDFLAGS+= -lintl
+.else
+CONFIGURE_ENV+= ac_cv_header_libintl_h=no
+.endif
+
+.if !defined(WITHOUT_PANGO)
+USE_SDL+= pango
+CONFIGURE_ARGS+=--disable-sdlttf
+.else
+USE_SDL+= ttf
+.endif
+
+.if !defined(WITHOUT_SOUND)
+USE_SDL+= mixer
+.else
+CONFIGURE_ARGS+=--disable-sound
+.endif
+
+post-patch: .SILENT
+ ${REINPLACE_CMD} -E '/CFLAGS|CXXFLAGS/s/-g//' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/hex-a-hop/distinfo b/games/hex-a-hop/distinfo
index 565e3a1c2f7b..c6511a18b346 100644
--- a/games/hex-a-hop/distinfo
+++ b/games/hex-a-hop/distinfo
@@ -1,3 +1,3 @@
-MD5 (hex-a-hop-1.0.0.tar.gz) = 0f8623f061eee8508d8ca78d86ed15e2
-SHA256 (hex-a-hop-1.0.0.tar.gz) = 200b2b88133f532419398224d29d72ca394168fbc7646b7ce50985867ac275a7
-SIZE (hex-a-hop-1.0.0.tar.gz) = 883536
+MD5 (hex-a-hop-1.1.0.tar.gz) = cc8d065c2cc0fce9e08852b8c465175e
+SHA256 (hex-a-hop-1.1.0.tar.gz) = 80bf19d936a8430cab5bc468ee6827c38052e026c609eb7ece16317e7932a0d6
+SIZE (hex-a-hop-1.1.0.tar.gz) = 9249269
diff --git a/games/hex-a-hop/files/patch-Makefile.FreeBSD b/games/hex-a-hop/files/patch-Makefile.FreeBSD
deleted file mode 100644
index e3dd561de9a7..000000000000
--- a/games/hex-a-hop/files/patch-Makefile.FreeBSD
+++ /dev/null
@@ -1,19 +0,0 @@
---- Makefile.FreeBSD.orig Tue Sep 12 17:28:37 2006
-+++ Makefile.FreeBSD Tue Sep 12 17:28:53 2006
-@@ -11,13 +11,13 @@
- .endif
-
- hex-a-hop: gfx.o hex_puzzzle.o
-- $(CXX) $(CXXFLAGS) gfx.o hex_puzzzle.o `sdl11-config --libs` -lm -o hex-a-hop
-+ $(CXX) $(CXXFLAGS) gfx.o hex_puzzzle.o `sdl-config --libs` -lm -o hex-a-hop
-
- gfx.o: gfx.cpp state.h
-- $(CC) $(CXXFLAGS) `sdl11-config --cflags` -c -o $@ $<
-+ $(CC) $(CXXFLAGS) `sdl-config --cflags` -c -o $@ $<
-
- hex_puzzzle.o: hex_puzzzle.cpp *.h
-- $(CC) $(CXXFLAGS) `sdl11-config --cflags` -c -o $@ $<
-+ $(CC) $(CXXFLAGS) `sdl-config --cflags` -c -o $@ $<
-
- clean :
- rm -f gfx.o hex_puzzzle.o hex-a-hop
diff --git a/games/hex-a-hop/files/patch-hex_puzzzle.cpp b/games/hex-a-hop/files/patch-hex_puzzzle.cpp
deleted file mode 100644
index 7cc8d43ae7e0..000000000000
--- a/games/hex-a-hop/files/patch-hex_puzzzle.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- hex_puzzzle.cpp.orig 2006-02-21 07:12:34.000000000 +0300
-+++ hex_puzzzle.cpp 2008-09-14 21:34:14.296378652 +0400
-@@ -2313,7 +2313,7 @@
-
- SDL_Surface* Load(const char * bmp, bool colourKey=true)
- {
-- typedef unsigned long uint32;
-+ typedef unsigned int uint32;
- uint32* tmp = 0;
-
- SDL_Surface * g = 0;
diff --git a/games/hex-a-hop/files/patch-menus.h b/games/hex-a-hop/files/patch-menus.h
deleted file mode 100644
index 8bcb8052d3bb..000000000000
--- a/games/hex-a-hop/files/patch-menus.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- menus.h.orig 2006-02-21 06:10:35.000000000 +0300
-+++ menus.h 2008-09-14 21:34:41.711083734 +0400
-@@ -1073,7 +1073,7 @@
- if (under)
- under->Render();
-
-- RenderFade(time, dir, (int)this);
-+ RenderFade(time, dir, reinterpret_cast<intptr_t>(this));
- }
- void Update(double timedelta)
- {
diff --git a/games/hex-a-hop/files/patch-src-i18n.h b/games/hex-a-hop/files/patch-src-i18n.h
new file mode 100644
index 000000000000..2c99e150916b
--- /dev/null
+++ b/games/hex-a-hop/files/patch-src-i18n.h
@@ -0,0 +1,10 @@
+--- src/i18n.h~
++++ src/i18n.h
+@@ -20,6 +20,7 @@
+
+ #ifdef USE_GETTEXT
+
++#include <iconv.h>
+ #include <libintl.h>
+ #define _(String) gettext (String)
+
diff --git a/games/hex-a-hop/files/patch-src-system-relative.c b/games/hex-a-hop/files/patch-src-system-relative.c
new file mode 100644
index 000000000000..ed0e68c03171
--- /dev/null
+++ b/games/hex-a-hop/files/patch-src-system-relative.c
@@ -0,0 +1,20 @@
+--- src/system-relative.c~
++++ src/system-relative.c
+@@ -163,6 +163,8 @@ lisys_relative_exename ()
+ }
+
+ return strdup (name);
++#elif __FreeBSD__
++ return getprogname();
+ #else
+ #warning "Not supported."
+ return NULL;
+@@ -177,7 +179,7 @@ lisys_relative_exename ()
+ char*
+ lisys_relative_exedir ()
+ {
+-#if defined WIN32 || defined linux
++#if defined WIN32 || defined linux || defined __FreeBSD__
+ char* tmp;
+ char* ptr;
+
diff --git a/games/hex-a-hop/files/patch-src-text.cpp b/games/hex-a-hop/files/patch-src-text.cpp
new file mode 100644
index 000000000000..8bfce50bf2dd
--- /dev/null
+++ b/games/hex-a-hop/files/patch-src-text.cpp
@@ -0,0 +1,11 @@
+--- src/text.cpp~
++++ src/text.cpp
+@@ -439,7 +439,7 @@ void ConvertToUTF8(const std::string &te
+ errno = 0;
+ static const char *locale_enc = gettext_init.GetEncoding();
+ iconv_t cd = iconv_open("UTF-8", locale_enc);
+- char *in_buf = const_cast<char *>(&text_locally_encoded[0]);
++ const char *in_buf = const_cast<char *>(&text_locally_encoded[0]);
+ char *out_buf = &text_utf8[0];
+ iconv(cd, &in_buf, &text_length, &out_buf, &text_utf8_length);
+ iconv_close(cd);
diff --git a/games/hex-a-hop/files/patch-state.h b/games/hex-a-hop/files/patch-state.h
deleted file mode 100644
index bf81412910e9..000000000000
--- a/games/hex-a-hop/files/patch-state.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- state.h.orig Tue Sep 12 17:30:34 2006
-+++ state.h Tue Sep 12 17:30:40 2006
-@@ -22,7 +22,7 @@
-
- // LINUX: SDL/
- #ifdef __FreeBSD__
--#include <SDL11/SDL.h>
-+#include <SDL/SDL.h>
- #else
- #include <SDL/SDL.h>
- #endif
diff --git a/games/hex-a-hop/pkg-descr b/games/hex-a-hop/pkg-descr
index 27af79d2e9fc..8e32ffd43cad 100644
--- a/games/hex-a-hop/pkg-descr
+++ b/games/hex-a-hop/pkg-descr
@@ -5,5 +5,4 @@ The objective is simply to destroy all the green hexagonal tiles on each of the
100 levels. As you progress through the game, more types of tiles are introduced
which make things more difficult and interesting (hopefully).
-Author: Tom Beaumont <tombeaumont@yahoo.com>
-WWW: http://www.aceinternet.co.uk/~mokona/
+WWW: http://hexahop.sourceforge.net/
diff --git a/games/hex-a-hop/pkg-plist b/games/hex-a-hop/pkg-plist
index 9efb25c4672e..f281a35bed1e 100644
--- a/games/hex-a-hop/pkg-plist
+++ b/games/hex-a-hop/pkg-plist
@@ -1,13 +1,34 @@
bin/hex-a-hop
-%%DATADIR%%/graphics/emi.dat
-%%DATADIR%%/graphics/font.dat
-%%DATADIR%%/graphics/gradient.dat
-%%DATADIR%%/graphics/icon.bmp
-%%DATADIR%%/graphics/map.dat
-%%DATADIR%%/graphics/map_top.dat
-%%DATADIR%%/graphics/tiles.dat
-%%DATADIR%%/graphics/tiles_reflect.dat
-%%DATADIR%%/graphics/title.dat
+%%DATADIR%%/emi.dat
+%%DATADIR%%/font.dat
+%%DATADIR%%/font.ttf
+%%DATADIR%%/gradient.dat
+%%DATADIR%%/icon.bmp
%%DATADIR%%/levels.dat
-@dirrm %%DATADIR%%/graphics
+%%DATADIR%%/map.dat
+%%DATADIR%%/map_top.dat
+%%DATADIR%%/music-ending-nonfree.ogg
+%%DATADIR%%/music-game-nonfree-1.ogg
+%%DATADIR%%/music-game-nonfree.ogg
+%%DATADIR%%/sound-builder-nonfree.ogg
+%%DATADIR%%/sound-collapse-nonfree.ogg
+%%DATADIR%%/sound-crack.ogg
+%%DATADIR%%/sound-death.ogg
+%%DATADIR%%/sound-explode-big.ogg
+%%DATADIR%%/sound-explode-small.ogg
+%%DATADIR%%/sound-floater-enter.ogg
+%%DATADIR%%/sound-found-antiice-nonfree.ogg
+%%DATADIR%%/sound-found-jump-nonfree.ogg
+%%DATADIR%%/sound-ice.ogg
+%%DATADIR%%/sound-laser.ogg
+%%DATADIR%%/sound-lift-down-nonfree.ogg
+%%DATADIR%%/sound-lift-up-nonfree.ogg
+%%DATADIR%%/sound-spinner-nonfree.ogg
+%%DATADIR%%/sound-trampoline.ogg
+%%DATADIR%%/sound-used-antiice.ogg
+%%DATADIR%%/sound-used-jump.ogg
+%%DATADIR%%/sound-win.ogg
+%%DATADIR%%/tiles.dat
+%%DATADIR%%/tiles_reflect.dat
+%%DATADIR%%/title.dat
@dirrm %%DATADIR%%