aboutsummaryrefslogtreecommitdiff
path: root/games/hex-a-hop
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-30 09:20:15 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-30 09:20:15 +0000
commit27b27c697960e38de372e05cfd7f3cdc62eef879 (patch)
treebe105174a37a98825cc97c0b701c604aaf8a4042 /games/hex-a-hop
parent8e93b103e5b91a016acc022b761f27e920a3b819 (diff)
Notes
Diffstat (limited to 'games/hex-a-hop')
-rw-r--r--games/hex-a-hop/Makefile14
-rw-r--r--games/hex-a-hop/files/patch-hex_puzzzle.cpp11
-rw-r--r--games/hex-a-hop/files/patch-menus.h11
-rw-r--r--games/hex-a-hop/pkg-plist25
4 files changed, 39 insertions, 22 deletions
diff --git a/games/hex-a-hop/Makefile b/games/hex-a-hop/Makefile
index 1378e192a684..5bbd18ed32f7 100644
--- a/games/hex-a-hop/Makefile
+++ b/games/hex-a-hop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hex-a-hop
PORTVERSION= 1.0.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= http://ftp.bishopston.net/freebsd/distfiles/ \
ftp://ftp.bishopston.net/freebsd/distfiles/ \
@@ -16,23 +16,19 @@ MASTER_SITES= http://ftp.bishopston.net/freebsd/distfiles/ \
MAINTAINER= jamie@bishopston.net
COMMENT= A puzzle game based on hexagonal tiles
-NOT_FOR_ARCHS= amd64 sparc64
-NOT_FOR_ARCHS_REASON_amd64= Probably an easy fix, but I've no access to an amd64 machine. Offers of help appreciated!
-NOT_FOR_ARCHS_REASON_sparc64= Probably an easy fix, but I've no access to an sparc64 machine. Offers of help appreciated!
-
USE_SDL= sdl
MAKEFILE= Makefile.FreeBSD
ALL_TARGET= ${PORTNAME}
-MAKE_ARGS+= SYSTEM_INSTALL_DIR="${PREFIX}/games/hex-a-hop/"
+MAKE_ARGS+= SYSTEM_INSTALL_DIR="${DATADIR}/"
DESKTOP_ENTRIES="Hex-a-Hop" "A puzzle game based on hexagonal tiles" \
"${PREFIX}/games/hex-a-hop/graphics/icon.bmp" \
"hex-a-hop" "Application;LogicGame;Game;" false
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hex-a-hop ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/games/hex-a-hop/graphics/
- ${INSTALL_DATA} ${WRKSRC}/graphics/* ${PREFIX}/games/hex-a-hop/graphics
- ${INSTALL_DATA} ${WRKSRC}/levels.dat ${PREFIX}/games/hex-a-hop
+ ${MKDIR} ${DATADIR}/graphics
+ ${INSTALL_DATA} ${WRKSRC}/graphics/* ${DATADIR}/graphics/
+ ${INSTALL_DATA} ${WRKSRC}/levels.dat ${DATADIR}/
.include <bsd.port.mk>
diff --git a/games/hex-a-hop/files/patch-hex_puzzzle.cpp b/games/hex-a-hop/files/patch-hex_puzzzle.cpp
new file mode 100644
index 000000000000..7cc8d43ae7e0
--- /dev/null
+++ b/games/hex-a-hop/files/patch-hex_puzzzle.cpp
@@ -0,0 +1,11 @@
+--- hex_puzzzle.cpp.orig 2006-02-21 07:12:34.000000000 +0300
++++ hex_puzzzle.cpp 2008-09-14 21:34:14.296378652 +0400
+@@ -2313,7 +2313,7 @@
+
+ SDL_Surface* Load(const char * bmp, bool colourKey=true)
+ {
+- typedef unsigned long uint32;
++ typedef unsigned int uint32;
+ uint32* tmp = 0;
+
+ SDL_Surface * g = 0;
diff --git a/games/hex-a-hop/files/patch-menus.h b/games/hex-a-hop/files/patch-menus.h
new file mode 100644
index 000000000000..8bcb8052d3bb
--- /dev/null
+++ b/games/hex-a-hop/files/patch-menus.h
@@ -0,0 +1,11 @@
+--- menus.h.orig 2006-02-21 06:10:35.000000000 +0300
++++ menus.h 2008-09-14 21:34:41.711083734 +0400
+@@ -1073,7 +1073,7 @@
+ if (under)
+ under->Render();
+
+- RenderFade(time, dir, (int)this);
++ RenderFade(time, dir, reinterpret_cast<intptr_t>(this));
+ }
+ void Update(double timedelta)
+ {
diff --git a/games/hex-a-hop/pkg-plist b/games/hex-a-hop/pkg-plist
index 80c586862bba..9efb25c4672e 100644
--- a/games/hex-a-hop/pkg-plist
+++ b/games/hex-a-hop/pkg-plist
@@ -1,14 +1,13 @@
bin/hex-a-hop
-games/hex-a-hop/graphics/emi.dat
-games/hex-a-hop/graphics/font.dat
-games/hex-a-hop/graphics/gradient.dat
-games/hex-a-hop/graphics/icon.bmp
-games/hex-a-hop/graphics/map.dat
-games/hex-a-hop/graphics/map_top.dat
-games/hex-a-hop/graphics/tiles.dat
-games/hex-a-hop/graphics/tiles_reflect.dat
-games/hex-a-hop/graphics/title.dat
-games/hex-a-hop/levels.dat
-@dirrm games/hex-a-hop/graphics/
-@dirrm games/hex-a-hop/
-@dirrmtry games/
+%%DATADIR%%/graphics/emi.dat
+%%DATADIR%%/graphics/font.dat
+%%DATADIR%%/graphics/gradient.dat
+%%DATADIR%%/graphics/icon.bmp
+%%DATADIR%%/graphics/map.dat
+%%DATADIR%%/graphics/map_top.dat
+%%DATADIR%%/graphics/tiles.dat
+%%DATADIR%%/graphics/tiles_reflect.dat
+%%DATADIR%%/graphics/title.dat
+%%DATADIR%%/levels.dat
+@dirrm %%DATADIR%%/graphics
+@dirrm %%DATADIR%%