aboutsummaryrefslogtreecommitdiff
path: root/games/hex/Makefile
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-08-14 03:52:28 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-08-14 03:52:28 +0000
commit52a5b148a45c19c12742d210227c96f8871cb19e (patch)
treecc392e38ccc23d9432bf6b49fc05824dd450c4f3 /games/hex/Makefile
parent9e83383a64f9dab0b4d167106564afb504d2e2e7 (diff)
downloadports-52a5b148a45c19c12742d210227c96f8871cb19e.tar.gz
ports-52a5b148a45c19c12742d210227c96f8871cb19e.zip
Notes
Diffstat (limited to 'games/hex/Makefile')
-rw-r--r--games/hex/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/games/hex/Makefile b/games/hex/Makefile
new file mode 100644
index 000000000000..c6ecdb1f6a5f
--- /dev/null
+++ b/games/hex/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: Hex
+# Version required: 0.0.2
+# Date created: 9 Aug 1999
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $Id$
+#
+
+DISTNAME= hex-0.0.2
+CATEGORIES= games
+MASTER_SITES= http://www.nott.ac.uk/~psystrj/ \
+ http://www.psn.net/~andrews/dist/
+
+MAINTAINER= andrews@technologist.com
+
+LIB_DEPENDS= Imlib.4:${PORTSDIR}/graphics/imlib \
+ gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+USE_X_PREFIX= YES
+
+USE_GMAKE= YES
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+pre-install:
+ @${MKDIR} ${X11BASE}/share/hex
+ @${MKDIR} ${X11BASE}/share/hex/levels
+ @${MKDIR} ${X11BASE}/share/hex/graphics
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/hex ${X11BASE}/bin/hex
+ @${INSTALL_DATA} ${WRKSRC}/HISTORY ${X11BASE}/share/hex/HISTORY
+ @${INSTALL_DATA} ${WRKSRC}/README ${X11BASE}/share/hex/README
+ @${INSTALL_DATA} ${WRKSRC}/TODO ${X11BASE}/share/hex/TODO
+.for i in 0 1 2 3 4 5 6 7 8
+ @${INSTALL_DATA} ${WRKSRC}/graphics/ball${i}.png \
+ ${X11BASE}/share/hex/graphics/ball${i}.png
+.endfor
+ @${INSTALL_DATA} ${WRKSRC}/levels/Level1 \
+ ${X11BASE}/share/hex/levels/Level1
+
+.include <bsd.port.mk>