aboutsummaryrefslogtreecommitdiff
path: root/games/hinversi
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-04-02 10:01:00 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-04-02 10:01:00 +0000
commit5ed6d73e5f047e7ae843cbe0743fd16027ab7b9a (patch)
treee8c845cac5c985f6e581552b3dc7976f8b68686b /games/hinversi
parent7c54d6e79af98e98da2dd181b6f95e9ea403d67d (diff)
downloadports-5ed6d73e5f047e7ae843cbe0743fd16027ab7b9a.tar.gz
ports-5ed6d73e5f047e7ae843cbe0743fd16027ab7b9a.zip
Notes
Diffstat (limited to 'games/hinversi')
-rw-r--r--games/hinversi/Makefile29
-rw-r--r--games/hinversi/distinfo3
-rw-r--r--games/hinversi/pkg-descr6
-rw-r--r--games/hinversi/pkg-plist16
4 files changed, 54 insertions, 0 deletions
diff --git a/games/hinversi/Makefile b/games/hinversi/Makefile
new file mode 100644
index 000000000000..09d9d1cc092b
--- /dev/null
+++ b/games/hinversi/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: hinversi
+# Date created: 2 April 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hinversi
+PORTVERSION= 0.8.1
+CATEGORIES= games
+MASTER_SITES= http://asturio.gmxhome.de/ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Reversi/Othello clone
+
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE} --mandir=${PREFIX}/man\
+ --disable-static
+MAN1= hinversi-cli.1
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^mkdir_p/s|=.*|=$$(mkinstalldirs)|'\
+ ${WRKSRC}/po/Makefile.in.in
+ @${REINPLACE_CMD} -e '/^pkgconfigdir/s|=.*|=${PREFIX}/libdata/pkgconfig|'\
+ ${WRKSRC}/lib/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/games/hinversi/distinfo b/games/hinversi/distinfo
new file mode 100644
index 000000000000..ea6acba317e9
--- /dev/null
+++ b/games/hinversi/distinfo
@@ -0,0 +1,3 @@
+MD5 (hinversi-0.8.1.tar.gz) = a870d9aea3c6d186464b9af06640fcdd
+SHA256 (hinversi-0.8.1.tar.gz) = fbf156430df89ca7960525ae9e7ff1d551bbb07c927928903b4ecdd8f61109e9
+SIZE (hinversi-0.8.1.tar.gz) = 408955
diff --git a/games/hinversi/pkg-descr b/games/hinversi/pkg-descr
new file mode 100644
index 000000000000..0e540a65c619
--- /dev/null
+++ b/games/hinversi/pkg-descr
@@ -0,0 +1,6 @@
+Hinversi is a version of Reversi or Othello, a board game. It was written
+from the beginning thinking on modularity, to ease the process of changing
+and improving the AI engine.
+
+WWW: http://asturio.gmxhome.de/hinversi.html
+Author: Claudio Clemens <asturio@gmx.net>
diff --git a/games/hinversi/pkg-plist b/games/hinversi/pkg-plist
new file mode 100644
index 000000000000..4fe95ad8b2b0
--- /dev/null
+++ b/games/hinversi/pkg-plist
@@ -0,0 +1,16 @@
+bin/hinversi-cli
+include/hinversi/abClient.h
+include/hinversi/aiManager.h
+include/hinversi/macros.h
+include/hinversi/matador.h
+include/hinversi/naiv-client.h
+include/hinversi/othello.h
+include/hinversi/ringbuf.h
+include/hinversi/simpleClient.h
+lib/libhinversi.la
+lib/libhinversi.so
+lib/libhinversi.so.0
+libdata/pkgconfig/libhinversi.pc
+share/locale/de/LC_MESSAGES/hinversi.mo
+share/locale/pt_BR/LC_MESSAGES/hinversi.mo
+@dirrm include/hinversi