aboutsummaryrefslogtreecommitdiff
path: root/games/hlserver-tsc
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-17 19:40:05 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-17 19:40:05 +0000
commit4634238708f54aad287a839522f40893b414e5a4 (patch)
tree2cb4e20b6fd4f2794636064d875579eaa08a254c /games/hlserver-tsc
parentb5ce7322605bd95b222f7ba3db9fffb332366344 (diff)
downloadports-4634238708f54aad287a839522f40893b414e5a4.tar.gz
ports-4634238708f54aad287a839522f40893b414e5a4.zip
Notes
Diffstat (limited to 'games/hlserver-tsc')
-rw-r--r--games/hlserver-tsc/Makefile29
-rw-r--r--games/hlserver-tsc/distinfo1
-rw-r--r--games/hlserver-tsc/pkg-comment1
-rw-r--r--games/hlserver-tsc/pkg-descr19
-rw-r--r--games/hlserver-tsc/pkg-install105
-rw-r--r--games/hlserver-tsc/pkg-plist7
6 files changed, 162 insertions, 0 deletions
diff --git a/games/hlserver-tsc/Makefile b/games/hlserver-tsc/Makefile
new file mode 100644
index 000000000000..7ad4865b1b14
--- /dev/null
+++ b/games/hlserver-tsc/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: TSC Server
+# Date created: Mon Nov 12 13:19:17 BRST 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tsc
+PORTVERSION= 0.2.4.6.b
+MASTER_SITES= http://www.heyphucker.com/ \
+ http://www.wbg-clan.de/download/server/ \
+ http://www.mystwalker.de/cs/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/^0.//:S/.b$//}
+
+MAINTAINER= lioux@FreeBSD.org
+
+BUILD_DEPENDS+= ${LINUXBASE}${HLDSDIR}cstrike/liblist.gam:${HALFLIFE_COUNTERSTRIKE_MASTER}
+
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+PKGDEINSTALL= ${PKGINSTALL}
+
+slaveport-post-install:
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
+ ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+HALFLIFE_COUNTERSTRIKE_MASTER= ${.CURDIR}/../hlserver-cs
+
+.include "${HALFLIFE_COUNTERSTRIKE_MASTER}/Makefile"
diff --git a/games/hlserver-tsc/distinfo b/games/hlserver-tsc/distinfo
new file mode 100644
index 000000000000..cb3f2125db6a
--- /dev/null
+++ b/games/hlserver-tsc/distinfo
@@ -0,0 +1 @@
+MD5 (tsc2.4.6.zip) = f0738b6573dd0acdc75f9520322ba949
diff --git a/games/hlserver-tsc/pkg-comment b/games/hlserver-tsc/pkg-comment
new file mode 100644
index 000000000000..f3b50c424c0e
--- /dev/null
+++ b/games/hlserver-tsc/pkg-comment
@@ -0,0 +1 @@
+Half-Life mod Counter-Strike with TSC modifications
diff --git a/games/hlserver-tsc/pkg-descr b/games/hlserver-tsc/pkg-descr
new file mode 100644
index 000000000000..621eedd3c8de
--- /dev/null
+++ b/games/hlserver-tsc/pkg-descr
@@ -0,0 +1,19 @@
+This package contains the files to run a FreeBSD Half-Life
+Counter-Strike server under Linux emulation with the TSC modification
+
+[from developer's site]
+
+TSC is a server side modification to CS and the half life server
+system. It adds more features and effects to the CS experience.
+Features included in this release are:
+
+-AIMBOT PROTECTION - USERS WILL BE DISCONNECTED!!! [automatically
+enabled]
+-Optional model and sprite enforcement controlls with various
+enforcement levels.
+- OGC 5.0a blocked
+- lots more
+
+Visit these following web pages for more information:
+
+WWW: http://www.tsc.austin2600.org/
diff --git a/games/hlserver-tsc/pkg-install b/games/hlserver-tsc/pkg-install
new file mode 100644
index 000000000000..abf6e144cf15
--- /dev/null
+++ b/games/hlserver-tsc/pkg-install
@@ -0,0 +1,105 @@
+#!/bin/sh
+# $FreeBSD$
+
+# based on original from op port, written by Cyrille Lefevre
+# <clefevre@citeweb.net>
+
+[ $# != 2 ] && exit 1
+PKGNAME=$1
+ACTION=$2
+
+HLDSDIR=/usr/games/hlds_l/
+CONF_DIR=${PKG_PREFIX}/${HLDSDIR}/cstrike
+
+CONF_FILE=liblist.gam
+CONF_OWN=root
+CONF_GRP=wheel
+CONF_MODE=444
+
+SAMP_SUFX=.old
+
+INSTALL=install
+CMP=cmp
+FMT=fmt
+GREP=grep
+PERL=perl
+RM=rm
+RMDIR=rmdir
+
+WWW="http://www.tsc.austin2600.org/"
+
+INSTALL_DIR="${INSTALL} -d -o root -g wheel -m 755"
+INSTALL_DATA="install -c -o root -g wheel -m 444"
+
+AUDIO_FILES="gasp1.wav gasp2.wav"
+
+case "$ACTION" in
+
+POST-INSTALL)
+ for file in ${AUDIO_FILES}
+ do
+ ${INSTALL_DATA} ${PKG_PREFIX}/${HLDSDIR}dmc/sound/player/${file} \
+ ${PKG_PREFIX}${HLDSDIR}cstrike/sound/player/
+ done
+
+ echo "$PKGNAME: ======> <======"
+
+ if [ -f ${CONF_DIR}/${CONF_FILE} ]
+ then
+IS_IT_THERE=`${GREP} -E -e '^gamedll_linux.*\"dlls\/cs_i386.so\"$' ${CONF_DIR}/${CONF_FILE}`
+ fi
+
+ if [ -n "${IS_IT_THERE}" ]
+ then
+ ${PERL} -pi -ne 's|^(gamedll_linux.*\"dlls\/)cs_i386(.so\"\s*)$|\1tsc\2|' \
+ ${CONF_DIR}/${CONF_FILE}
+ echo "$PKGNAME: Modified ${CONF_DIR}/${CONF_FILE}. It now uses TSC."
+ echo "$PKGNAME: If you want admin mod or metamod, check TSC's site (${WWW}) for installation instructions." | ${FMT}
+ else
+ echo "$PKGNAME: ERROR: Existing ${CONF_DIR}/${CONF_FILE} configuration file was modified by hand." | ${FMT}
+ echo "$PKGNAME: You probably edited it by hand. Therefore, I can't automatically modify it."
+ echo "$PKGNAME: There is no problem."
+ echo "$PKGNAME: Just go to developer's site (${WWW}) and check installation instructions."
+ fi
+
+ echo "$PKGNAME: ======> <======"
+ ;;
+
+DEINSTALL)
+ for file in ${AUDIO_FILES}
+ do
+ ${RM} ${PKG_PREFIX}/${HLDSDIR}cstrike/sound/player/${file}
+ done
+
+ echo "$PKGNAME: ======> <======"
+
+ if [ -f ${CONF_DIR}/${CONF_FILE} ]
+ then
+IS_IT_THERE=`${GREP} -E -e '^gamedll_linux.*\"dlls\/tsc.so\"$' ${CONF_DIR}/${CONF_FILE}`
+ fi
+
+ if [ -n "${IS_IT_THERE}" ]
+ then
+ ${PERL} -pi -ne 's|^(gamedll_linux.*\"dlls\/)tsc(.so\"\s*)$|\1cs_i386\2|' \
+ ${CONF_DIR}/${CONF_FILE}
+ echo "$PKGNAME: Modified ${CONF_DIR}/${CONF_FILE}. It no longer uses TSC."
+ echo "$PKGNAME: If added admin mod or metamod to TSC, check TSC's site (${WWW}) for deinstallation (do installation backwards) instructions." | ${FMT}
+ else
+ echo "$PKGNAME: ERROR: Existing ${CONF_DIR}/${CONF_FILE} configuration file was modified by hand." | ${FMT}
+ echo "$PKGNAME: You probably edited it by hand. Therefore, I can't automatically modify it."
+ echo "$PKGNAME: There is no problem."
+ echo "$PKGNAME: Just go to developer's site (${WWW}) and check deinstallation (do installation backwards) instructions." | ${FMT}
+ fi
+
+ echo "$PKGNAME: ======> <======"
+ ;;
+
+PRE-INSTALL|POST-DEINSTALL)
+ ;;
+
+*)
+ exit 1
+ ;;
+esac
+
+exit
diff --git a/games/hlserver-tsc/pkg-plist b/games/hlserver-tsc/pkg-plist
new file mode 100644
index 000000000000..267412886487
--- /dev/null
+++ b/games/hlserver-tsc/pkg-plist
@@ -0,0 +1,7 @@
+%%HLDSDIR%%cstrike/cheatlib.tsc
+%%HLDSDIR%%cstrike/dlls/tsc.so
+%%PORTDOCS%%%%HLDSDIR%%cstrike/readme.txt
+%%PORTDOCS%%%%HLDSDIR%%cstrike/sound/player/sound readme.txt
+%%HLDSDIR%%cstrike/sound/welcome.wav
+%%HLDSDIR%%cstrike/tsc.cfg
+%%HLDSDIR%%cstrike/users.tsc