aboutsummaryrefslogtreecommitdiff
path: root/games/hoichess
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-10-06 19:43:13 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-10-06 19:43:13 +0000
commit22d479752d4296088e05f4f715677c785d49af6e (patch)
tree7a445d40425e320e28eef028c9a68b4d0bcae672 /games/hoichess
parent62627f140769b6d77ee78186ff827faef4306504 (diff)
downloadports-22d479752d4296088e05f4f715677c785d49af6e.tar.gz
ports-22d479752d4296088e05f4f715677c785d49af6e.zip
Notes
Diffstat (limited to 'games/hoichess')
-rw-r--r--games/hoichess/Makefile29
-rw-r--r--games/hoichess/distinfo2
-rw-r--r--games/hoichess/pkg-descr5
-rw-r--r--games/hoichess/pkg-plist10
4 files changed, 46 insertions, 0 deletions
diff --git a/games/hoichess/Makefile b/games/hoichess/Makefile
new file mode 100644
index 000000000000..0a9339568155
--- /dev/null
+++ b/games/hoichess/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= hoichess
+PORTVERSION= 0.12.1
+CATEGORIES= games
+MASTER_SITES= http://www.hoicher.de/hoichess/download/ \
+ ftp://ftp.stack.nl/pub/users/johans/hoichess/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= johans@FreeBSD.org
+COMMENT= Not-so-very-strong chess engine
+
+USES= gmake perl5
+USE_PERL5= build
+MAKE_JOBS_UNSAFE=yes
+MAKE_ENV= HAVE_GETOPT=1
+
+post-patch:
+ @${RM} ${WRKSRC}/src/lib/getopt.h
+ @${REINPLACE_CMD} -e '1,/^LDFLAG/d' ${WRKSRC}/src/Makefile.config
+ @${ECHO} 'INSTALL = ${INSTALL}' >> ${WRKSRC}/src/Makefile.config
+ @${REINPLACE_CMD} -Ee '/INSTALL|install/s/ -D / /' \
+ ${WRKSRC}/src/Makefile ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '1,/^####/d' ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -e '/^prefix/s|= .*|= ${STAGEDIR}$${PREFIX}|' \
+ -e '/bindir/s/games/bin/; /mandir/s/share//' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
+
diff --git a/games/hoichess/distinfo b/games/hoichess/distinfo
new file mode 100644
index 000000000000..59878563fc19
--- /dev/null
+++ b/games/hoichess/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hoichess-0.12.1-src.tar.gz) = bbef42a275afde9be76bbb6c2bb3743ea5a8bba2b5fe6231187ea25c2e294291
+SIZE (hoichess-0.12.1-src.tar.gz) = 145321
diff --git a/games/hoichess/pkg-descr b/games/hoichess/pkg-descr
new file mode 100644
index 000000000000..2755acf5967e
--- /dev/null
+++ b/games/hoichess/pkg-descr
@@ -0,0 +1,5 @@
+HoiChess is an xboard compatible chess engine. HoiChess plays
+at easier levels than most modern engines, making chess games
+actually winnable for regular human beings.
+
+WWW: http://www.hoicher.de/hoichess
diff --git a/games/hoichess/pkg-plist b/games/hoichess/pkg-plist
new file mode 100644
index 000000000000..7bfca10a2ab8
--- /dev/null
+++ b/games/hoichess/pkg-plist
@@ -0,0 +1,10 @@
+bin/hoichess
+bin/hoixiangqi
+man/man6/hoichess.6.gz
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/hoichess.6.html
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%