aboutsummaryrefslogtreecommitdiff
path: root/games/hyperrogue
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-06-25 20:32:30 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-06-25 20:32:30 +0000
commit252a5942082323c794504e03dfec0cd562da26f8 (patch)
treecc73f33ba7ddc4302908b55f4b3deb8e57b34e6e /games/hyperrogue
parent20e3689533a0272a1d48820608aafdea07b9c0a9 (diff)
downloadports-252a5942082323c794504e03dfec0cd562da26f8.tar.gz
ports-252a5942082323c794504e03dfec0cd562da26f8.zip
Notes
Diffstat (limited to 'games/hyperrogue')
-rw-r--r--games/hyperrogue/Makefile8
-rw-r--r--games/hyperrogue/distinfo6
-rw-r--r--games/hyperrogue/files/patch-Makefile.am16
-rw-r--r--games/hyperrogue/files/patch-sound.cpp11
-rw-r--r--games/hyperrogue/pkg-plist1
5 files changed, 16 insertions, 26 deletions
diff --git a/games/hyperrogue/Makefile b/games/hyperrogue/Makefile
index bd88000aa93d..58575e5ff3c7 100644
--- a/games/hyperrogue/Makefile
+++ b/games/hyperrogue/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= hyperrogue
-PORTVERSION= 9.4g
+PORTVERSION= 10.4f
DISTVERSIONPREFIX= v
CATEGORIES= games
@@ -12,17 +12,17 @@ COMMENT= Roguelike in a non-euclidean world
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libpng.so:graphics/png
-
BROKEN_powerpc64= fails to link: langen-langen.o: relocation truncated to fit: R_PPC64_TOC16_DS
+LIB_DEPENDS= libpng.so:graphics/png
+
USE_GITHUB= yes
GH_ACCOUNT= zenorogue
USES= autoreconf localbase
GNU_CONFIGURE= yes
USE_SDL= sdl mixer gfx ttf
-USE_GL= gl
+USE_GL= gl glew
# remove -O2, otherwise clang takes gigabytes of memory
CFLAGS:= ${CFLAGS:C/-O[0-9]//} -DFHS
diff --git a/games/hyperrogue/distinfo b/games/hyperrogue/distinfo
index 611d820ab036..cec2fa590602 100644
--- a/games/hyperrogue/distinfo
+++ b/games/hyperrogue/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1498498940
-SHA256 (zenorogue-hyperrogue-v9.4g_GH0.tar.gz) = 62b611185afc045f83c837e592ceadc28b27ef6ffb09ca1adc11cc79c22008cc
-SIZE (zenorogue-hyperrogue-v9.4g_GH0.tar.gz) = 57345565
+TIMESTAMP = 1529938419
+SHA256 (zenorogue-hyperrogue-v10.4f_GH0.tar.gz) = be8d2741ba48735f3318e68ef613d08602f14299485a2de39a8ce3f9bee23cfd
+SIZE (zenorogue-hyperrogue-v10.4f_GH0.tar.gz) = 57537630
diff --git a/games/hyperrogue/files/patch-Makefile.am b/games/hyperrogue/files/patch-Makefile.am
index 7b0e1677a4a5..a6fd8bb4edfa 100644
--- a/games/hyperrogue/files/patch-Makefile.am
+++ b/games/hyperrogue/files/patch-Makefile.am
@@ -1,11 +1,11 @@
---- Makefile.am.orig 2017-04-15 02:52:00 UTC
+--- Makefile.am.orig 2018-06-22 18:28:41 UTC
+++ Makefile.am
-@@ -6,7 +6,7 @@ dist_doc_DATA = README.md
- hyperrogue_SOURCES = hyper.cpp savepng.c
+@@ -3,7 +3,7 @@ bin_PROGRAMS = hyperrogue
+ hyperroguedir = $(datadir)/hyperrogue
+ dist_hyperrogue_DATA = hyperrogue-music.txt DejaVuSans-Bold.ttf
+ dist_doc_DATA = README.md
+-hyperrogue_SOURCES = hyper.cpp savepng.c
++hyperrogue_SOURCES = hyper.cpp savepng.cpp
# Some definitions used in graph.cpp
--hyperrogue_CPPFLAGS = -DFONTDESTDIR=\"$(pkgdatadir)/DejaVuSans-Bold.ttf\" -DMUSICDESTDIR=\"$(pkgdatadir)/hyperrogue-music.txt\" -DSOUNDDESTDIR=\"$(pkgdatadir)/sounds/\" -O2
-+hyperrogue_CPPFLAGS = -DFONTDESTDIR=\"$(pkgdatadir)/DejaVuSans-Bold.ttf\" -DMUSICDESTDIR=\"$(pkgdatadir)/hyperrogue-music.txt\" -DSOUNDDESTDIR=\"$(pkgdatadir)/sounds/\"
-
- # Musicdir
- musicdir=$(datadir)/hyperrogue/music
+ hyperrogue_CPPFLAGS = -DFONTDESTDIR=\"$(pkgdatadir)/DejaVuSans-Bold.ttf\" -DMUSICDESTDIR=\"$(pkgdatadir)/hyperrogue-music.txt\" -DSOUNDDESTDIR=\"$(pkgdatadir)/sounds/\"
diff --git a/games/hyperrogue/files/patch-sound.cpp b/games/hyperrogue/files/patch-sound.cpp
deleted file mode 100644
index 5e9487db26ca..000000000000
--- a/games/hyperrogue/files/patch-sound.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- sound.cpp.orig 2017-04-15 02:52:00 UTC
-+++ sound.cpp
-@@ -122,7 +122,7 @@ bool loadMusicInfo(string dir) {
- for(int i=0; i<size(dir); i++) if(dir[i] == '/' || dir[i] == '\\')
- dir2 = dir.substr(0, i+1);
- char buf[1000];
-- while(fgets(buf, 800, f) > 0) {
-+ while(fgets(buf, 800, f) != NULL) {
- for(int i=0; buf[i]; i++) if(buf[i] == 10 || buf[i] == 13) buf[i] = 0;
- if(buf[0] == '[' && buf[3] == ']') {
- int id = (buf[1] - '0') * 10 + buf[2] - '0';
diff --git a/games/hyperrogue/pkg-plist b/games/hyperrogue/pkg-plist
index 1fe5de9ea51e..9bf83e45eb63 100644
--- a/games/hyperrogue/pkg-plist
+++ b/games/hyperrogue/pkg-plist
@@ -86,6 +86,7 @@ bin/hyperrogue
%%DATADIR%%/sounds/speak-princess.ogg
%%DATADIR%%/sounds/splash1.ogg
%%DATADIR%%/sounds/splash2.ogg
+%%DATADIR%%/sounds/steamhiss.ogg
%%DATADIR%%/sounds/storm.ogg
%%DATADIR%%/sounds/tada.ogg
%%DATADIR%%/sounds/trapdoor.ogg