aboutsummaryrefslogtreecommitdiff
path: root/games/icebreaker/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-10-19 13:17:31 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-10-19 13:17:31 +0000
commit8201390c0a8c73f9f3a014a6dabbc6be13439c04 (patch)
treef292330e559b183eec1a4dab6dbdb7571a107a29 /games/icebreaker/Makefile
parentdcf8dc728dfb89574d114dcac00ae8690e16b0a7 (diff)
downloadports-8201390c0a8c73f9f3a014a6dabbc6be13439c04.tar.gz
ports-8201390c0a8c73f9f3a014a6dabbc6be13439c04.zip
Notes
Diffstat (limited to 'games/icebreaker/Makefile')
-rw-r--r--games/icebreaker/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/games/icebreaker/Makefile b/games/icebreaker/Makefile
new file mode 100644
index 000000000000..87201cde9f96
--- /dev/null
+++ b/games/icebreaker/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: icebreaker
+# Date created: 19 October 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= icebreaker
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://www.mattdm.org/icebreaker/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+
+USE_GMAKE= yes
+MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
+ prefix="${PREFIX}" \
+ highscoredir="${PREFIX}/share/icebreaker/scores" \
+ CHMOD="${CHMOD}" \
+ CHOWN="${CHOWN}" \
+ MKDIR="${MKDIR}"
+
+.include <bsd.port.mk>