aboutsummaryrefslogtreecommitdiff
path: root/games/iceicepenguin/Makefile
diff options
context:
space:
mode:
authorGlen Barber <gjb@FreeBSD.org>2012-09-01 15:55:56 +0000
committerGlen Barber <gjb@FreeBSD.org>2012-09-01 15:55:56 +0000
commit18dbd7a34f798c2a7ad9d38d9a10d169df293f5f (patch)
tree41efec3c44b59119b2c07ac4fa638029f60fa145 /games/iceicepenguin/Makefile
parent2dd792788eaee419100d121a705cb958f40f007d (diff)
downloadports-18dbd7a34f798c2a7ad9d38d9a10d169df293f5f.tar.gz
ports-18dbd7a34f798c2a7ad9d38d9a10d169df293f5f.zip
Notes
Diffstat (limited to 'games/iceicepenguin/Makefile')
-rw-r--r--games/iceicepenguin/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/games/iceicepenguin/Makefile b/games/iceicepenguin/Makefile
new file mode 100644
index 000000000000..d1ea5abd8c57
--- /dev/null
+++ b/games/iceicepenguin/Makefile
@@ -0,0 +1,65 @@
+# $FreeBSD$
+
+PORTNAME= iceicepenguin
+PORTVERSION= 1.5.1
+CATEGORIES= games python
+MASTER_SITES= SF/${PORTNAME}/Default/Ice%20Ice%20Penguin/ \
+ SF/nemysisfreebsdp/:icons
+DISTNAME= iip.${DISTVERSION}-final
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${PORTNAME}_icons.zip:icons
+DIST_SUBDIR= python
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Remake of an old SEGA Dreamcast game called Chu Chu Rocket
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
+
+WRKSRC= ${WRKDIR}/"ice ice penguin"
+
+FETCH_ARGS?= -Fpr
+USE_ZIP= yes
+USE_PYTHON= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}_48.png \
+ share/pixmaps/${PORTNAME}_64.png \
+ share/pixmaps/${PORTNAME}_72.png \
+ share/pixmaps/${PORTNAME}_96.png
+
+PORTDATA= *
+PORTDOCS= CHANGELOG.txt readme.txt
+
+SUB_FILES= ${PORTNAME}
+
+.include <bsd.port.options.mk>
+
+do-install:
+# Scripts
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+
+# Executable
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${DATADIR}
+
+# Data
+ ${MKDIR} ${DATADIR}
+.for d in fonts gfx lvls menu sfx
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR})
+.endfor
+
+# Pixmaps
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}*.png ${PREFIX}/share/pixmaps
+
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>