aboutsummaryrefslogtreecommitdiff
path: root/games/iceicepenguin/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-11-26 12:22:43 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-11-26 12:22:43 +0000
commit934d2a8b6f8987552c3102fd6393386ad62e91b2 (patch)
treec0aef4960da80a80e43d726d3c4ffecaaa4c4b3b /games/iceicepenguin/Makefile
parent80b2de7aa86a1e11b04eb48b33e1658cffe4064c (diff)
downloadports-934d2a8b6f8987552c3102fd6393386ad62e91b2.tar.gz
ports-934d2a8b6f8987552c3102fd6393386ad62e91b2.zip
Notes
Diffstat (limited to 'games/iceicepenguin/Makefile')
-rw-r--r--games/iceicepenguin/Makefile27
1 files changed, 11 insertions, 16 deletions
diff --git a/games/iceicepenguin/Makefile b/games/iceicepenguin/Makefile
index f09fe83e2cf1..c4898d3c32d4 100644
--- a/games/iceicepenguin/Makefile
+++ b/games/iceicepenguin/Makefile
@@ -6,12 +6,12 @@ PORTVERSION= 1.5.1
PORTREVISION= 3
CATEGORIES= games python
MASTER_SITES= SF/${PORTNAME}/Default/Ice%20Ice%20Penguin/ \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/games/:icons
DISTFILES= iip.${DISTVERSION}-final${EXTRACT_SUFX} \
${PORTNAME}_icons_1${EXTRACT_SUFX}:icons
DIST_SUBDIR= python
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Remake of an old SEGA Dreamcast game called Chu Chu Rocket
LICENSE= GPLv3
@@ -34,28 +34,23 @@ SUB_FILES= ${PORTNAME}
DESKTOP_ENTRIES="Ice Ice Penguin" "${COMMENT}" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" false
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
.for d in fonts gfx lvls menu sfx
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR})
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
.endfor
- ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${STAGEDIR}${DATADIR}
-post-install:
.for s in ${ICON_SIZES}
- ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
- ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
.endfor
- ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>