aboutsummaryrefslogtreecommitdiff
path: root/games/ioquake3
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2014-05-30 05:52:53 +0000
committerAlex Kozlov <ak@FreeBSD.org>2014-05-30 05:52:53 +0000
commit322c5211e83f4f561eb3842839fe167c19fa2854 (patch)
tree10e7844a179c6aaa14eada32dc4ca6a39919cfb1 /games/ioquake3
parentc7e04dae7b1b93c6adb9f4f77b60a2b981d7682a (diff)
downloadports-322c5211e83f4f561eb3842839fe167c19fa2854.tar.gz
ports-322c5211e83f4f561eb3842839fe167c19fa2854.zip
Notes
Diffstat (limited to 'games/ioquake3')
-rw-r--r--games/ioquake3/Makefile10
-rw-r--r--games/ioquake3/files/patch-Makefile43
2 files changed, 29 insertions, 24 deletions
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index e011769cf2ea..db5c822912b6 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -14,6 +14,7 @@ COMMENT?= Cleaned-up and enhanced version of Quake 3
USES= pkgconfig gmake
+NO_STAGE= yes
# Port configuration flags:
# CLIENT SERVER TOOLS DLRENDERER GAMELIBS OPUS OPENGL2
IOQ3?= CLIENT TOOLS GAMELIBS
@@ -225,13 +226,18 @@ PLIST_FILES+= ${inst:C/.*;//}
# Generate install target
do-install: ${Q3INSTALL}
.for dir in ${PLIST_DIRS}
- @${MKDIR} ${STAGEDIR}${PREFIX}/${dir}
+ ${MKDIR} ${PREFIX}/${dir}
.endfor
.for inst in ${IOQ3_INST}
${INSTALL_${inst:C/;.*//}} ${BUILDDIR}/${inst:C/[^;]*;//:C/;.*//} \
- ${STAGEDIR}${PREFIX}/${inst:C/.*;//}
+ ${PREFIX}/${inst:C/.*;//}
.endfor
+post-install:
+ @${JOT} -s '' -b= 78
+ @${CAT} ${PKGMESSAGE}
+ @${JOT} -s '' -b= 78
+
.if !defined(Q3TOTALCONV)
.include "${.CURDIR}/../quake3-data/Makefile.include"
.endif
diff --git a/games/ioquake3/files/patch-Makefile b/games/ioquake3/files/patch-Makefile
index 9e24e8d2cf4e..ca1190284c67 100644
--- a/games/ioquake3/files/patch-Makefile
+++ b/games/ioquake3/files/patch-Makefile
@@ -1,4 +1,5 @@
-Index: Makefile
+--- Makefile.orig 2009-04-22 20:54:48.000000000 +0200
++++ Makefile 2011-11-04 20:42:56.000000000 +0100
@@ -187,6 +187,8 @@
# FIXME: introduce CLIENT_CFLAGS
SDL_CFLAGS=$(shell pkg-config --cflags sdl|sed 's/-Dmain=SDL_main//')
@@ -8,7 +9,7 @@ Index: Makefile
endif
# version info
-@@ -521,44 +523,30 @@
+@@ -521,44 +523,25 @@
ifeq ($(PLATFORM),freebsd)
@@ -38,6 +39,16 @@ Index: Makefile
- RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O3 -ffast-math -funroll-loops \
- -fomit-frame-pointer -fexpensive-optimizations
- else
+- ifeq ($(ARCH),i386)
+- RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O3 -mtune=pentiumpro \
+- -march=pentium -fomit-frame-pointer -pipe -ffast-math \
+- -falign-loops=2 -falign-jumps=2 -falign-functions=2 \
+- -funroll-loops -fstrength-reduce
+- HAVE_VM_COMPILED=true
+- else
+- BASE_CFLAGS += -DNO_VM_COMPILED
+- endif
+- endif
+ ifndef HOMEPATH
+ HOMEPATH = /.ioquake3
+ endif
@@ -53,19 +64,7 @@ Index: Makefile
+ -DDEFAULT_LIBDIR=\\\"$(DEFAULT_LIBDIR)\\\" \
+ -DUSE_ICON -DMAP_ANONYMOUS=MAP_ANON
+ CLIENT_CFLAGS += $(SDL_CFLAGS)
-+ # disable vm on i386
- ifeq ($(ARCH),i386)
-- RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O3 -mtune=pentiumpro \
-- -march=pentium -fomit-frame-pointer -pipe -ffast-math \
-- -falign-loops=2 -falign-jumps=2 -falign-functions=2 \
-- -funroll-loops -fstrength-reduce
-- HAVE_VM_COMPILED=true
-+ BASE_CFLAGS += -DNO_VM_COMPILED
- else
-- BASE_CFLAGS += -DNO_VM_COMPILED
-- endif
-+ HAVE_VM_COMPILED = true
- endif
++ HAVE_VM_COMPILED = true
- DEBUG_CFLAGS=$(BASE_CFLAGS) -g
+ OPTIMIZEVM = -O3 -funroll-loops -fomit-frame-pointer
@@ -73,7 +72,7 @@ Index: Makefile
SHLIBEXT=so
SHLIBCFLAGS=-fPIC
-@@ -568,20 +556,52 @@
+@@ -568,20 +551,52 @@
# don't need -ldl (FreeBSD)
LIBS=-lm
@@ -108,8 +107,8 @@ Index: Makefile
+ ifneq ($(USE_LOCAL_HEADERS),1)
+ CLIENT_CFLAGS += $(VORBIS_CFLAGS)
+ endif
-+ endif
-+
+ endif
+
+ ifeq ($(BUILD_CLIENT),1)
+ BASE_CFLAGS += $(CLIENT_CFLAGS)
+ endif
@@ -124,15 +123,15 @@ Index: Makefile
+ ifeq ($(CROSS_COMPILING),1)
+ BASE_CFLAGS += -m64
+ endif
- endif
-
++ endif
++
+ RELEASE_CFLAGS = $(BASE_CFLAGS)
+ DEBUG_CFLAGS = $(BASE_CFLAGS) -g
+
else # ifeq freebsd
#############################################################################
-@@ -1442,6 +1462,9 @@
+@@ -1442,6 +1457,9 @@
ifeq ($(ARCH),x86_64)
Q3OBJ += $(B)/client/vm_x86_64.o $(B)/client/vm_x86_64_assembler.o
endif
@@ -142,7 +141,7 @@ Index: Makefile
ifeq ($(ARCH),ppc)
Q3OBJ += $(B)/client/vm_powerpc.o $(B)/client/vm_powerpc_asm.o
endif
-@@ -1591,6 +1614,9 @@
+@@ -1591,6 +1609,9 @@
ifeq ($(ARCH),x86_64)
Q3DOBJ += $(B)/ded/vm_x86_64.o $(B)/ded/vm_x86_64_assembler.o
endif