aboutsummaryrefslogtreecommitdiff
path: root/games/iourbanterror
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-09-29 01:58:29 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-09-29 01:58:29 +0000
commit1270cbb8ec56be4db0e3cdeddb6659db019f01cf (patch)
treef06ecf01cf0afaa49e8c571e1ddac54cace0248e /games/iourbanterror
parent21291b2b23b65a7a93b8c1c52ab0c23688ed216c (diff)
downloadports-1270cbb8ec56be4db0e3cdeddb6659db019f01cf.tar.gz
ports-1270cbb8ec56be4db0e3cdeddb6659db019f01cf.zip
Notes
Diffstat (limited to 'games/iourbanterror')
-rw-r--r--games/iourbanterror/Makefile44
-rw-r--r--games/iourbanterror/distinfo6
-rw-r--r--games/iourbanterror/files/patch-Makefile162
-rw-r--r--games/iourbanterror/pkg-descr21
-rw-r--r--games/iourbanterror/pkg-message4
-rw-r--r--games/iourbanterror/pkg-plist7
6 files changed, 153 insertions, 91 deletions
diff --git a/games/iourbanterror/Makefile b/games/iourbanterror/Makefile
index cb37008aa1c1..e0853d726379 100644
--- a/games/iourbanterror/Makefile
+++ b/games/iourbanterror/Makefile
@@ -5,21 +5,25 @@
# $FreeBSD$
#
-PORTNAME= ioquake3
-DISTVERSION= 1.34-rc3
-PORTREVISION= 3
+PORTNAME= iourbanterror
+DISTVERSION= 2007_04_02
CATEGORIES= games
-MASTER_SITES= http://ioquake3.org/files/
-DISTNAME= ${PORTNAME}_${DISTVERSION}
+MASTER_SITES= http://ftp.snt.utwente.nl/pub/games/urbanterror/iourbanterror/source/complete/
+DISTNAME= ioUrbanTerrorSource_${DISTVERSION}
MAINTAINER= alepulver@FreeBSD.org
-COMMENT= Cleaned-up and enhaced version of Quake 3
+COMMENT= Quake 3 engine modified for Urban Terror (based on ioquake3)
-USE_BZIP2= yes
+RUN_DEPENDS= ${Q3DIR}/q3ut4:${PORTSDIR}/games/urbanterror-data
+
+USE_ZIP= yes
USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME:C/_.*//}
OPTIONS= CLIENT "Build client" on \
CELLSHADING "Enable Cell Shading effect" off \
+ CURL "Enable curl support" on \
+ CURL_DLOPEN "Enable dynamic loading of curl" on \
GAMELIBS "Build game libraries (when not mandatory)" off \
DEDICATED "Build dedicated server" on \
MP3 "Enable MP3 support" off \
@@ -40,6 +44,8 @@ VM_ARCHS= amd64 i386 powerpc
.include <bsd.port.pre.mk>
+Q3DIR!= cd ${PORTSDIR}/games/quake3-data && ${MAKE} -V Q3DIR
+
.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED) && \
defined(WITHOUT_SMP)
IGNORE= needs at least one of CLIENT, DEDICATED and SMP options
@@ -60,6 +66,14 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-cellshading
.endif
.if !defined(WITHOUT_CLIENT) || !defined(WITHOUT_SMP)
+# curl
+. if defined(WITH_CURL)
+LIB_DEPENDS+= curl.4:${PORTSDIR}/ftp/curl
+MAKE_ENV+= USE_CURL=1
+. if defined(WITH_CURL_DLOPEN)
+MAKE_ENV+= USE_CURL_DLOPEN=1
+. endif
+. endif
# OpenAL
. if defined(WITH_OPENAL)
LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
@@ -90,7 +104,7 @@ MAKE_ENV+= USE_CODEC_VORBIS=1
.if !defined(WITHOUT_CLIENT)
MAKE_ENV+= BUILD_CLIENT=1
PLIST_SUB+= CLIENT=""
-Q3BIN+= ioquake3
+Q3BIN+= ioUrbanTerror
.else
PLIST_SUB+= CLIENT="@comment "
.endif
@@ -98,7 +112,7 @@ PLIST_SUB+= CLIENT="@comment "
.if !defined(WITHOUT_DEDICATED)
MAKE_ENV+= BUILD_SERVER=1
PLIST_SUB+= DEDICATED=""
-Q3BIN+= ioq3ded
+Q3BIN+= ioUrTded
.else
PLIST_SUB+= DEDICATED="@comment "
.endif
@@ -123,15 +137,19 @@ MAKE_ENV+= USE_OPTIMIZED_CFLAGS=1
.if !defined(WITHOUT_SMP)
MAKE_ENV+= BUILD_CLIENT_SMP=1
PLIST_SUB+= SMP=""
-Q3BIN+= ioquake3-smp
+Q3BIN+= ioUrbanTerror-smp
.else
PLIST_SUB+= SMP="@comment "
.endif
post-patch:
# There are new variables in the config files, so keep them in another dir.
- @${REINPLACE_CMD} -E 's|/\.q3a|/.${PORTNAME}|' \
+ @${REINPLACE_CMD} -E 's|/\.q3a|/.ioUrbanTerror|' \
${WRKSRC}/code/unix/unix_shared.c
+# BattlEye development has stopped, and UT website recommends to disable it,
+# also it's binary only, so it won't work anyways.
+ @${REINPLACE_CMD} -Ee 's|("sv_battleye",) "1"|\1 "0"|' \
+ ${WRKSRC}/code/server/sv_init.c
do-install:
.for bin in ${Q3BIN}
@@ -145,7 +163,8 @@ do-install:
.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/ioUrbanTerror_README.txt \
+ ${WRKSRC}/README ${DOCSDIR}
.endif
post-install:
@@ -153,5 +172,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include "${.CURDIR}/../quake3-data/Makefile.include"
.include <bsd.port.post.mk>
diff --git a/games/iourbanterror/distinfo b/games/iourbanterror/distinfo
index 460e3d60fe5e..5986ec9794e2 100644
--- a/games/iourbanterror/distinfo
+++ b/games/iourbanterror/distinfo
@@ -1,3 +1,3 @@
-MD5 (ioquake3_1.34-rc3.tar.bz2) = ed06d79afcb026f58763a89483733823
-SHA256 (ioquake3_1.34-rc3.tar.bz2) = fb43f63178c6700f20b83634b816f77e390e375e7d9c717180c9820f0c541b01
-SIZE (ioquake3_1.34-rc3.tar.bz2) = 3147694
+MD5 (ioUrbanTerrorSource_2007_04_02.zip) = 225988ec27f498d4752a999f48b8dc15
+SHA256 (ioUrbanTerrorSource_2007_04_02.zip) = 4148834471d1dc0e15b895e7323cda9b7f21995a0d3e8928aa9236cfe7784d95
+SIZE (ioUrbanTerrorSource_2007_04_02.zip) = 8691615
diff --git a/games/iourbanterror/files/patch-Makefile b/games/iourbanterror/files/patch-Makefile
index 70d1aa3fe694..bda1d4a3dd90 100644
--- a/games/iourbanterror/files/patch-Makefile
+++ b/games/iourbanterror/files/patch-Makefile
@@ -1,14 +1,19 @@
---- Makefile.orig Tue Nov 28 19:05:39 2006
-+++ Makefile Fri Sep 14 14:44:03 2007
-@@ -26,11 +26,20 @@
+--- Makefile.orig Sun Apr 1 19:55:18 2007
++++ Makefile Fri Sep 28 22:39:05 2007
+@@ -27,16 +27,22 @@
endif
endif
--BUILD_CLIENT =
--BUILD_CLIENT_SMP =
--BUILD_SERVER =
--BUILD_GAME_SO =
--BUILD_GAME_QVM =
+-BUILD_CLIENT =1
+-BUILD_CLIENT_SMP =0
+-BUILD_SERVER =1
+-BUILD_GAME_SO =0
+-BUILD_GAME_QVM =0
+-OPTIMIZE =1
+-USE_SDL =1
+-USE_OPENAL =0
+-USE_CURL =1
+-USE_CODEC_VORBIS =0
+BUILD_CLIENT?=0
+BUILD_CLIENT_SMP?=0
+BUILD_GAME_QVM?=0
@@ -17,6 +22,8 @@
+HAVE_VM_COMPILED?=false
+USE_CODEC_MP3?=0
+USE_CODEC_VORBIS?=0
++USE_CURL?=0
++USE_CURL_DLOPEN?=0
+USE_LOCAL_HEADERS?=0
+USE_OPENAL?=0
+USE_OPENAL_DLOPEN?=0
@@ -26,14 +33,10 @@
#############################################################################
#
-@@ -88,30 +97,10 @@
+@@ -98,38 +104,10 @@
+ USE_SDL=1
endif
- export USE_CCACHE
--ifndef USE_SDL
--USE_SDL=1
--endif
--
-ifndef USE_OPENAL
-USE_OPENAL=1
-endif
@@ -42,6 +45,18 @@
-USE_OPENAL_DLOPEN=0
-endif
-
+-ifndef USE_CURL
+-USE_CURL=1
+-endif
+-
+-ifndef USE_CURL_DLOPEN
+- ifeq ($(PLATFORM),mingw32)
+- USE_CURL_DLOPEN=0
+- else
+- USE_CURL_DLOPEN=1
+- endif
+-endif
+-
-ifndef USE_CODEC_VORBIS
-USE_CODEC_VORBIS=0
-endif
@@ -58,7 +73,7 @@
CDIR=$(MOUNT_DIR)/client
SDIR=$(MOUNT_DIR)/server
RDIR=$(MOUNT_DIR)/renderer
-@@ -185,6 +174,10 @@
+@@ -217,6 +195,10 @@
BASE_CFLAGS += -DUSE_CODEC_VORBIS=1
endif
@@ -69,30 +84,30 @@
ifeq ($(USE_SDL),1)
BASE_CFLAGS += -DUSE_SDL_VIDEO=1 -DUSE_SDL_SOUND=1 $(shell sdl-config --cflags)
GL_CFLAGS =
-@@ -243,6 +236,10 @@
+@@ -389,6 +371,11 @@
endif
endif
+ ifeq ($(USE_CODEC_MP3),1)
++ BASE_CFLAGS += -DUSE_CODEC_MP3=1
+ CLIENT_LDFLAGS += -lmad
+ endif
+
ifeq ($(USE_CODEC_VORBIS),1)
+ BASE_CFLAGS += -DUSE_CODEC_VORBIS=1
CLIENT_LDFLAGS += -lvorbisfile -lvorbis -logg
- endif
-@@ -342,6 +339,11 @@
+@@ -483,6 +470,10 @@
endif
endif
+ ifeq ($(USE_CODEC_MP3),1)
-+ BASE_CFLAGS += -DUSE_CODEC_MP3=1
+ CLIENT_LDFLAGS += -lmad
+ endif
+
ifeq ($(USE_CODEC_VORBIS),1)
- BASE_CFLAGS += -DUSE_CODEC_VORBIS=1
CLIENT_LDFLAGS += -lvorbisfile -lvorbis -logg
-@@ -444,18 +446,12 @@
+ endif
+@@ -504,18 +495,12 @@
ifeq ($(PLATFORM),freebsd)
@@ -114,7 +129,7 @@
ifeq ($(USE_OPENAL),1)
BASE_CFLAGS += -DUSE_OPENAL=1
-@@ -468,47 +464,61 @@
+@@ -528,47 +513,61 @@
BASE_CFLAGS += -DUSE_CODEC_VORBIS=1
endif
@@ -145,7 +160,7 @@
- BASE_CFLAGS += -DNO_VM_COMPILED
+ ifeq ($(USE_SDL_AUDIO),1)
+ BASE_CFLAGS += -DUSE_SDL_SOUND=1
-+ endif
+ endif
+
+ ifeq ($(USE_SDL_VIDEO),1)
+ BASE_CFLAGS += -DUSE_SDL_VIDEO=1
@@ -158,7 +173,7 @@
+ RELEASE_CFLAGS+=-falign-loops=2 -falign-jumps=2 -falign-functions=2 \
+ -fstrength-reduce
+ endif
- endif
++ endif
+
+ ifneq ($(HAVE_VM_COMPILED),true)
+ BASE_CFLAGS += -DNO_VM_COMPILED
@@ -199,7 +214,7 @@
endif
endif
-@@ -516,7 +526,6 @@
+@@ -576,7 +575,6 @@
CLIENT_LDFLAGS += -lvorbisfile -lvorbis -logg
endif
@@ -207,24 +222,24 @@
else # ifeq freebsd
#############################################################################
-@@ -670,24 +679,25 @@
+@@ -731,24 +729,25 @@
TARGETS =
ifneq ($(BUILD_SERVER),0)
-- TARGETS += $(B)/ioq3ded.$(ARCH)$(BINEXT)
-+ TARGETS += $(B)/ioq3ded$(BINEXT)
+- TARGETS += $(B)/ioUrTded.$(ARCH)$(BINEXT)
++ TARGETS += $(B)/ioUrTded$(BINEXT)
endif
ifneq ($(BUILD_CLIENT),0)
-- TARGETS += $(B)/ioquake3.$(ARCH)$(BINEXT)
+- TARGETS += $(B)/ioUrbanTerror.$(ARCH)$(BINEXT)
- ifneq ($(BUILD_CLIENT_SMP),0)
-- TARGETS += $(B)/ioquake3-smp.$(ARCH)$(BINEXT)
+- TARGETS += $(B)/ioUrbanTerror-smp.$(ARCH)$(BINEXT)
- endif
-+ TARGETS += $(B)/ioquake3$(BINEXT)
++ TARGETS += $(B)/ioUrbanTerror$(BINEXT)
+endif
+
+ifneq ($(BUILD_CLIENT_SMP),0)
-+ TARGETS += $(B)/ioquake3-smp$(BINEXT)
++ TARGETS += $(B)/ioUrbanTerror-smp$(BINEXT)
endif
ifneq ($(BUILD_GAME_SO),0)
@@ -244,7 +259,7 @@
endif
ifneq ($(BUILD_GAME_QVM),0)
-@@ -749,11 +759,11 @@
+@@ -810,11 +809,11 @@
$(MAKE) targets B=$(BD) CFLAGS="$(CFLAGS) $(DEBUG_CFLAGS) $(DEPEND_CFLAGS)"
build_release: B=$(BR)
@@ -258,21 +273,34 @@
targets: $(TARGETS)
-@@ -836,6 +846,7 @@
+@@ -897,8 +896,13 @@
+ $(B)/client/snd_main.o \
$(B)/client/snd_codec.o \
$(B)/client/snd_codec_wav.o \
- $(B)/client/snd_codec_ogg.o \
-+ $(B)/client/snd_codec_mp3.o \
- \
+- $(B)/client/snd_codec_ogg.o \
+- \
++ $(B)/client/snd_codec_ogg.o
++
++ifeq ($(USE_CODEC_MP3),1)
++ Q3OBJ += $(B)/client/snd_codec_mp3.o
++endif
++
++Q3OBJ += \
$(B)/client/qal.o \
$(B)/client/snd_openal.o \
-@@ -964,13 +975,10 @@
- ifeq ($(ARCH),i386)
+ \
+@@ -1026,16 +1030,16 @@
+ endif
+
+ ifeq ($(HAVE_VM_COMPILED),true)
+- ifeq ($(ARCH),i386)
++ ifeq ($(ARCH),x86)
Q3OBJ += $(B)/client/vm_x86.o
endif
- ifeq ($(ARCH),x86)
-- Q3OBJ += $(B)/client/vm_x86.o
-- endif
++ ifeq ($(ARCH),i386)
+ Q3OBJ += $(B)/client/vm_x86.o
+ endif
- ifeq ($(ARCH),x86_64)
+ ifeq ($(ARCH),amd64)
Q3OBJ += $(B)/client/vm_x86_64.o
@@ -282,20 +310,29 @@
Q3OBJ += $(B)/client/$(VM_PPC).o
endif
endif
-@@ -1017,10 +1025,10 @@
+@@ -1071,7 +1075,7 @@
+
+ ifeq ($(USE_SDL),1)
+ ifneq ($(PLATFORM),darwin)
+- BUILD_CLIENT_SMP = 0
++ #BUILD_CLIENT_SMP = 0
+ endif
+ endif
+
+@@ -1084,10 +1088,10 @@
$(B)/client/sdl_glimp_smp.o
endif
--$(B)/ioquake3.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ) $(LIBSDLMAIN)
-+$(B)/ioquake3$(BINEXT): $(Q3OBJ) $(Q3POBJ) $(LIBSDLMAIN)
+-$(B)/ioUrbanTerror.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ) $(LIBSDLMAIN)
++$(B)/ioUrbanTerror$(BINEXT): $(Q3OBJ) $(Q3POBJ) $(LIBSDLMAIN)
$(CC) -o $@ $(Q3OBJ) $(Q3POBJ) $(CLIENT_LDFLAGS) $(LDFLAGS) $(LIBSDLMAIN)
--$(B)/ioquake3-smp.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ_SMP) $(LIBSDLMAIN)
-+$(B)/ioquake3-smp$(BINEXT): $(Q3OBJ) $(Q3POBJ_SMP) $(LIBSDLMAIN)
+-$(B)/ioUrbanTerror-smp.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ_SMP) $(LIBSDLMAIN)
++$(B)/ioUrbanTerror-smp$(BINEXT): $(Q3OBJ) $(Q3POBJ_SMP) $(LIBSDLMAIN)
$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) $(CLIENT_LDFLAGS) \
$(THREAD_LDFLAGS) $(LDFLAGS) $(LIBSDLMAIN)
-@@ -1056,6 +1064,7 @@
+@@ -1124,6 +1128,7 @@
$(B)/client/snd_codec.o : $(CDIR)/snd_codec.c; $(DO_CC)
$(B)/client/snd_codec_wav.o : $(CDIR)/snd_codec_wav.c; $(DO_CC)
$(B)/client/snd_codec_ogg.o : $(CDIR)/snd_codec_ogg.c; $(DO_CC)
@@ -303,13 +340,18 @@
$(B)/client/qal.o : $(CDIR)/qal.c; $(DO_CC)
$(B)/client/snd_openal.o : $(CDIR)/snd_openal.c; $(DO_CC)
-@@ -1317,18 +1326,15 @@
- ifeq ($(ARCH),i386)
+@@ -1389,21 +1394,21 @@
+ endif
+
+ ifeq ($(HAVE_VM_COMPILED),true)
+- ifeq ($(ARCH),i386)
++ ifeq ($(ARCH),x86)
Q3DOBJ += $(B)/ded/vm_x86.o
endif
- ifeq ($(ARCH),x86)
-- Q3DOBJ += $(B)/ded/vm_x86.o
-- endif
++ ifeq ($(ARCH),i386)
+ Q3DOBJ += $(B)/ded/vm_x86.o
+ endif
- ifeq ($(ARCH),x86_64)
+ ifeq ($(ARCH),amd64)
Q3DOBJ += $(B)/ded/vm_x86_64.o
@@ -320,12 +362,12 @@
endif
endif
--$(B)/ioq3ded.$(ARCH)$(BINEXT): $(Q3DOBJ)
-+$(B)/ioq3ded$(BINEXT): $(Q3DOBJ)
+-$(B)/ioUrTded.$(ARCH)$(BINEXT): $(Q3DOBJ)
++$(B)/ioUrTded$(BINEXT): $(Q3DOBJ)
$(CC) -o $@ $(Q3DOBJ) $(LDFLAGS)
- $(B)/ded/sv_bot.o : $(SDIR)/sv_bot.c; $(DO_DED_CC)
-@@ -1445,7 +1451,7 @@
+ $(B)/ded/sv_battleye.o : $(SDIR)/sv_battleye.c; $(DO_DED_CC)
+@@ -1522,7 +1527,7 @@
Q3CGOBJ = $(Q3CGOBJ_) $(B)/baseq3/cgame/cg_syscalls.o
Q3CGVMOBJ = $(Q3CGOBJ_:%.o=%.asm) $(B)/baseq3/game/bg_lib.asm
@@ -334,7 +376,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(Q3CGOBJ)
$(B)/baseq3/vm/cgame.qvm: $(Q3CGVMOBJ) $(CGDIR)/cg_syscalls.asm
-@@ -1486,7 +1492,7 @@
+@@ -1563,7 +1568,7 @@
MPCGOBJ = $(MPCGOBJ_) $(B)/missionpack/cgame/cg_syscalls.o
MPCGVMOBJ = $(MPCGOBJ_:%.o=%.asm) $(B)/missionpack/game/bg_lib.asm
@@ -343,7 +385,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(MPCGOBJ)
$(B)/missionpack/vm/cgame.qvm: $(MPCGVMOBJ) $(CGDIR)/cg_syscalls.asm
-@@ -1536,7 +1542,7 @@
+@@ -1613,7 +1618,7 @@
Q3GOBJ = $(Q3GOBJ_) $(B)/baseq3/game/g_syscalls.o
Q3GVMOBJ = $(Q3GOBJ_:%.o=%.asm) $(B)/baseq3/game/bg_lib.asm
@@ -352,7 +394,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(Q3GOBJ)
$(B)/baseq3/vm/qagame.qvm: $(Q3GVMOBJ) $(GDIR)/g_syscalls.asm
-@@ -1584,7 +1590,7 @@
+@@ -1661,7 +1666,7 @@
MPGOBJ = $(MPGOBJ_) $(B)/missionpack/game/g_syscalls.o
MPGVMOBJ = $(MPGOBJ_:%.o=%.asm) $(B)/missionpack/game/bg_lib.asm
@@ -361,7 +403,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(MPGOBJ)
$(B)/missionpack/vm/qagame.qvm: $(MPGVMOBJ) $(GDIR)/g_syscalls.asm
-@@ -1644,7 +1650,7 @@
+@@ -1721,7 +1726,7 @@
Q3UIOBJ = $(Q3UIOBJ_) $(B)/missionpack/ui/ui_syscalls.o
Q3UIVMOBJ = $(Q3UIOBJ_:%.o=%.asm) $(B)/baseq3/game/bg_lib.asm
@@ -370,7 +412,7 @@
$(CC) $(CFLAGS) $(SHLIBLDFLAGS) -o $@ $(Q3UIOBJ)
$(B)/baseq3/vm/ui.qvm: $(Q3UIVMOBJ) $(UIDIR)/ui_syscalls.asm
-@@ -1669,7 +1675,7 @@
+@@ -1746,7 +1751,7 @@
MPUIOBJ = $(MPUIOBJ_) $(B)/missionpack/ui/ui_syscalls.o
MPUIVMOBJ = $(MPUIOBJ_:%.o=%.asm) $(B)/baseq3/game/bg_lib.asm
diff --git a/games/iourbanterror/pkg-descr b/games/iourbanterror/pkg-descr
index d49d4c07954b..0adb28e44079 100644
--- a/games/iourbanterror/pkg-descr
+++ b/games/iourbanterror/pkg-descr
@@ -1,11 +1,12 @@
-This project, icculus.org/quake3 (sometimes referred to ioquake3, or ioq3 for
-short) aims to build upon id Software's Quake 3 source code release. The
-source code was released on August 20, 2005 under the GPL. Since then, we have
-been cleaning up, fixing bugs, and adding features. Our permanent goal is to
-create the open source Quake 3 distribution upon which people base their games
-and projects. We also seek to have the perfect version of the engine for
-playing Quake 3: Arena, Team Arena, and all popular mods. This distribution of
-the engine has been ported to many new platforms and has had a slew of new
-features added, along with massive bug extermination.
+Urban Terror is a realism based total conversion mod for Quake III Arena which
+no longer requires this game to be played. It only uses its engine, which is
+open sourced through the GPL and may be distributed freely. Urban Terror plays
+in about the same setting as Counter Strike, but is less focused on realism
+and plays much faster, which among other things, is caused by the ability to
+strafe jump, which combined with wall jumping can lead to very quick movement
+and nice jumps. Urban Terror has 7 game modes, 25 maps and 15 weapons.
-WWW: http://ioquake3.org/
+This port installs the modified ioquake3 engine for Urban Terror called
+ioUrbanTerror, and depends on the data, resulting in a playable game.
+
+WWW: http://ftp.snt.utwente.nl/pub/games/urbanterror/iourbanterror/source/
diff --git a/games/iourbanterror/pkg-message b/games/iourbanterror/pkg-message
index 1f128f1231e9..37847a24d3bc 100644
--- a/games/iourbanterror/pkg-message
+++ b/games/iourbanterror/pkg-message
@@ -7,8 +7,8 @@ If you have sound problems with OpenAL recompile without it. Also the OPENAL
option causes the program to omit restoring gamma and mouse sensivity after
exitting.
-The configuration files are saved to ~/.ioquake3 instead of ~/.q3a because
-they have additional variables which would be removed if other engines
+The configuration files are saved to ~/.ioUrbanTerror instead of ~/.q3a
+because they have additional variables which would be removed if other engines
overwrite them. But you can safely copy the original directory to the new one
for the first time.
diff --git a/games/iourbanterror/pkg-plist b/games/iourbanterror/pkg-plist
index d40d035630d5..dfd078238ae7 100644
--- a/games/iourbanterror/pkg-plist
+++ b/games/iourbanterror/pkg-plist
@@ -1,6 +1,6 @@
-%%DEDICATED%%bin/ioq3ded
-%%CLIENT%%bin/ioquake3
-%%SMP%%bin/ioquake3-smp
+%%DEDICATED%%bin/ioUrTded
+%%CLIENT%%bin/ioUrbanTerror
+%%SMP%%bin/ioUrbanTerror-smp
%%GAMELIBS%%%%LIBDIR%%/baseq3/cgame.so
%%GAMELIBS%%%%LIBDIR%%/baseq3/qagame.so
%%GAMELIBS%%%%LIBDIR%%/baseq3/ui.so
@@ -8,6 +8,7 @@
%%GAMELIBS%%%%LIBDIR%%/missionpack/qagame.so
%%GAMELIBS%%%%LIBDIR%%/missionpack/ui.so
%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/ioUrbanTerror_README.txt
%%GAMELIBS%%@dirrm %%LIBDIR%%/missionpack
%%GAMELIBS%%@dirrm %%LIBDIR%%/baseq3
%%GAMELIBS%%@dirrm %%LIBDIR%%