aboutsummaryrefslogtreecommitdiff
path: root/games/ivan
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-11-27 19:47:06 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-11-27 19:47:06 +0000
commit54b480fbc3ea9c3943536faa41d82e6c67d03520 (patch)
tree28f4fcebc9451b5845c742dd08ce2584db44e37e /games/ivan
parent5e7269ce123b96b9eab6b8fc851ce175baea73ef (diff)
downloadports-54b480fbc3ea9c3943536faa41d82e6c67d03520.tar.gz
ports-54b480fbc3ea9c3943536faa41d82e6c67d03520.zip
Notes
Diffstat (limited to 'games/ivan')
-rw-r--r--games/ivan/Makefile9
-rw-r--r--games/ivan/pkg-install15
-rw-r--r--games/ivan/pkg-plist9
3 files changed, 12 insertions, 21 deletions
diff --git a/games/ivan/Makefile b/games/ivan/Makefile
index 59ee68d7f07e..bec41346b9c6 100644
--- a/games/ivan/Makefile
+++ b/games/ivan/Makefile
@@ -3,13 +3,16 @@
PORTNAME= ivan
PORTVERSION= 0.50
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/IVAN/IVAN%20${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Graphical roguelike game
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_SDL= sdl
USES= gmake
GNU_CONFIGURE= yes
@@ -33,4 +36,8 @@ post-patch:
${WRKSRC}/Main/Include/stack.h ${WRKSRC}/Main/Source/lsquare.cpp \
${WRKSRC}/Main/Source/lterras.cpp
+post-install:
+ ${MKDIR} ${STAGEDIR}/var/games/ivan/Bones
+ ${TOUCH} ${STAGEDIR}/var/games/ivan/ivan-highscore.scores.sample
+
.include <bsd.port.mk>
diff --git a/games/ivan/pkg-install b/games/ivan/pkg-install
deleted file mode 100644
index d3a81f914d2e..000000000000
--- a/games/ivan/pkg-install
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-
-STATEDIR="/var/games/ivan"
-
-[ "$2" != "POST-INSTALL" -o -d "$SCOREDIR" ] && exit 0
-
-echo "Creating state directory..."
-
-mkdir -p "$STATEDIR"
-touch "$STATEDIR/ivan-highscore.scores"
-mkdir -p "$STATEDIR/Bones"
-chgrp -R games "$STATEDIR"
-chmod -R g+w "$STATEDIR"
diff --git a/games/ivan/pkg-plist b/games/ivan/pkg-plist
index 18adaf7fd62a..499d0079211a 100644
--- a/games/ivan/pkg-plist
+++ b/games/ivan/pkg-plist
@@ -1,5 +1,4 @@
-@group games
-@mode 2555
-bin/ivan
-@mode
-@group
+@(,games,2555) bin/ivan
+@sample(,games,664) /var/games/ivan/ivan-highscore.scores.sample
+@dir(,games,775) /var/games/ivan/Bones
+@dir(,games,775) /var/games/ivan