aboutsummaryrefslogtreecommitdiff
path: root/games/jaggedalliance2
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2016-01-11 21:28:55 +0000
committerLars Engels <lme@FreeBSD.org>2016-01-11 21:28:55 +0000
commit1872d73923c1d8081f91070be69ecab6d1b1abda (patch)
treebd5feb189dc72fcf989f3ccb97e62357d4059c29 /games/jaggedalliance2
parente3bb08d25b7e5fbf67139eeb568eabde72046f8e (diff)
downloadports-1872d73923c1d8081f91070be69ecab6d1b1abda.tar.gz
ports-1872d73923c1d8081f91070be69ecab6d1b1abda.zip
Notes
Diffstat (limited to 'games/jaggedalliance2')
-rw-r--r--games/jaggedalliance2/Makefile68
-rw-r--r--games/jaggedalliance2/distinfo4
-rw-r--r--games/jaggedalliance2/files/patch-Makefile25
-rw-r--r--games/jaggedalliance2/files/patch-configure11
-rw-r--r--games/jaggedalliance2/files/patch-sgp__MemMan.cc10
-rw-r--r--games/jaggedalliance2/files/pkg-message.in15
-rw-r--r--games/jaggedalliance2/pkg-descr2
-rw-r--r--games/jaggedalliance2/pkg-plist70
8 files changed, 130 insertions, 75 deletions
diff --git a/games/jaggedalliance2/Makefile b/games/jaggedalliance2/Makefile
index f82e600fff82..0242495a6f68 100644
--- a/games/jaggedalliance2/Makefile
+++ b/games/jaggedalliance2/Makefile
@@ -2,68 +2,40 @@
# $FreeBSD$
PORTNAME= ja2
-PORTVERSION= 0.12.1
-DISTVERSIONSUFFIX= -source
-PORTREVISION= 3
+PORTVERSION= 0.14.01
CATEGORIES= games
-MASTER_SITES= http://deponie.yamagi.org/freebsd/distfiles/ \
- http://tron.homeunix.org/ja2/
+MASTER_SITES= https://bitbucket.org/gennady/ja2-stracciatella/get/
+DISTNAME= v${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
MAINTAINER= lme@FreeBSD.org
COMMENT= Port of "Jagged Alliance 2" using SDL
-BROKEN= unfetchable
-
# Ignore this if you feel adventurous
ONLY_FOR_ARCHS= amd64 arm i386 pc98
ONLY_FOR_ARCHS_REASON= Needs a little endian environment
-USES= gmake tar:bzip2
-USE_SDL= sdl
-NO_CDROM= License only permits non-commerical use
-NO_PACKAGE= Language of the datafiles must be hardcoded in the game binary
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-SUB_FILES= pkg-message
-
-OPTIONS_SINGLE= LANGUAGE
-OPTIONS_SINGLE_LANGUAGE= DUTCH ENGLISH FRENCH GERMAN ITALIAN POLISH RUSSIAN RUSSIAN_GOLD
-OPTIONS_DEFAULT= ENGLISH
-DUTCH_DESC= Compile for Dutch version
-ENGLISH_DESC= Compile for English version
-FRENCH_DESC= Compile for French version
-GERMAN_DESC= Compile for German version
-ITALIAN_DESC= Compile for Italian version
-POLISH_DESC= Compile for Polish version
-RUSSIAN_DESC= Compile for Russian version
-RUSSIAN_GOLD_DESC= Compile for Russian Gold version
-
-.include <bsd.port.options.mk>
-
-.for i in ${OPTIONS_SINGLE_LANGUAGE}
-. if ${PORT_OPTIONS:M${i}}
-MAKE_ARGS+= LNG=${i}
-. endif
-.endfor
+NO_CDROM= License only permits non-commerical use
-MAKE_ARGS+= NO_DEPS=yes # For a single full build dependency calculation is unnecessary
+USES= gmake tar:bzip2
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+USE_SDL= sdl
-MAKE_ARGS+= SGPDATADIR=${STAGEDIR}${DATADIR}
+MAKE_ENV= Q=
-MAKE_ARGS+= ${INSTALL_MACROS:S/BSD_//}
+WRKSRC= ${WRKDIR}/gennady-ja2-stracciatella-5585014471a7
+SUB_FILES= pkg-message
-MAKE_ARGS+= PREFIX=${STAGEDIR}${PREFIX} MANPREFIX=${STAGEDIR}${PREFIX}
+post-patch:
+ @${REINPLACE_CMD} -e 's|/some/place/where/the/data/is|${DATADIR}|' \
+ ${WRKSRC}/sgp/SGP.cc
post-install:
- @${MKDIR} ${STAGEDIR}${DATADIR}/Data/TILECACHE
-
-lowercase:
- @for i in \
- ${STAGEDIR}${DATADIR}/Data/*.[Ss][Ll][Ff] \
- ${STAGEDIR}${DATADIR}/Data/TILECACHE/*.[Jj][Ss][Dd] \
- ${STAGEDIR}${DATADIR}/Data/TILECACHE/*.[Ss][Tt][Ii]; \
- do \
- ${MV} -n $$i `${DIRNAME} $$i`/`${BASENAME} $$i | ${TR} '[A-Z]' '[a-z]'`; \
- done
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ja2
+ ${INSTALL_DATA} ${WRKSRC}/_build/distr-files-linux/ja2-stracciatella.desktop \
+ ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/Build/Res/jagged3.ico \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/jagged2.ico
.include <bsd.port.mk>
diff --git a/games/jaggedalliance2/distinfo b/games/jaggedalliance2/distinfo
index 784a28313b9f..21065c8e0f24 100644
--- a/games/jaggedalliance2/distinfo
+++ b/games/jaggedalliance2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ja2-0.12.1-source.tar.bz2) = c29bef2b4ba3f28b808b18d3d4c4388be85f255e9c6d9c355b8080de33fc18d1
-SIZE (ja2-0.12.1-source.tar.bz2) = 2305303
+SHA256 (ja2/v0.14.01.tar.bz2) = 53ba2fa928eded7e1c1e574407fb814234a7040ebd3a28e4000f6d834b110350
+SIZE (ja2/v0.14.01.tar.bz2) = 7752070
diff --git a/games/jaggedalliance2/files/patch-Makefile b/games/jaggedalliance2/files/patch-Makefile
new file mode 100644
index 000000000000..26bbb9afb799
--- /dev/null
+++ b/games/jaggedalliance2/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig 2014-05-09 20:51:45 UTC
++++ Makefile
+@@ -607,14 +607,14 @@ clean distclean:
+ $(Q)rm -fr $(DEPS) $(OBJS) $(BINARY)
+
+ install: $(BINARY)
+- test -z "$(INSTALLABLE)" || install -d $(BINARY_DIR)
+- test -z "$(INSTALLABLE)" || install -d $(MANPAGE_DIR)
+- test -z "$(INSTALLABLE)" || install -d $(FULL_PATH_EXTRA_DATA_DIR)
+- test -z "$(INSTALLABLE)" || install -m 555 $(BINARY) $(BINARY_DIR)
+- test -z "$(INSTALLABLE)" || cp -r externalized $(FULL_PATH_EXTRA_DATA_DIR)
+- test -z "$(INSTALLABLE)" || cp -r mods $(FULL_PATH_EXTRA_DATA_DIR)
+- test -z "$(INSTALLABLE)" || cp -r _unittests $(FULL_PATH_EXTRA_DATA_DIR)
+- test -z "$(INSTALLABLE)" || install -m 444 ja2_manpage $(MANPAGE_DIR)/ja2.6
++ test -z "$(INSTALLABLE)" || install -d ${DESTDIR}$(BINARY_DIR)
++ test -z "$(INSTALLABLE)" || install -d ${DESTDIR}$(MANPAGE_DIR)
++ test -z "$(INSTALLABLE)" || install -d ${DESTDIR}$(FULL_PATH_EXTRA_DATA_DIR)
++ test -z "$(INSTALLABLE)" || install -m 555 $(BINARY) ${DESTDIR}$(BINARY_DIR)
++ test -z "$(INSTALLABLE)" || cp -r externalized ${DESTDIR}$(FULL_PATH_EXTRA_DATA_DIR)
++ test -z "$(INSTALLABLE)" || cp -r mods ${DESTDIR}$(FULL_PATH_EXTRA_DATA_DIR)
++ test -z "$(INSTALLABLE)" || cp -r _unittests ${DESTDIR}$(FULL_PATH_EXTRA_DATA_DIR)
++ test -z "$(INSTALLABLE)" || install -m 444 ja2_manpage ${DESTDIR}$(MANPAGE_DIR)/ja2.6
+
+ @test -n "$(INSTALLABLE)" || echo "------------------------------------------------------------------------------"
+ @test -n "$(INSTALLABLE)" || echo "This build doesn't support installation."
diff --git a/games/jaggedalliance2/files/patch-configure b/games/jaggedalliance2/files/patch-configure
new file mode 100644
index 000000000000..911723f0e28d
--- /dev/null
+++ b/games/jaggedalliance2/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2014-05-09 20:51:45 UTC
++++ configure
+@@ -47,7 +47,7 @@ fi
+ # writing Makefile.config
+ echo "# configuration options" >Makefile.config
+ echo "BINARY_DIR := $PREFIX/bin" >>Makefile.config
+-echo "MANPAGE_DIR := $PREFIX/share/man/man6" >>Makefile.config
++echo "MANPAGE_DIR := $PREFIX/man/man6" >>Makefile.config
+ echo "FULL_PATH_EXTRA_DATA_DIR := $PREFIX/share/ja2" >>Makefile.config
+ echo "INSTALLABLE := yes" >>Makefile.config
+
diff --git a/games/jaggedalliance2/files/patch-sgp__MemMan.cc b/games/jaggedalliance2/files/patch-sgp__MemMan.cc
deleted file mode 100644
index c46fba824763..000000000000
--- a/games/jaggedalliance2/files/patch-sgp__MemMan.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./sgp/MemMan.cc.orig 2013-09-28 16:08:40.756136684 +0200
-+++ ./sgp/MemMan.cc 2013-09-28 16:09:05.355134574 +0200
-@@ -5,6 +5,7 @@
- // 11sep96:HJH - Creation
- // 29may97:ARM - Fix & improve MemDebugCounter handling, logging of
- // MemAlloc/MemFree, and reporting of any errors
-+#include <new>
- #include <stdexcept>
-
- #include "Types.h"
diff --git a/games/jaggedalliance2/files/pkg-message.in b/games/jaggedalliance2/files/pkg-message.in
index 93ea9d2911e9..e57582dfec3b 100644
--- a/games/jaggedalliance2/files/pkg-message.in
+++ b/games/jaggedalliance2/files/pkg-message.in
@@ -1,18 +1,7 @@
==========================================================================
This Jagged Alliance 2 port requires data files from the original
- game CD and installation. Copy the following files:
-
- Put all *.slf files into %%DATADIR%%/Data.
- Put all *.jsd and *.sti files from the TILECACHE directory into
- %%DATADIR%%/Data/TILECACHE.
- All filenames must be lowercase!
- After copying you can use "make lowercase" to rename all files.
-
- When a user starts the game for the first time a file ~/.ja2/ja2.ini
- is created. In there the path to the data files has to be specified at
- the line "data_dir = ...".
-
- Enjoy!
+ game CD and installation. Copy Data/ directory from original game
+ into %%DATADIR%%/
==========================================================================
diff --git a/games/jaggedalliance2/pkg-descr b/games/jaggedalliance2/pkg-descr
index 7c6e947b4043..b03e792bf4d1 100644
--- a/games/jaggedalliance2/pkg-descr
+++ b/games/jaggedalliance2/pkg-descr
@@ -3,4 +3,4 @@ mercenaries to liberate the small country of Arulco.
You need an original game CD and installation to use this port.
-WWW: http://tron.homeunix.org/ja2/
+WWW: https://bitbucket.org/gennady/ja2-stracciatella
diff --git a/games/jaggedalliance2/pkg-plist b/games/jaggedalliance2/pkg-plist
index d17fea6037c6..2c935f3e4a4c 100644
--- a/games/jaggedalliance2/pkg-plist
+++ b/games/jaggedalliance2/pkg-plist
@@ -1,5 +1,73 @@
bin/ja2
man/man6/ja2.6.gz
share/applications/ja2-stracciatella.desktop
+%%DATADIR%%/_unittests/datatypes/doubles.bin
+%%DATADIR%%/_unittests/datatypes/floats.bin
+%%DATADIR%%/_unittests/find-files/file-without-extension
+%%DATADIR%%/_unittests/find-files/lowercase-ext.txt
+%%DATADIR%%/_unittests/find-files/subfolder/file.txt
+%%DATADIR%%/_unittests/find-files/uppercase-ext.TXT
+%%DATADIR%%/_unittests/saves/strac-linux/SaveGame01.sav
+%%DATADIR%%/_unittests/saves/strac-macos/SaveGame09.sav
+%%DATADIR%%/_unittests/saves/strac-macos/imp.dat
+%%DATADIR%%/_unittests/saves/strac-win/SaveGame09.sav
+%%DATADIR%%/_unittests/saves/vanilla-russian/IMP.dat
+%%DATADIR%%/_unittests/saves/vanilla-russian/SaveGame06.sav
+%%DATADIR%%/externalized/ammo_types.json
+%%DATADIR%%/externalized/army-gun-choice-extended.json
+%%DATADIR%%/externalized/army-gun-choice-normal.json
+%%DATADIR%%/externalized/bobby-ray-inventory-new.json
+%%DATADIR%%/externalized/bobby-ray-inventory-used.json
+%%DATADIR%%/externalized/calibres.json
+%%DATADIR%%/externalized/dealer-inventory-alberto-santos.json
+%%DATADIR%%/externalized/dealer-inventory-arnie.json
+%%DATADIR%%/externalized/dealer-inventory-carlo-santos.json
+%%DATADIR%%/externalized/dealer-inventory-devin.json
+%%DATADIR%%/externalized/dealer-inventory-elgin.json
+%%DATADIR%%/externalized/dealer-inventory-frank.json
+%%DATADIR%%/externalized/dealer-inventory-franz.json
+%%DATADIR%%/externalized/dealer-inventory-fredo.json
+%%DATADIR%%/externalized/dealer-inventory-gabby.json
+%%DATADIR%%/externalized/dealer-inventory-herve-santos.json
+%%DATADIR%%/externalized/dealer-inventory-howard.json
+%%DATADIR%%/externalized/dealer-inventory-jake.json
+%%DATADIR%%/externalized/dealer-inventory-keith.json
+%%DATADIR%%/externalized/dealer-inventory-manny.json
+%%DATADIR%%/externalized/dealer-inventory-micky.json
+%%DATADIR%%/externalized/dealer-inventory-perko.json
+%%DATADIR%%/externalized/dealer-inventory-peter-santos.json
+%%DATADIR%%/externalized/dealer-inventory-sam.json
+%%DATADIR%%/externalized/dealer-inventory-tony.json
+%%DATADIR%%/externalized/game.json
+%%DATADIR%%/externalized/imp.json
+%%DATADIR%%/externalized/magazines.json
+%%DATADIR%%/externalized/readme.txt
+%%DATADIR%%/externalized/strings/ammo-calibre-bobbyray-dut.json
+%%DATADIR%%/externalized/strings/ammo-calibre-bobbyray-eng.json
+%%DATADIR%%/externalized/strings/ammo-calibre-bobbyray-fr.json
+%%DATADIR%%/externalized/strings/ammo-calibre-bobbyray-ger.json
+%%DATADIR%%/externalized/strings/ammo-calibre-bobbyray-it.json
+%%DATADIR%%/externalized/strings/ammo-calibre-bobbyray-pl.json
+%%DATADIR%%/externalized/strings/ammo-calibre-bobbyray-rus.json
+%%DATADIR%%/externalized/strings/ammo-calibre-dut.json
+%%DATADIR%%/externalized/strings/ammo-calibre-eng.json
+%%DATADIR%%/externalized/strings/ammo-calibre-fr.json
+%%DATADIR%%/externalized/strings/ammo-calibre-ger.json
+%%DATADIR%%/externalized/strings/ammo-calibre-it.json
+%%DATADIR%%/externalized/strings/ammo-calibre-pl.json
+%%DATADIR%%/externalized/strings/ammo-calibre-rus.json
+%%DATADIR%%/externalized/strings/new-strings-dut.json
+%%DATADIR%%/externalized/strings/new-strings-eng.json
+%%DATADIR%%/externalized/strings/new-strings-fr.json
+%%DATADIR%%/externalized/strings/new-strings-ger.json
+%%DATADIR%%/externalized/strings/new-strings-it.json
+%%DATADIR%%/externalized/strings/new-strings-pl.json
+%%DATADIR%%/externalized/strings/new-strings-rus.json
+%%DATADIR%%/externalized/weapons.json
+%%DATADIR%%/mods/from-russia-with-love/data/maps/A9.dat
+%%DATADIR%%/mods/from-russia-with-love/license.txt
+%%DATADIR%%/mods/from-russia-with-love/readme.txt
+%%DATADIR%%/mods/readme.txt
+%%DATADIR%%/mods/test-json-dialogs/data/mercedt/009.edt.json
+%%DATADIR%%/mods/test-json-dialogs/readme.txt
share/pixmaps/jagged2.ico
-@dir %%DATADIR%%/Data/TILECACHE