aboutsummaryrefslogtreecommitdiff
path: root/games/jigzo/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-09-11 21:57:40 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-09-11 21:57:40 +0000
commit41f778ba31397ede79e70f0645c853afd439b4fb (patch)
treec8bf4ed4f92ac6e22e4da669b18ec0e12d62b125 /games/jigzo/Makefile
parent767960debff163320425110d5d4b5f6c89da4888 (diff)
- Add DESKTOP_ENTRY to bunch of ports
- Mark some ports MAKE_JOBS_SAFE
Notes
Notes: svn path=/head/; revision=241249
Diffstat (limited to 'games/jigzo/Makefile')
-rw-r--r--games/jigzo/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/games/jigzo/Makefile b/games/jigzo/Makefile
index b3bba0f79f1d..757109a7fd5c 100644
--- a/games/jigzo/Makefile
+++ b/games/jigzo/Makefile
@@ -22,9 +22,17 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
USE_SDL= sdl mixer
USE_GL= gl
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
PORTDOCS= *
+DESKTOP_ENTRIES="Jigzo" \
+ "An OpenGL jigsaw puzzle game" \
+ "" \
+ "jigzo" \
+ "Game;LogicGame;KidsGame;" \
+ false
+
post-patch:
.for i in font image puzzles sound
@${REINPLACE_CMD} -e "s|${i}/|${DATADIR}/${i}/|g" \