aboutsummaryrefslogtreecommitdiff
path: root/games/jinput
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-17 00:28:16 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-17 00:28:16 +0000
commit74d73173c2e15aca00a6709e8c6b5545f013c507 (patch)
tree519523c2f7fd22c2e096c05f01d3dc27ade567ea /games/jinput
parentbbb141173387f3dc5a7af4f5bf5d010f85e1519f (diff)
downloadports-74d73173c2e15aca00a6709e8c6b5545f013c507.tar.gz
ports-74d73173c2e15aca00a6709e8c6b5545f013c507.zip
Notes
Diffstat (limited to 'games/jinput')
-rw-r--r--games/jinput/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/games/jinput/Makefile b/games/jinput/Makefile
index 14d80f5684ec..a14ee9ff1d51 100644
--- a/games/jinput/Makefile
+++ b/games/jinput/Makefile
@@ -23,15 +23,16 @@ ALL_TARGET= simple_linux
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}/${PORTNAME}.jar
PLIST_DIRS= %%JAVAJARDIR%%/${PORTNAME}
-NO_STAGE= yes
post-patch:
@${LN} -sf ${JAVALIBDIR}/jutils/jutils.jar ${WRKSRC}/lib/
+do-build:
+ @(cd ${BUILD_WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${ANT} ${ALL_TARGET})
+
do-install:
- @${ECHO_MSG} -n ">> Install JAR files in ${JAVAJARDIR}/${PORTNAME}/ ..."
- @${MKDIR} ${JAVAJARDIR}/${PORTNAME}
- @${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}.jar \
- ${JAVAJARDIR}/${PORTNAME}/
- @${ECHO_MSG} " [ DONE ]"
+ @${MKDIR} ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}.jar \
+ ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}/
.include <bsd.port.mk>