aboutsummaryrefslogtreecommitdiff
path: root/games/joequake/files
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-05-20 13:29:07 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-05-20 13:29:07 +0000
commit624ff389260361caf9d25712603a83871538cc24 (patch)
tree76d253266f0ec1dfd0184c2b3b3356efd2b5c247 /games/joequake/files
parent6d24ec16df8d183320c8db32383c6acdb919657b (diff)
downloadports-624ff389260361caf9d25712603a83871538cc24.tar.gz
ports-624ff389260361caf9d25712603a83871538cc24.zip
Notes
Diffstat (limited to 'games/joequake/files')
-rw-r--r--games/joequake/files/patch-Makefile.linux24
-rw-r--r--games/joequake/files/patch-cd_linux.c4
-rw-r--r--games/joequake/files/patch-cl_slist.c4
-rw-r--r--games/joequake/files/patch-common.c20
-rw-r--r--games/joequake/files/patch-console.c4
-rw-r--r--games/joequake/files/patch-gl_screen.c10
-rw-r--r--games/joequake/files/patch-host.c8
-rw-r--r--games/joequake/files/patch-image.c4
-rw-r--r--games/joequake/files/patch-keys.c6
-rw-r--r--games/joequake/files/patch-net.h4
-rw-r--r--games/joequake/files/patch-r_part.c4
-rw-r--r--games/joequake/files/patch-r_screen.c4
-rw-r--r--games/joequake/files/patch-snd_linux.c4
-rw-r--r--games/joequake/files/patch-vid_glx.c4
-rw-r--r--games/joequake/files/patch-vid_x11.c6
15 files changed, 55 insertions, 55 deletions
diff --git a/games/joequake/files/patch-Makefile.linux b/games/joequake/files/patch-Makefile.linux
index 65edd59322c8..b3964d50a009 100644
--- a/games/joequake/files/patch-Makefile.linux
+++ b/games/joequake/files/patch-Makefile.linux
@@ -1,5 +1,5 @@
---- Makefile.linux.orig Wed Sep 7 20:11:50 2005
-+++ Makefile.linux Sun Jan 15 01:54:54 2006
+--- ./Makefile.linux.orig Sat Apr 22 12:10:56 2006
++++ ./Makefile.linux Sat May 20 10:03:52 2006
@@ -4,14 +4,25 @@
# by Slawomir Mazurek <homer13@o2.pl>
#
@@ -9,24 +9,24 @@
+# this nice line comes from the linux kernel makefile
+ARCH := $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc/ -e s/sparc64/sparc/ -e s/arm.*/arm/ -e s/sa110/arm/ -e s/alpha/axp/)
+OSTYPE := $(shell uname -s)
-+
+
+-################
+CC ?= gcc
+#_E := @
+LOCALBASE ?= /usr/local
+X11BASE ?= /usr/X11R6
+USE_OPTIMIZE ?= YES
-+
+
+-default_target: glx
+ifeq ($(ARCH),i386)
+USE_X86_ASM ?= YES
+else
-+USE_X86_ASM ?= NO
++USE_X86_ASM = NO
+endif
- ################
-
--default_target: glx
--
-all: glx x11 svga
++################
++
+all:
################################
@@ -40,7 +40,7 @@
- -funroll-loops -fomit-frame-pointer -DNDEBUG \
- -ffast-math -fno-strength-reduce -fexpensive-optimizations \
- -I/usr/include
-+CFLAGS += -DNDEBUG -DDATADIR='"$(DATADIR)"'
++CFLAGS += -DNDEBUG -DDATADIR='"$(Q1DIR)"'
+
+ifeq ($(strip $(USE_OPTIMIZE)),YES)
+CFLAGS += -O1 -funsigned-char -funroll-loops -fomit-frame-pointer \
@@ -51,7 +51,7 @@
@@ -75,19 +87,25 @@
image version security iplog \
- slist
+ cl_slist
+ifeq ($(strip $(USE_X86_ASM)),YES)
GLX_S_FILES := \
@@ -81,7 +81,7 @@
glx: _OBJS := $(GLX_C_OBJS) $(GLX_S_OBJS)
@@ -138,27 +156,37 @@
snd_linux image version security \
- iplog slist
+ iplog cl_slist
+ifeq ($(strip $(USE_X86_ASM)),YES)
X11_S_FILES := \
diff --git a/games/joequake/files/patch-cd_linux.c b/games/joequake/files/patch-cd_linux.c
index 674381f50c6c..c3ce342197e0 100644
--- a/games/joequake/files/patch-cd_linux.c
+++ b/games/joequake/files/patch-cd_linux.c
@@ -1,5 +1,5 @@
---- cd_linux.c.orig Sun Aug 14 10:09:04 2005
-+++ cd_linux.c Wed Dec 7 17:22:17 2005
+--- ./cd_linux.c.orig Sun Jan 8 20:08:58 2006
++++ ./cd_linux.c Sat May 20 10:00:24 2006
@@ -31,7 +31,11 @@
#include <time.h>
#include <errno.h>
diff --git a/games/joequake/files/patch-cl_slist.c b/games/joequake/files/patch-cl_slist.c
index 3a1aaa1d55df..4ea71fd66773 100644
--- a/games/joequake/files/patch-cl_slist.c
+++ b/games/joequake/files/patch-cl_slist.c
@@ -1,5 +1,5 @@
---- cl_slist.c.orig Sat Apr 22 13:34:10 2006
-+++ cl_slist.c Thu May 4 22:03:17 2006
+--- ./cl_slist.c.orig Sat Apr 22 13:34:10 2006
++++ ./cl_slist.c Sat May 20 10:00:24 2006
@@ -21,10 +21,13 @@
#include "quakedef.h"
diff --git a/games/joequake/files/patch-common.c b/games/joequake/files/patch-common.c
index cb61c32b334b..30fb529471b2 100644
--- a/games/joequake/files/patch-common.c
+++ b/games/joequake/files/patch-common.c
@@ -1,6 +1,6 @@
---- common.c.orig Sat Dec 3 19:45:26 2005
-+++ common.c Tue Jan 31 15:03:09 2006
-@@ -1634,14 +1634,18 @@
+--- ./common.c.orig Sun Jan 8 21:02:18 2006
++++ ./common.c Sat May 20 10:00:24 2006
+@@ -1646,14 +1646,18 @@
*/
void COM_InitFilesystem (void)
{
@@ -20,20 +20,20 @@
for (i=0 ; i < strlen(com_basedir) ; i++)
if (com_basedir[i] == '\\')
-@@ -1653,6 +1657,12 @@
+@@ -1665,7 +1669,12 @@
// start up with GAMENAME by default (id1)
COM_AddGameDirectory (va("%s/"GAMENAME, com_basedir));
-+
-+ if (home != NULL) {
-+ Q_snprintfz(homepath, sizeof(homepath), "%s/.joequake/"GAMENAME, home);
-+ COM_AddGameDirectory(homepath);
-+ }
++ if (home != NULL)
++ COM_AddGameDirectory(va("%s/.joequake/"GAMENAME, home));
+
COM_AddGameDirectory (va("%s/joequake", com_basedir));
++ if (home != NULL)
++ COM_AddGameDirectory(va("%s/.joequake/joequake", home));
if (COM_CheckParm("-rogue"))
-@@ -1675,4 +1685,11 @@
+ COM_AddGameDirectory (va("%s/rogue", com_basedir));
+@@ -1687,4 +1696,11 @@
// Adds basedir/gamedir as an override game
if ((i = COM_CheckParm("-game")) && i + 1 < com_argc)
COM_AddGameDirectory (va("%s/%s", com_basedir, com_argv[i+1]));
diff --git a/games/joequake/files/patch-console.c b/games/joequake/files/patch-console.c
index 30c44b957140..3bdb8166abc3 100644
--- a/games/joequake/files/patch-console.c
+++ b/games/joequake/files/patch-console.c
@@ -1,5 +1,5 @@
---- console.c.orig Sun Aug 14 09:38:36 2005
-+++ console.c Mon Jan 16 18:54:47 2006
+--- ./console.c.orig Sun Jan 8 18:27:46 2006
++++ ./console.c Sat May 20 10:00:24 2006
@@ -205,8 +205,11 @@
*/
void Con_Init (void)
diff --git a/games/joequake/files/patch-gl_screen.c b/games/joequake/files/patch-gl_screen.c
index 884de6a5e404..888b5e1144cd 100644
--- a/games/joequake/files/patch-gl_screen.c
+++ b/games/joequake/files/patch-gl_screen.c
@@ -1,6 +1,6 @@
---- gl_screen.c.orig Wed Sep 7 11:10:32 2005
-+++ gl_screen.c Mon Jan 16 20:20:05 2006
-@@ -734,8 +734,9 @@
+--- ./gl_screen.c.orig Sun Apr 16 16:15:48 2006
++++ ./gl_screen.c Sat May 20 10:00:24 2006
+@@ -728,8 +728,9 @@
void SCR_ScreenShot_f (void)
{
int i, success;
@@ -11,7 +11,7 @@
if (Cmd_Argc() == 2)
{
Q_strncpyz (name, Cmd_Argv(1), sizeof(name));
-@@ -753,7 +754,7 @@
+@@ -747,7 +748,7 @@
for (i=0 ; i<999 ; i++)
{
Q_snprintfz (name, sizeof(name), "joequake%03i.%s", i, ext);
@@ -20,7 +20,7 @@
break; // file doesn't exist
}
-@@ -769,7 +770,7 @@
+@@ -763,7 +764,7 @@
return;
}
diff --git a/games/joequake/files/patch-host.c b/games/joequake/files/patch-host.c
index 3bc894cfa4c0..429cb205239d 100644
--- a/games/joequake/files/patch-host.c
+++ b/games/joequake/files/patch-host.c
@@ -1,6 +1,6 @@
---- host.c.orig Wed Oct 26 10:21:22 2005
-+++ host.c Mon Jan 16 18:45:46 2006
-@@ -969,6 +969,7 @@
+--- ./host.c.orig Sun Apr 16 15:42:16 2006
++++ ./host.c Sat May 20 10:00:24 2006
+@@ -964,6 +964,7 @@
*/
void Host_Shutdown (void)
{
@@ -8,7 +8,7 @@
int i, j;
FILE *cmdhist;
cmdhistory_t cmdhistory;
-@@ -989,7 +990,8 @@
+@@ -984,7 +985,8 @@
Host_WriteConfiguration ();
IPLog_WriteLog ();
diff --git a/games/joequake/files/patch-image.c b/games/joequake/files/patch-image.c
index 76a95bc5361d..e5dce3ef01e5 100644
--- a/games/joequake/files/patch-image.c
+++ b/games/joequake/files/patch-image.c
@@ -1,5 +1,5 @@
---- image.c.orig Sun Oct 16 21:47:00 2005
-+++ image.c Mon Jan 16 20:18:54 2006
+--- ./image.c.orig Sun Oct 16 22:47:00 2005
++++ ./image.c Sat May 20 10:00:24 2006
@@ -422,6 +422,7 @@
buffer[i+2] = temp;
}
diff --git a/games/joequake/files/patch-keys.c b/games/joequake/files/patch-keys.c
index f4476c489606..f3ec6e6d2458 100644
--- a/games/joequake/files/patch-keys.c
+++ b/games/joequake/files/patch-keys.c
@@ -1,6 +1,6 @@
---- keys.c.orig Fri Oct 21 18:30:06 2005
-+++ keys.c Mon Jan 16 18:47:12 2006
-@@ -783,11 +783,13 @@
+--- ./keys.c.orig Sat Mar 25 15:00:04 2006
++++ ./keys.c Sat May 20 10:00:24 2006
+@@ -808,11 +808,13 @@
void Key_Init (void)
{
// joe: added stuff from [sons]Quake
diff --git a/games/joequake/files/patch-net.h b/games/joequake/files/patch-net.h
index 0a10eace4110..a88bea740195 100644
--- a/games/joequake/files/patch-net.h
+++ b/games/joequake/files/patch-net.h
@@ -1,5 +1,5 @@
---- net.h.orig Thu Jul 21 12:00:04 2005
-+++ net.h Mon Dec 5 21:11:16 2005
+--- ./net.h.orig Thu Jul 21 13:00:04 2005
++++ ./net.h Sat May 20 10:00:24 2006
@@ -258,7 +258,7 @@
extern int hostCacheCount;
extern hostcache_t hostcache[HOSTCACHESIZE];
diff --git a/games/joequake/files/patch-r_part.c b/games/joequake/files/patch-r_part.c
index 8c898863ca11..7ea779616fd6 100644
--- a/games/joequake/files/patch-r_part.c
+++ b/games/joequake/files/patch-r_part.c
@@ -1,5 +1,5 @@
---- r_part.c.orig Fri Aug 26 15:02:44 2005
-+++ r_part.c Sun Jan 15 02:00:02 2006
+--- ./r_part.c.orig Sat Apr 1 11:31:48 2006
++++ ./r_part.c Sat May 20 10:00:24 2006
@@ -59,7 +59,7 @@
vec3_t r_pright, r_pup, r_ppn;
diff --git a/games/joequake/files/patch-r_screen.c b/games/joequake/files/patch-r_screen.c
index 562ec987be6e..97a6f4798391 100644
--- a/games/joequake/files/patch-r_screen.c
+++ b/games/joequake/files/patch-r_screen.c
@@ -1,5 +1,5 @@
---- r_screen.c.orig Sat Oct 15 11:42:06 2005
-+++ r_screen.c Mon Jan 16 20:20:08 2006
+--- ./r_screen.c.orig Sun Jan 8 18:35:00 2006
++++ ./r_screen.c Sat May 20 10:00:24 2006
@@ -556,8 +556,9 @@
void SCR_ScreenShot_f (void)
{
diff --git a/games/joequake/files/patch-snd_linux.c b/games/joequake/files/patch-snd_linux.c
index 34aaa04641b0..99bdfa3653aa 100644
--- a/games/joequake/files/patch-snd_linux.c
+++ b/games/joequake/files/patch-snd_linux.c
@@ -1,5 +1,5 @@
---- snd_linux.c.orig Fri Sep 10 12:22:32 2004
-+++ snd_linux.c Mon Dec 5 20:05:40 2005
+--- ./snd_linux.c.orig Sun Jan 8 19:20:26 2006
++++ ./snd_linux.c Sat May 20 10:00:24 2006
@@ -25,7 +25,11 @@
#include <sys/mman.h>
#include <sys/shm.h>
diff --git a/games/joequake/files/patch-vid_glx.c b/games/joequake/files/patch-vid_glx.c
index 76db8a6a6a1c..684cce054c44 100644
--- a/games/joequake/files/patch-vid_glx.c
+++ b/games/joequake/files/patch-vid_glx.c
@@ -1,5 +1,5 @@
---- vid_glx.c.orig Sun Oct 16 17:40:58 2005
-+++ vid_glx.c Mon Dec 5 21:10:31 2005
+--- ./vid_glx.c.orig Sun Jan 8 18:36:04 2006
++++ ./vid_glx.c Sat May 20 10:00:24 2006
@@ -22,7 +22,9 @@
#include <termios.h>
#include <sys/ioctl.h>
diff --git a/games/joequake/files/patch-vid_x11.c b/games/joequake/files/patch-vid_x11.c
index 367e3c0b992e..c4b6e8e541d9 100644
--- a/games/joequake/files/patch-vid_x11.c
+++ b/games/joequake/files/patch-vid_x11.c
@@ -1,6 +1,6 @@
---- vid_x11.c.orig Mon Oct 17 10:08:06 2005
-+++ vid_x11.c Sun Jan 15 01:55:33 2006
-@@ -1052,3 +1052,13 @@
+--- ./vid_x11.c.orig Sat Mar 25 15:28:06 2006
++++ ./vid_x11.c Sat May 20 10:00:24 2006
+@@ -1053,3 +1053,13 @@
void VID_UnlockBuffer (void)
{
}