aboutsummaryrefslogtreecommitdiff
path: root/games/jtans
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-02-01 20:39:21 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-02-01 20:39:21 +0000
commit3ec4a5d59be452a4b469a21904742222f1d270f7 (patch)
treeff12f89f88dc2128df1d2423dedcf41c4e427ac7 /games/jtans
parentd585f804f176a504368327cac89d5b3b0db2f09a (diff)
Notes
Diffstat (limited to 'games/jtans')
-rw-r--r--games/jtans/Makefile12
-rw-r--r--games/jtans/files/jtans3
-rw-r--r--games/jtans/files/jtans.sh.in5
3 files changed, 12 insertions, 8 deletions
diff --git a/games/jtans/Makefile b/games/jtans/Makefile
index 91742dede7c5..9e599722765f 100644
--- a/games/jtans/Makefile
+++ b/games/jtans/Makefile
@@ -18,18 +18,20 @@ EXTRACT_SUFX= .jar
MAINTAINER= ports@FreeBSD.org
COMMENT= A (not so) ancient puzzle
+RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
+
NO_WRKSUBDIR= yes
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= .
-USE_JAVA= 1.3+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
NO_BUILD= yes
-
-post-patch:
- @${SED} 's,%%DATADIR%%,${DATADIR},' ${FILESDIR}/jtans > ${WRKSRC}/jtans
+SUB_FILES= jtans.sh
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/jtans ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/jtans.sh ${PREFIX}/bin/jtans
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/jtans_appli-1.0.jar ${DATADIR}
diff --git a/games/jtans/files/jtans b/games/jtans/files/jtans
deleted file mode 100644
index 37023904b41a..000000000000
--- a/games/jtans/files/jtans
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-java -jar %%DATADIR%%/jtans_appli-1.0.jar
diff --git a/games/jtans/files/jtans.sh.in b/games/jtans/files/jtans.sh.in
new file mode 100644
index 000000000000..195a4bf9de64
--- /dev/null
+++ b/games/jtans/files/jtans.sh.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+JAVA_VERSION="1.3+" "%%LOCALBASE%%/bin/java" -jar "%%DATADIR%%/jtans_appli-1.0.jar"