aboutsummaryrefslogtreecommitdiff
path: root/games/jutils
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-04-18 07:49:34 +0000
committerChris Rees <crees@FreeBSD.org>2012-04-18 07:49:34 +0000
commit8813f8a04398fd8243c4c020f731b26702759304 (patch)
tree8e40a63710fb48bd4b4ecb0703693361fb907a18 /games/jutils
parent4717508d1e2abc269d5b56962b7864fe81fb465b (diff)
downloadports-8813f8a04398fd8243c4c020f731b26702759304.tar.gz
ports-8813f8a04398fd8243c4c020f731b26702759304.zip
Notes
Diffstat (limited to 'games/jutils')
-rw-r--r--games/jutils/Makefile33
-rw-r--r--games/jutils/distinfo2
-rw-r--r--games/jutils/pkg-descr3
3 files changed, 38 insertions, 0 deletions
diff --git a/games/jutils/Makefile b/games/jutils/Makefile
new file mode 100644
index 000000000000..1a27bb6265de
--- /dev/null
+++ b/games/jutils/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: jinput
+# Date created: Mar 25 2012
+# Whom: loader <loader@freebsdmall.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jutils
+PORTVERSION= 20070610.r26
+CATEGORIES= games java
+MASTER_SITES= LOCAL/loader
+
+MAINTAINER= loader@freebsdmall.com
+COMMENT= Common utilities for Java Game Technology Group projects
+
+USE_BZIP2= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.6
+JAVA_OS= native
+JAVA_VENDOR= openjdk
+USE_ANT= YES
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}/${PORTNAME}.jar
+PLIST_DIRS= %%JAVAJARDIR%%/${PORTNAME}
+
+do-install:
+ @${ECHO_MSG} -n ">> Install JAR files in ${JAVAJARDIR}/${PORTNAME}/ ..."
+ @${MKDIR} ${JAVAJARDIR}/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/bin/${PORTNAME}.jar \
+ ${JAVAJARDIR}/${PORTNAME}/
+ @${ECHO_MSG} " [ DONE ]"
+
+.include <bsd.port.mk>
diff --git a/games/jutils/distinfo b/games/jutils/distinfo
new file mode 100644
index 000000000000..3d58f415ae7a
--- /dev/null
+++ b/games/jutils/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jutils-20070610.r26.tar.bz2) = ffa493d38b5ed645e177be54d94691ef6c3f8b5ad6d8db616c22c2190bedb9de
+SIZE (jutils-20070610.r26.tar.bz2) = 29481
diff --git a/games/jutils/pkg-descr b/games/jutils/pkg-descr
new file mode 100644
index 000000000000..9ecc4febf1ee
--- /dev/null
+++ b/games/jutils/pkg-descr
@@ -0,0 +1,3 @@
+A set of APIs utilized by the Java Game Technology Group.
+
+WWW: https://svn.java.net/svn/jutils~svn/trunk