aboutsummaryrefslogtreecommitdiff
path: root/games/jzip
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>1998-05-08 02:38:34 +0000
committerMatthew Hunt <mph@FreeBSD.org>1998-05-08 02:38:34 +0000
commitb1b9984c3cb9f58661411f7dd830b0ed60180985 (patch)
tree1249e9d04697f4d96aad65b911368b31e8219453 /games/jzip
parent1c3bffa62370c6a1b757a3d5e0c0830cb4030963 (diff)
downloadports-b1b9984c3cb9f58661411f7dd830b0ed60180985.tar.gz
ports-b1b9984c3cb9f58661411f7dd830b0ed60180985.zip
Notes
Diffstat (limited to 'games/jzip')
-rw-r--r--games/jzip/Makefile27
-rw-r--r--games/jzip/distinfo1
-rw-r--r--games/jzip/files/patch-aa17
-rw-r--r--games/jzip/pkg-comment1
-rw-r--r--games/jzip/pkg-descr7
-rw-r--r--games/jzip/pkg-plist1
6 files changed, 54 insertions, 0 deletions
diff --git a/games/jzip/Makefile b/games/jzip/Makefile
new file mode 100644
index 000000000000..96b8eb45be7b
--- /dev/null
+++ b/games/jzip/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: jzip
+# Version required: 2.0.1g
+# Date created: 7 May 1998
+# Whom: Matthew Hunt <mph@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= jzip201g
+PKGNAME= jzip-2.0.1g
+CATEGORIES= games
+MASTER_SITES= http://www.cfug.org/infocom/
+EXTRACT_SUFX= .zip
+
+MAINTAINER= mph@freebsd.org
+
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
+EXTRACT_CMD= unzip
+EXTRACT_BEFORE_ARGS= -qq
+
+NO_WRKSUBDIR= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/jzip ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/games/jzip/distinfo b/games/jzip/distinfo
new file mode 100644
index 000000000000..fbfe837c5a97
--- /dev/null
+++ b/games/jzip/distinfo
@@ -0,0 +1 @@
+MD5 (jzip201g.zip) = 6751370c6662d33ee0238cea656c6499
diff --git a/games/jzip/files/patch-aa b/games/jzip/files/patch-aa
new file mode 100644
index 000000000000..292cbf349e67
--- /dev/null
+++ b/games/jzip/files/patch-aa
@@ -0,0 +1,17 @@
+--- Makefile.orig Tue Dec 5 09:57:04 1995
++++ Makefile Thu May 7 22:35:23 1998
+@@ -21,10 +21,10 @@
+ # -DHARD_COLORS
+ # to the CFLAGS line.
+
+-CC = cc
+-CFLAGS = -c -DPOSIX
+-LDFLAGS = -O
+-LIBS = -lcurses
++#CC = cc
++CFLAGS += -c -DBSD -DHAVE_GETOPT
++#LDFLAGS = -O
++LIBS = -ltermcap
+
+ INC = ztypes.h
+ OBJS = jzip.o control.o extern.o fileio.o input.o interpre.o math.o memory.o \
diff --git a/games/jzip/pkg-comment b/games/jzip/pkg-comment
new file mode 100644
index 000000000000..954f8c3d2755
--- /dev/null
+++ b/games/jzip/pkg-comment
@@ -0,0 +1 @@
+A text-mode Infocom game interpreter.
diff --git a/games/jzip/pkg-descr b/games/jzip/pkg-descr
new file mode 100644
index 000000000000..6f6f0e563c24
--- /dev/null
+++ b/games/jzip/pkg-descr
@@ -0,0 +1,7 @@
+This software interprets Infocom text-adventure games. This port
+does not install any games; you can install them yourself if you
+own the games, or you can legally obtain the Zork series from:
+ http://www.csd.uwo.ca/~pete/Infocom/download.html
+Information on other methods of obtaining the games, including CD-ROM
+vendors, is available from:
+ http://www.cfug.org/infocom/
diff --git a/games/jzip/pkg-plist b/games/jzip/pkg-plist
new file mode 100644
index 000000000000..9b551b46d274
--- /dev/null
+++ b/games/jzip/pkg-plist
@@ -0,0 +1 @@
+bin/jzip