aboutsummaryrefslogtreecommitdiff
path: root/games/kmquake2
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-07-28 21:51:28 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-07-28 21:51:28 +0000
commiteab71026bf48a4e6680e0c771d41b4622887193f (patch)
treeb78ab2f0ecf962804fd9a1dbb37b84af13ff7be9 /games/kmquake2
parentd495a8c682489f0951f75aa715c8c8cfaea4b2a2 (diff)
downloadports-eab71026bf48a4e6680e0c771d41b4622887193f.tar.gz
ports-eab71026bf48a4e6680e0c771d41b4622887193f.zip
Notes
Diffstat (limited to 'games/kmquake2')
-rw-r--r--games/kmquake2/Makefile9
-rw-r--r--games/kmquake2/files/patch-qcommon__files.c56
2 files changed, 58 insertions, 7 deletions
diff --git a/games/kmquake2/Makefile b/games/kmquake2/Makefile
index b97f670aee07..9aea5e6a8313 100644
--- a/games/kmquake2/Makefile
+++ b/games/kmquake2/Makefile
@@ -7,9 +7,10 @@
PORTNAME= kmquake2
PORTVERSION= 0.19
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://qudos.quakedev.com/linux/quake2/engines/KMQuake2/:src \
- http://qexpo.quakedev.com/uploaded/54/:data \
+ http://qexpo2005.quakedev.com/uploaded/54/:data \
http://www.markshan.com/maps/:pax \
ftp://ftp.splatterworld.de/games/q2/mods/:pax \
http://www.markshan.com/engine/:paxpatch
@@ -32,9 +33,9 @@ WRKSRC= ${WRKDIR}/KMQuake2_${PORTVERSION:S/.//}_src_unix
OPTIONS= 3ZB2 "Build 3zb2 modification (bots)" off \
CLIENT "Build client" on \
- CTF "Build Capture The Flag modification" off \
+ CTF "Build CTF (Capture The Flag) modification" off \
DEDICATED "Build dedicated server" on \
- GAME "Build main game modification" on \
+ GAME "Build a main game .so file (required)" on \
HYBRID "Build Rogue-Xatrix hybrid modification" off \
LIGHTS "Build Lights modification with bots" off \
OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
@@ -65,7 +66,7 @@ MOD_LIST= 3ZB2 CTF HYBRID LIGHTS PAX ROGUE XATRIX ZAERO
.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED) && \
defined(WITHOUT_SDL)
-IGNORE= needs at least one of CLIENT, DEDICATED and SDL options
+IGNORE= needs at least one executable (CLIENT, DEDICATED and SDL)
.endif
.for mod in ${MOD_LIST}
diff --git a/games/kmquake2/files/patch-qcommon__files.c b/games/kmquake2/files/patch-qcommon__files.c
index 73e4e79ff4c6..d23a70ad2d3a 100644
--- a/games/kmquake2/files/patch-qcommon__files.c
+++ b/games/kmquake2/files/patch-qcommon__files.c
@@ -1,5 +1,5 @@
---- ./qcommon/files.c.orig Thu Mar 23 06:30:01 2006
-+++ ./qcommon/files.c Thu Jun 8 13:39:12 2006
+--- qcommon/files.c.orig Thu Mar 23 06:30:01 2006
++++ qcommon/files.c Fri Jul 28 14:54:41 2006
@@ -1314,7 +1314,7 @@
char *homedir; /* Home directory. */
@@ -9,7 +9,41 @@
FS_AddGameDirectory(gdir);
}
}
-@@ -1512,6 +1512,7 @@
+@@ -1468,16 +1468,7 @@
+ // basedir <path>
+ // allows the game to run from outside the data tree
+ //
+-#if defined __unix__
+-#ifdef DATADIR
+- fs_basedir = Cvar_Get("basedir", DATADIR, CVAR_NOSET);
+-#else
+- fs_basedir = Cvar_Get("basedir", ".", CVAR_NOSET);
+-#endif
+-#endif
+-#ifdef _WIN32
+ fs_basedir = Cvar_Get ("basedir", ".", CVAR_NOSET);
+-#endif
+
+ //
+ // cddir <path>
+@@ -1491,11 +1482,14 @@
+ //
+ // start up with baseq2 by default
+ //
+-#ifdef LIBDIR // unix
++#ifdef DATADIR
++ FS_AddGameDirectory(va("%s/"BASEDIRNAME, DATADIR));
++#endif
++#ifdef LIBDIR
+ FS_AddGameDirectory(va("%s/"BASEDIRNAME, LIBDIR));
+ #endif
+ FS_AddGameDirectory (va("%s/"BASEDIRNAME, fs_basedir->string) );
+-#ifdef DATADIR // unix
++#ifdef DATADIR
+ FS_AddHomeAsGameDirectory(BASEDIRNAME);
+ #endif
+ // any set gamedirs will be freed up to here
+@@ -1512,6 +1506,7 @@
#ifdef __unix__
/* Create directory if it does not exist. */
@@ -17,3 +51,19 @@
Sys_Mkdir(fs_gamedir);
Com_Printf("Using '%s' for writing.\n", fs_gamedir);
+@@ -1624,11 +1619,14 @@
+ Cvar_FullSet ("gamedir", dir, CVAR_SERVERINFO|CVAR_NOSET);
+ if (fs_cddir->string[0])
+ FS_AddGameDirectory (va("%s/%s", fs_cddir->string, dir) );
++#ifdef DATADIR
++ FS_AddGameDirectory(va("%s/%s", DATADIR, dir));
++#endif
+ #ifdef LIBDIR
+ FS_AddGameDirectory(va("%s/%s", LIBDIR, dir));
+ #endif
+ FS_AddGameDirectory (va("%s/%s", fs_basedir->string, dir) );
+-#if defined(DATADIR) && !defined(_WIN32)
++#ifdef DATADIR
+ FS_AddHomeAsGameDirectory(dir);
+ #endif
+ }