aboutsummaryrefslogtreecommitdiff
path: root/games/knavalbattle
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-27 11:55:25 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-27 11:55:25 +0000
commit24482eebf1b38a1d781b1f6c16bb588f5e652980 (patch)
treebcb09269855487369fcfd28040255e86e37e1362 /games/knavalbattle
parente9088ff192d5f032b73c9b2e3386bbc9bf25136b (diff)
downloadports-24482eebf1b38a1d781b1f6c16bb588f5e652980.tar.gz
ports-24482eebf1b38a1d781b1f6c16bb588f5e652980.zip
KDE/FreeBSD team presents KDE SC 4.10.1 ports!
- kdegames4 port has been split. - kdeutils4-printer-applet and system-config-printer-kde have been replaced by print/kde4-print-manager. - Recover misc/kde4-l10n-mr from attic. - New USE_KDE4 components: kactivities, libkdegames, nepomuk-core, and nepomuk-widgets. - Provide sharedmime component with magic: ports don't need to run update-mime-database themselves now. - Switch some ports to out-of-source build. - Update port comments. - Adjust dependence on Qt4 components. - x11/kde4 installs modern kdepim4 now. - Remove redundant aspell and hspell from kdelibs4, both can be enabled in textproc/enchant if needed. - Remove stale bits from bsd.kde4.mk The area51 repository features commits by Schaich Alonso and myself. Contributors: - Tobias Berner
Notes
Notes: svn path=/head/; revision=315373
Diffstat (limited to 'games/knavalbattle')
-rw-r--r--games/knavalbattle/Makefile23
-rw-r--r--games/knavalbattle/distinfo2
-rw-r--r--games/knavalbattle/pkg-descr6
-rw-r--r--games/knavalbattle/pkg-plist23
4 files changed, 54 insertions, 0 deletions
diff --git a/games/knavalbattle/Makefile b/games/knavalbattle/Makefile
new file mode 100644
index 000000000000..d8cf9cc6e168
--- /dev/null
+++ b/games/knavalbattle/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= knavalbattle
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= games kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE/${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= ${${PORTNAME}_DESC}
+
+CONFLICTS_INSTALL= kdegames-4.[0-9].*
+
+USE_KDE4= kdehier kdelibs kdeprefix libkdegames automoc4
+USES= cmake:outsource
+USE_QT4= corelib gui network xml \
+ moc_build qmake_build rcc_build uic_build
+USE_XZ= yes
+MAKE_JOBS_SAFE= yes
+
+.include <${.CURDIR}/../kdegames4/Makefile.common>
+.include <bsd.port.mk>
diff --git a/games/knavalbattle/distinfo b/games/knavalbattle/distinfo
new file mode 100644
index 000000000000..ae930464f8ed
--- /dev/null
+++ b/games/knavalbattle/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/4.10.1/knavalbattle-4.10.1.tar.xz) = 4ba4f05d9be054eeca7619ea753b10bd640532f7ba25f0033a825ff0ebae18ec
+SIZE (KDE/4.10.1/knavalbattle-4.10.1.tar.xz) = 856940
diff --git a/games/knavalbattle/pkg-descr b/games/knavalbattle/pkg-descr
new file mode 100644
index 000000000000..6123de0fd669
--- /dev/null
+++ b/games/knavalbattle/pkg-descr
@@ -0,0 +1,6 @@
+Naval Battle is a Battle Ship game for KDE. Ships are placed on a
+board which represents the sea. Players try to hit each others
+ships in turns without knowing where they are placed. The first
+player to destroy all ships wins the game.
+
+WWW: http://www.kde.org/applications/games/navalbattle/
diff --git a/games/knavalbattle/pkg-plist b/games/knavalbattle/pkg-plist
new file mode 100644
index 000000000000..82bc2d3a743f
--- /dev/null
+++ b/games/knavalbattle/pkg-plist
@@ -0,0 +1,23 @@
+bin/kbattleship
+share/applications/kde4/kbattleship.desktop
+share/apps/kbattleship/kbattleshipui.rc
+share/apps/kbattleship/pictures/default.desktop
+share/apps/kbattleship/pictures/default_theme.svgz
+share/apps/kbattleship/sounds/ship-player-shoot-water.ogg
+share/apps/kbattleship/sounds/ship-player1-shoot.ogg
+share/apps/kbattleship/sounds/ship-player2-shoot.ogg
+share/apps/kbattleship/sounds/ship-sink.ogg
+share/doc/HTML/en/kbattleship/common
+share/doc/HTML/en/kbattleship/index.cache.bz2
+share/doc/HTML/en/kbattleship/index.docbook
+share/icons/hicolor/128x128/apps/kbattleship.png
+share/icons/hicolor/16x16/apps/kbattleship.png
+share/icons/hicolor/22x22/apps/kbattleship.png
+share/icons/hicolor/32x32/apps/kbattleship.png
+share/icons/hicolor/48x48/apps/kbattleship.png
+share/icons/hicolor/64x64/apps/kbattleship.png
+share/kde4/services/kbattleship.protocol
+@dirrm share/doc/HTML/en/kbattleship
+@dirrm share/apps/kbattleship/sounds
+@dirrm share/apps/kbattleship/pictures
+@dirrm share/apps/kbattleship