aboutsummaryrefslogtreecommitdiff
path: root/games/kobodeluxe/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-29 14:06:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-29 14:06:17 +0000
commitdfb3e1c45f4ec9257b02ca5ce8439e7f3ffc92cd (patch)
tree3f7a9ba62403fbe056de608cf064eec62c5ffc4c /games/kobodeluxe/Makefile
parentceb246e62e633bb0391d0bfe3a33089225fb613e (diff)
Notes
Diffstat (limited to 'games/kobodeluxe/Makefile')
-rw-r--r--games/kobodeluxe/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/games/kobodeluxe/Makefile b/games/kobodeluxe/Makefile
index 2474742fe2bb..467447eba712 100644
--- a/games/kobodeluxe/Makefile
+++ b/games/kobodeluxe/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kobodeluxe
-DISTVERSION= 0.4.1
+PORTVERSION= 0.5.1
CATEGORIES= games
MASTER_SITES= http://olofson.net/kobodl/download/ \
http://www.amdmi3.ru/distfiles/
@@ -18,8 +18,8 @@ COMMENT= An SDL port of the scrolling game XKobo
USE_BZIP2= yes
USE_SDL= image sdl
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
- --sharedstatedir=${SCOREDIR}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --sharedstatedir=${SCOREDIR} --enable-oss
MAN6= kobodl.6
@@ -28,13 +28,15 @@ PLIST_SUB= SCOREDIR="${SCOREDIR}"
DATADIR= ${PREFIX}/share/kobo-deluxe
-OPTIONS= OPENGL "OpenGL rendering layer (experimental)" off
+OPTIONS= OPENGL "OpenGL rendering layer" on
.include <bsd.port.pre.mk>
-.if defined(WITH_OPENGL)
+.if !defined(WITHOUT_OPENGL)
USE_GL= yes
CONFIGURE_ARGS+= --enable-opengl
+.else
+CONFIGURE_ARGS+= --disable-opengl
.endif
post-patch: