aboutsummaryrefslogtreecommitdiff
path: root/games/kpicframer/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-01-25 15:40:57 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-01-25 15:40:57 +0000
commite7a98f122ad9be9d2b5da23767187b753c7584cb (patch)
treed756c144ffec939921b4bcb18be3b94ea4201e24 /games/kpicframer/Makefile
parentc9f5ea983e84ffee755dee9cd3c6d714ddbbc45f (diff)
downloadports-e7a98f122ad9be9d2b5da23767187b753c7584cb.tar.gz
ports-e7a98f122ad9be9d2b5da23767187b753c7584cb.zip
Notes
Diffstat (limited to 'games/kpicframer/Makefile')
-rw-r--r--games/kpicframer/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/kpicframer/Makefile b/games/kpicframer/Makefile
new file mode 100644
index 000000000000..7e0420861b70
--- /dev/null
+++ b/games/kpicframer/Makefile
@@ -0,0 +1,32 @@
+# New ports collection Makefile for: kpicframer
+# Date created: 2004-01-25
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= kpicframer
+PORTVERSION= 0.5
+CATEGORIES= games kde
+MASTER_SITES= http://www.norbs.de/kpicframer/download/
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= KDE card game
+
+BUILD_DEPENDS= autoconf257:${PORTSDIR}/devel/autoconf257 \
+ automake17:${PORTSDIR}/devel/automake17
+
+USE_KDELIBS_VER= 3
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+pre-configure:
+ cd ${WRKSRC}; ${MAKE} -f admin/Makefile.common cvs
+ ${FIND} ${WRKSRC} -name "*.ui" | ${XARGS} ${REINPLACE_CMD} -e "s,version=\"3.3\",version=\"3.2\","
+
+pre-build:
+ ${TOUCH} ${WRKSRC}/config.h.in
+
+.include <bsd.port.mk>