aboutsummaryrefslogtreecommitdiff
path: root/games/kspaceduel
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-27 11:55:25 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-27 11:55:25 +0000
commit24482eebf1b38a1d781b1f6c16bb588f5e652980 (patch)
treebcb09269855487369fcfd28040255e86e37e1362 /games/kspaceduel
parente9088ff192d5f032b73c9b2e3386bbc9bf25136b (diff)
downloadports-24482eebf1b38a1d781b1f6c16bb588f5e652980.tar.gz
ports-24482eebf1b38a1d781b1f6c16bb588f5e652980.zip
Notes
Diffstat (limited to 'games/kspaceduel')
-rw-r--r--games/kspaceduel/Makefile22
-rw-r--r--games/kspaceduel/distinfo2
-rw-r--r--games/kspaceduel/pkg-descr5
-rw-r--r--games/kspaceduel/pkg-plist48
4 files changed, 77 insertions, 0 deletions
diff --git a/games/kspaceduel/Makefile b/games/kspaceduel/Makefile
new file mode 100644
index 000000000000..8f47006608da
--- /dev/null
+++ b/games/kspaceduel/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= kspaceduel
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= games kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE/${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= ${${PORTNAME}_DESC}
+
+CONFLICTS_INSTALL= kdegames-4.[0-9].*
+
+USE_KDE4= kdehier kdelibs kdeprefix libkdegames automoc4
+USES= cmake:outsource
+USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_XZ= yes
+MAKE_JOBS_SAFE= yes
+
+.include <${.CURDIR}/../kdegames4/Makefile.common>
+.include <bsd.port.mk>
diff --git a/games/kspaceduel/distinfo b/games/kspaceduel/distinfo
new file mode 100644
index 000000000000..0f13ebede798
--- /dev/null
+++ b/games/kspaceduel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/4.10.1/kspaceduel-4.10.1.tar.xz) = a4fce851dfc864d7171c4e7d1042999b11ff5d1af517b9d72c09067a0d65b502
+SIZE (KDE/4.10.1/kspaceduel-4.10.1.tar.xz) = 264272
diff --git a/games/kspaceduel/pkg-descr b/games/kspaceduel/pkg-descr
new file mode 100644
index 000000000000..a52bb89ed5b5
--- /dev/null
+++ b/games/kspaceduel/pkg-descr
@@ -0,0 +1,5 @@
+In KSpaceDuel each of two possible players control a satellite
+spaceship orbiting the sun. As the game progresses players have
+to eliminate the opponent's spacecraft with bullets or mines.
+
+WWW: http://www.kde.org/applications/games/kspaceduel/
diff --git a/games/kspaceduel/pkg-plist b/games/kspaceduel/pkg-plist
new file mode 100644
index 000000000000..299ff592aee9
--- /dev/null
+++ b/games/kspaceduel/pkg-plist
@@ -0,0 +1,48 @@
+bin/kspaceduel
+share/applications/kde4/kspaceduel.desktop
+share/apps/kspaceduel/icons/hicolor/16x16/actions/spnewgame.png
+share/apps/kspaceduel/icons/hicolor/16x16/actions/spnewround.png
+share/apps/kspaceduel/icons/hicolor/16x16/actions/sppausegame.png
+share/apps/kspaceduel/icons/hicolor/22x22/actions/spnewgame.png
+share/apps/kspaceduel/icons/hicolor/22x22/actions/spnewround.png
+share/apps/kspaceduel/icons/hicolor/22x22/actions/sppausegame.png
+share/apps/kspaceduel/icons/hicolor/32x32/actions/spnewgame.png
+share/apps/kspaceduel/icons/hicolor/32x32/actions/spnewround.png
+share/apps/kspaceduel/icons/hicolor/32x32/actions/sppausegame.png
+share/apps/kspaceduel/kspaceduelui.rc
+share/apps/kspaceduel/sprites/backgr.png
+share/apps/kspaceduel/sprites/default_theme.svgz
+share/apps/kspaceduel/sprites/playerinfo/energy.png
+share/apps/kspaceduel/sprites/playerinfo/mine.png
+share/apps/kspaceduel/sprites/playerinfo/ship10.png
+share/apps/kspaceduel/sprites/playerinfo/ship11.png
+share/apps/kspaceduel/sprites/playerinfo/ship12.png
+share/apps/kspaceduel/sprites/playerinfo/ship13.png
+share/apps/kspaceduel/sprites/playerinfo/ship20.png
+share/apps/kspaceduel/sprites/playerinfo/ship21.png
+share/apps/kspaceduel/sprites/playerinfo/ship22.png
+share/apps/kspaceduel/sprites/playerinfo/ship23.png
+share/apps/kspaceduel/sprites/playerinfo/win.png
+share/config.kcfg/kspaceduel.kcfg
+share/doc/HTML/en/kspaceduel/common
+share/doc/HTML/en/kspaceduel/index.cache.bz2
+share/doc/HTML/en/kspaceduel/index.docbook
+share/doc/HTML/en/kspaceduel/kspaceduel3.png
+share/icons/hicolor/128x128/apps/kspaceduel.png
+share/icons/hicolor/16x16/apps/kspaceduel.png
+share/icons/hicolor/22x22/apps/kspaceduel.png
+share/icons/hicolor/32x32/apps/kspaceduel.png
+share/icons/hicolor/48x48/apps/kspaceduel.png
+share/icons/hicolor/64x64/apps/kspaceduel.png
+@dirrm share/doc/HTML/en/kspaceduel
+@dirrm share/apps/kspaceduel/sprites/playerinfo
+@dirrm share/apps/kspaceduel/sprites
+@dirrm share/apps/kspaceduel/icons/hicolor/32x32/actions
+@dirrm share/apps/kspaceduel/icons/hicolor/32x32
+@dirrm share/apps/kspaceduel/icons/hicolor/22x22/actions
+@dirrm share/apps/kspaceduel/icons/hicolor/22x22
+@dirrm share/apps/kspaceduel/icons/hicolor/16x16/actions
+@dirrm share/apps/kspaceduel/icons/hicolor/16x16
+@dirrm share/apps/kspaceduel/icons/hicolor
+@dirrm share/apps/kspaceduel/icons
+@dirrm share/apps/kspaceduel