aboutsummaryrefslogtreecommitdiff
path: root/games/kuklomenos/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-02 16:44:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-02 16:44:00 +0000
commitd02fa5c3da35e1af2a5ce741d59cb3cba18dd029 (patch)
treea9f7807967d8adf021142d3536ae5b8b99dd08f7 /games/kuklomenos/Makefile
parent6246c20c55c71f5e3973d44a9a52c81723be9440 (diff)
downloadports-d02fa5c3da35e1af2a5ce741d59cb3cba18dd029.tar.gz
ports-d02fa5c3da35e1af2a5ce741d59cb3cba18dd029.zip
Notes
Diffstat (limited to 'games/kuklomenos/Makefile')
-rw-r--r--games/kuklomenos/Makefile39
1 files changed, 29 insertions, 10 deletions
diff --git a/games/kuklomenos/Makefile b/games/kuklomenos/Makefile
index 1df7dea3dc43..dff26c922245 100644
--- a/games/kuklomenos/Makefile
+++ b/games/kuklomenos/Makefile
@@ -6,22 +6,41 @@
#
PORTNAME= kuklomenos
-PORTVERSION= 0.3.3.1
-PORTREVISION= 1
+PORTVERSION= 0.4
CATEGORIES= games
-MASTER_SITES= http://mbays.freeshell.org/kuklomenos/src/ LOCAL/chinsan/games
+MASTER_SITES= http://mbays.freeshell.org/kuklomenos/src/
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple but challenging abstract shoot-em-up game
-USE_SDL= sdl gfx
+LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
+OPTIONS= VORBIS "Enable Ogg/Vorbis support" on
+
+USE_SDL= sdl mixer
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags` `freetype-config --cflags` -I${LOCALBASE}/include " \
- LDFLAGS="`${SDL_CONFIG} --libs` -L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --datadir=${DATADIR}
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_VORBIS)
+CONFIGURE_ARGS+=--disable-sound
+PLIST_SUB+= VORBIS="@comment "
+.else
+LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+PLIST_SUB+= VORBIS=""
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/^sounds_DATA/s|Makefile.am||g' ${WRKSRC}/sounds/Makefile.in
-PLIST_FILES= bin/kuklomenos %%DATADIR%%/10x20.fnt %%DATADIR%%/7x13.fnt \
- %%DATADIR%%/amiga_machines.mod
-PLIST_DIRS= %%DATADIR%%
+.if ${OSVERSION} < 700000
+IGNORE= does not compile
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>