aboutsummaryrefslogtreecommitdiff
path: root/games/lander
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-02-22 15:08:35 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-02-22 15:08:35 +0000
commit1ce88e98be6eda36613e0b6257f1a48575757a69 (patch)
treedd2ee05b94176b46a23803148a4aeb8383f068ac /games/lander
parentf1d58233dbc2eaad30335e0d032028c5573e5285 (diff)
downloadports-1ce88e98be6eda36613e0b6257f1a48575757a69.tar.gz
ports-1ce88e98be6eda36613e0b6257f1a48575757a69.zip
Notes
Diffstat (limited to 'games/lander')
-rw-r--r--games/lander/Makefile41
-rw-r--r--games/lander/distinfo3
-rw-r--r--games/lander/pkg-descr7
-rw-r--r--games/lander/pkg-plist51
4 files changed, 102 insertions, 0 deletions
diff --git a/games/lander/Makefile b/games/lander/Makefile
new file mode 100644
index 000000000000..947a615ca1d0
--- /dev/null
+++ b/games/lander/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: lander
+# Date created: 21 Feb 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lander
+PORTVERSION= 0.5
+CATEGORIES= games
+MASTER_SITES= http://www.nickg.me.uk/files/ \
+ http://mirror.amdmi3.ru/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Lunar Lander clone
+
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+
+GNU_CONFIGURE= yes
+USE_GETTEXT= yes
+USE_SDL= sdl image mixer
+USE_GL= gl glu
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.1
+
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e '/LIBS=/ s|-lSDL_|`${SDL_CONFIG} --libs` &|' \
+ ${WRKSRC}/configure
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/lander/distinfo b/games/lander/distinfo
new file mode 100644
index 000000000000..dfb684a43d87
--- /dev/null
+++ b/games/lander/distinfo
@@ -0,0 +1,3 @@
+MD5 (lander-0.5.tar.gz) = 8ae0ea6e999e7566397d875c5c7adc80
+SHA256 (lander-0.5.tar.gz) = dda8797a93475feeee454f8d81c93d7787cb10c67df20637494b40e8edb32346
+SIZE (lander-0.5.tar.gz) = 1820603
diff --git a/games/lander/pkg-descr b/games/lander/pkg-descr
new file mode 100644
index 000000000000..f9875a4a8cca
--- /dev/null
+++ b/games/lander/pkg-descr
@@ -0,0 +1,7 @@
+This is a Lunar Lander clone written in C++ and OpenGL. Use the
+arrow keys to move the ship and avoid crashing into obstacles.
+Collect all the spinning keys and then land the ship on one of the
+landing pads. The levels are randomly generated and become
+progressively harder.
+
+WWW: http://www.doof.me.uk/lunar-lander/
diff --git a/games/lander/pkg-plist b/games/lander/pkg-plist
new file mode 100644
index 000000000000..fa7aa65c5b25
--- /dev/null
+++ b/games/lander/pkg-plist
@@ -0,0 +1,51 @@
+bin/lander
+%%DATADIR%%/Default_Font.ttf
+%%DATADIR%%/images/arrowblue.png
+%%DATADIR%%/images/arrowgreen.png
+%%DATADIR%%/images/arrowpink.png
+%%DATADIR%%/images/arrowred.png
+%%DATADIR%%/images/arrowyellow.png
+%%DATADIR%%/images/dirt_surface.png
+%%DATADIR%%/images/dirt_surface2.png
+%%DATADIR%%/images/exit_option.png
+%%DATADIR%%/images/fuelbar.png
+%%DATADIR%%/images/fuelmeter.png
+%%DATADIR%%/images/gameover.png
+%%DATADIR%%/images/gateway.png
+%%DATADIR%%/images/hscore.png
+%%DATADIR%%/images/keyblue.png
+%%DATADIR%%/images/keygreen.png
+%%DATADIR%%/images/keypink.png
+%%DATADIR%%/images/keyred.png
+%%DATADIR%%/images/keyyellow.png
+%%DATADIR%%/images/landingpad.png
+%%DATADIR%%/images/landingpadred.png
+%%DATADIR%%/images/levelcomp.png
+%%DATADIR%%/images/mine.png
+%%DATADIR%%/images/missile.png
+%%DATADIR%%/images/options_option.png
+%%DATADIR%%/images/particle.png
+%%DATADIR%%/images/red_rock_surface.png
+%%DATADIR%%/images/red_rock_surface2.png
+%%DATADIR%%/images/rock_surface.png
+%%DATADIR%%/images/rock_surface2.png
+%%DATADIR%%/images/score_option.png
+%%DATADIR%%/images/ship.png
+%%DATADIR%%/images/shipsmall.png
+%%DATADIR%%/images/snow_surface.png
+%%DATADIR%%/images/snow_surface2.png
+%%DATADIR%%/images/speedmeter.png
+%%DATADIR%%/images/star.png
+%%DATADIR%%/images/start_option.png
+%%DATADIR%%/images/title.png
+%%DATADIR%%/sounds/bleep.wav
+%%DATADIR%%/sounds/boing1.wav
+%%DATADIR%%/sounds/bomb_explosion.wav
+%%DATADIR%%/sounds/collect.wav
+%%DATADIR%%/sounds/firework_1.wav
+%%DATADIR%%/sounds/missile.wav
+%%DATADIR%%/sounds/select.wav
+share/locale/en_GB/LC_MESSAGES/lander.mo
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%