aboutsummaryrefslogtreecommitdiff
path: root/games/lbreakout2/Makefile
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2002-08-04 07:59:20 +0000
committerMark Pulford <markp@FreeBSD.org>2002-08-04 07:59:20 +0000
commit4959c9b21361dd0a8d2b83e1cf447ccf1f18f766 (patch)
tree97ced5d89f08f0e4afa1105f08d6721e1f672aa0 /games/lbreakout2/Makefile
parent61d4aab13248295db4fa5efba5f2c83e4ee4ec1b (diff)
downloadports-4959c9b21361dd0a8d2b83e1cf447ccf1f18f766.tar.gz
ports-4959c9b21361dd0a8d2b83e1cf447ccf1f18f766.zip
Notes
Diffstat (limited to 'games/lbreakout2/Makefile')
-rw-r--r--games/lbreakout2/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/games/lbreakout2/Makefile b/games/lbreakout2/Makefile
index 182e6c694437..ee76fc82e7f9 100644
--- a/games/lbreakout2/Makefile
+++ b/games/lbreakout2/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12 \
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-highscore-path=/var/games
+CONFIGURE_ARGS= --with-highscore-path=/var/games \
+ --with-doc-path=${PREFIX}/share/doc
CONFIGURE_ENV= SDL_CONFIG=${LOCALBASE}/bin/sdl11-config \
LDFLAGS=-L${LOCALBASE}/lib
USE_REINPLACE= yes
@@ -28,6 +29,9 @@ post-patch:
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's/if .*lbreakout2.hscr/if false/' \
${WRKSRC}/src/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's/ docs / /g' ${WRKSRC}/src/Makefile.in
+.endif
post-install:
${INSTALL_DATA} ${WRKSRC}/src/empty.hscr ${DATADIR}