aboutsummaryrefslogtreecommitdiff
path: root/games/lbreakout
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-16 14:05:28 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-16 14:05:28 +0000
commit2f214c16c17dfea00742e42f452709d1969a7701 (patch)
tree0249a8357f867ea012b950731169cc07236a3d95 /games/lbreakout
parent63dc6098d96bf48e05bdd3110d999e8673851749 (diff)
downloadports-2f214c16c17dfea00742e42f452709d1969a7701.tar.gz
ports-2f214c16c17dfea00742e42f452709d1969a7701.zip
Notes
Diffstat (limited to 'games/lbreakout')
-rw-r--r--games/lbreakout/Makefile19
-rw-r--r--games/lbreakout/pkg-descr2
2 files changed, 9 insertions, 12 deletions
diff --git a/games/lbreakout/Makefile b/games/lbreakout/Makefile
index c50f0ee67a88..ce78ca1f4ef9 100644
--- a/games/lbreakout/Makefile
+++ b/games/lbreakout/Makefile
@@ -14,20 +14,17 @@ MASTER_SITE_SUBDIR= lgames
MAINTAINER= ports@FreeBSD.org
COMMENT= A nice clone of classical Breakout game
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
-
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-
+USE_SDL= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
-USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-lcompat" \
- SDL_CONFIG="${SDL_CONFIG}"
+CONFIGURE_ENV= LIBS="-lcompat"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
- ${XARGS} ${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g'
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|"SDL/SDL|"SDL|g ; \
+ s|<SDL/SDL|<SDL|g'
pre-install:
${MKDIR} /var/games/${PORTNAME}
diff --git a/games/lbreakout/pkg-descr b/games/lbreakout/pkg-descr
index 34098e98f780..5dc2d277ef1c 100644
--- a/games/lbreakout/pkg-descr
+++ b/games/lbreakout/pkg-descr
@@ -18,4 +18,4 @@ This is a list of LBreakout's features:
Cool effects
Own levels can be created
-WWW: http://lgames.sourceforge.net/#lbreakout
+WWW: http://lgames.sourceforge.net/index.php?project=LBreakout