aboutsummaryrefslogtreecommitdiff
path: root/games/legend-of-edgar/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-10-15 16:02:57 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-10-15 16:02:57 +0000
commit57522ec2d4506375a66d0c444f5ab6280a4a0c08 (patch)
tree2c29a85445db5484514f133fc4b5d08c80b720bc /games/legend-of-edgar/Makefile
parentee94f9226776c2cd95ec71b4c05128a9f63772ed (diff)
downloadports-57522ec2d4506375a66d0c444f5ab6280a4a0c08.tar.gz
ports-57522ec2d4506375a66d0c444f5ab6280a4a0c08.zip
Notes
Diffstat (limited to 'games/legend-of-edgar/Makefile')
-rw-r--r--games/legend-of-edgar/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/games/legend-of-edgar/Makefile b/games/legend-of-edgar/Makefile
new file mode 100644
index 000000000000..5818e00186e9
--- /dev/null
+++ b/games/legend-of-edgar/Makefile
@@ -0,0 +1,54 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= edgar
+DISTVERSION= 1.12-1
+CATEGORIES= games
+MASTER_SITES= SF/legendof${PORTNAME}/${PORTVERSION:R}/
+PKGNAMEPREFIX= legend-of-
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= 2D platform game with a persistent world
+
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:S/-1//}
+
+USES= gmake
+USE_SDL= image mixer sdl ttf
+WITH_ZLIB= yes
+MAKEFILE= makefile
+
+PORTDOCS= *
+
+INSTALLS_ICONS= yes
+
+OPTIONS_DEFINE= DOCS NLS
+
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|CC = gcc|CC = ${CC}|' \
+ -e 's|$$(DESTDIR)/usr|${STAGEDIR}${LOCALBASE}|' \
+ -e 's|$$(PREFIX)/games/|$$(PREFIX)/bin/|' \
+ -e 's|/share/games/edgar/|/share/edgar/|' \
+ -e 's|-Wall ||' \
+ -e 's|sdl-config|$(SDL_CONFIG)|' \
+ -e 's|-s ||' \
+ ${WRKSRC}/makefile
+ @${REINPLACE_CMD} -e 's|SDL/SDL|${LOCALBASE}/include/SDL/SDL|g' \
+ ${WRKSRC}/src/headers.h
+ @${REINPLACE_CMD} -e 's|png.h|${LOCALBASE}/include/png.h|g' \
+ ${WRKSRC}/src/graphics/save_png.c
+ @${REINPLACE_CMD} -e 's|self->dirY =- 13|self->dirY -= 13|g' \
+ ${WRKSRC}/src/boss/golem_boss.c
+
+post-install:
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+.include <bsd.port.mk>