aboutsummaryrefslogtreecommitdiff
path: root/games/lgeneral
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
commit3a283e24f296371e9b753c09e3e62a92ef3d8703 (patch)
tree88e0a2bbddafb5c9bdc18e8e02c5e59fb9f9d471 /games/lgeneral
parent7a0a8929bea1c510b4f30261d294a78b556b49d7 (diff)
downloadports-3a283e24f296371e9b753c09e3e62a92ef3d8703.tar.gz
ports-3a283e24f296371e9b753c09e3e62a92ef3d8703.zip
Notes
Diffstat (limited to 'games/lgeneral')
-rw-r--r--games/lgeneral/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/games/lgeneral/Makefile b/games/lgeneral/Makefile
index 4ce14a971309..149aa6138157 100644
--- a/games/lgeneral/Makefile
+++ b/games/lgeneral/Makefile
@@ -20,8 +20,9 @@ LICENSE= GPLv2
CONFLICTS= lgeneral-data-[0-9]*
-OPTIONS= SOUND "Enable sound support" on \
- NLS "Enable native language support" on
+OPTIONS_DEFINE= SOUND NLS DOCS
+OPTIONS_DEFAULT= SOUND
+SOUND_DESC= Enable sound support
USE_SDL= sdl
USE_GMAKE= yes
@@ -36,19 +37,19 @@ MAN6= lgeneral.6
.include <bsd.port.options.mk>
-.if defined(WITHOUT_SOUND)
-CONFIGURE_ARGS+=--disable-sound
-.else
+.if ${PORT_OPTIONS:MSOUND}
USE_SDL+= mixer
+.else
+CONFIGURE_ARGS+=--disable-sound
.endif
-.if defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ENV+= am_cv_func_iconv=no
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
.endif
.include <bsd.port.pre.mk>
@@ -65,7 +66,7 @@ post-install:
@${FIND} ${DATADIR} | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
@${FIND} ${DATADIR} -type d | ${XARGS} ${CHMOD} a+rx
@${FIND} ${DATADIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.* ${DOCSDIR}
.endif