aboutsummaryrefslogtreecommitdiff
path: root/games/lianliankan
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-08-01 11:52:45 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-08-01 11:52:45 +0000
commit57b3d93e2fc50fe12fa3e9663f23c1b52833cb91 (patch)
tree6a32305dc4ef3d95c17aa9a52e84a363dfb51b69 /games/lianliankan
parent8bbc6baa46bc4544c91bd812d7576d290cdb5d67 (diff)
downloadports-57b3d93e2fc50fe12fa3e9663f23c1b52833cb91.tar.gz
ports-57b3d93e2fc50fe12fa3e9663f23c1b52833cb91.zip
Notes
Diffstat (limited to 'games/lianliankan')
-rw-r--r--games/lianliankan/Makefile19
-rw-r--r--games/lianliankan/distinfo6
-rw-r--r--games/lianliankan/files/patch-Makefile.in21
-rw-r--r--games/lianliankan/files/patch-src_main.c90
-rw-r--r--games/lianliankan/files/patch-src_pak_pak.c70
-rw-r--r--games/lianliankan/pkg-plist17
6 files changed, 60 insertions, 163 deletions
diff --git a/games/lianliankan/Makefile b/games/lianliankan/Makefile
index bc23374114fa..05113488a84a 100644
--- a/games/lianliankan/Makefile
+++ b/games/lianliankan/Makefile
@@ -6,29 +6,34 @@
#
PORTNAME= lianliankan
-PORTVERSION= 2.2
-PORTREVISION= 1
+DISTVERSION= 2.3beta1
CATEGORIES= games
MASTER_SITES= SF
MASTER_SITE_SUBDIR= llk-linux
-DISTNAME= llk_linux-${PORTVERSION}
+DISTNAME= llk_linux-${DISTVERSION}
MAINTAINER= relaxbsd@gmail.com
COMMENT= A scarce recreation game
+USE_AUTOTOOLS= automake:19:env
USE_GNOME= gtk20 esound
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_X_PREFIX= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.pre.mk>
+.if !defined(NOPORTDOCS)
+INSTALL_TARGET= install install-llk_linuxdocDATA
+.endif
+
+pre-configure:
+.for f in install-sh depcomp missing COPYING INSTALL
+ @${LN} -sf ${AUTOMAKE_DIR}/${f} ${WRKSRC}
+.endfor
post-install:
${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${FILESDIR}/lianliankan.desktop ${PREFIX}/share/applications
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/lianliankan/distinfo b/games/lianliankan/distinfo
index e5cbe1b71b16..1c26a2ff982d 100644
--- a/games/lianliankan/distinfo
+++ b/games/lianliankan/distinfo
@@ -1,3 +1,3 @@
-MD5 (llk_linux-2.2.tar.gz) = b3a6408e4024e9e2d26b8f71684a4576
-SHA256 (llk_linux-2.2.tar.gz) = 2e906a2ecf4154cbeb3e994defecca0d7627240494aa34b4e216e8483e855e3a
-SIZE (llk_linux-2.2.tar.gz) = 3251973
+MD5 (llk_linux-2.3beta1.tar.gz) = 29b2c974df1c4e46ca0dc4dd02763aba
+SHA256 (llk_linux-2.3beta1.tar.gz) = 4956569388329365bc6c995f68af6fbfcf6db4ccd6b677cbc41919a8894617e5
+SIZE (llk_linux-2.3beta1.tar.gz) = 3574240
diff --git a/games/lianliankan/files/patch-Makefile.in b/games/lianliankan/files/patch-Makefile.in
index 94b43c2977a8..51cc62109f8c 100644
--- a/games/lianliankan/files/patch-Makefile.in
+++ b/games/lianliankan/files/patch-Makefile.in
@@ -1,11 +1,22 @@
---- Makefile.in.orig Mon Apr 3 22:53:12 2006
-+++ Makefile.in Mon Apr 3 22:54:11 2006
-@@ -213,7 +213,7 @@
+--- Makefile.in.orig 2006-01-10 21:33:53.000000000 +0800
++++ Makefile.in 2007-07-30 17:56:35.000000000 +0800
+@@ -212,8 +212,8 @@
+ sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
- SUBDIRS = po src pixmaps data
+-SUBDIRS = po include src pixmaps data
-llk_linuxdocdir = ${prefix}/doc/llk_linux
-+llk_linuxdocdir = $(PACKAGE_DATA_DIR)/doc/llk_linux
++SUBDIRS = po src pixmaps data
++llk_linuxdocdir = ${PACKAGE_DATA_DIR}/doc/llk_linux
llk_linuxdoc_DATA = \
README\
COPYING\
+@@ -635,7 +635,7 @@
+
+ info-am:
+
+-install-data-am: install-llk_linuxdocDATA
++install-data-am:
+
+ install-exec-am:
+
diff --git a/games/lianliankan/files/patch-src_main.c b/games/lianliankan/files/patch-src_main.c
deleted file mode 100644
index 547a80f70d65..000000000000
--- a/games/lianliankan/files/patch-src_main.c
+++ /dev/null
@@ -1,90 +0,0 @@
---- src/main.c.orig Wed Dec 7 05:15:14 2005
-+++ src/main.c Thu May 25 00:52:58 2006
-@@ -727,9 +727,9 @@
- /* get and set next card back, and get and set next background picture */
- ui_pixbuf.cardback_choice = ui_pixbuf.cardback_choice>=5?0:ui_pixbuf.cardback_choice+1;
- if(pak_info.back_num > 0){
-+ gchar bgfilename[30];
- ui_pixbuf.randomback_choice = ui_pixbuf.randomback_choice>pak_info.back_num-1?1:ui_pixbuf.randomback_choice+1;
- /* Extract the bg picture and read it to ui_pixbuf.randomback */
-- gchar bgfilename[30];
- sprintf(bgfilename,"back%d.jpg",ui_pixbuf.randomback_choice-1);
- if(!ExtractSingleFile(bgfilename)){g_print(_("Failed to extract file:%s.\n"),bgfilename);}
- sprintf(bgfilename,"/tmp/llk_back%d.jpg",ui_pixbuf.randomback_choice-1);
-@@ -1200,12 +1200,13 @@
- struct passwd *user;
- int result;
- char path[MAX_PATH_LENGTH];
-- *message = (gchar *)g_malloc(sizeof(gchar)*100);
- gchar *return_str;
- GSList *radio_item_group=NULL;
- GtkWidget *menu,*menuitem;
- gint i;
-
-+ *message = (gchar *)g_malloc(sizeof(gchar)*100);
-+
- /* load ini file,if it do not exist, make a new one */
- user = getpwuid(getuid());
- /*user home directory: user->pw_dir*/
-@@ -1352,9 +1353,9 @@
- ui_pixbuf.mainback = gdk_pixbuf_new_from_file("/tmp/llk_mainback.jpg",NULL);
- ui_pixbuf.cardback_choice = g_rand_int_range(ui_rand,0,6); /*begin to end-1*/
- if(pak_info.back_num > 0){
-+ gchar bgfilename[30];
- ui_pixbuf.randomback_choice = g_rand_int_range(ui_rand,1,pak_info.back_num+1);
- /* Extract the bg picture and read it to ui_pixbuf.randomback */
-- gchar bgfilename[30];
- sprintf(bgfilename,"back%d.jpg",ui_pixbuf.randomback_choice-1);
- if(!ExtractSingleFile(bgfilename)){g_print(_("Failed to extract file:%s.\n"),bgfilename);}
- sprintf(bgfilename,"/tmp/llk_back%d.jpg",ui_pixbuf.randomback_choice-1);
-@@ -1474,9 +1475,9 @@
- ui_pixbuf.mainback = gdk_pixbuf_new_from_file("/tmp/llk_mainback.jpg",NULL);
- /* ui_pixbuf.cardback_choice = g_rand_int_range(ui_rand,0,6);*//*Do not change card back choice when change theme*/
- if(pak_info.back_num > 0){
-+ gchar bgfilename[30];
- ui_pixbuf.randomback_choice = g_rand_int_range(ui_rand,1,pak_info.back_num+1);
- /* Extract the bg picture and read it to ui_pixbuf.randomback */
-- gchar bgfilename[30];
- sprintf(bgfilename,"back%d.jpg",ui_pixbuf.randomback_choice-1);
- if(!ExtractSingleFile(bgfilename)){g_print(_("Failed to extract file:%s.\n"),bgfilename);}
- sprintf(bgfilename,"/tmp/llk_back%d.jpg",ui_pixbuf.randomback_choice-1);
-@@ -1640,6 +1641,12 @@
- gchar path[MAX_PATH_LENGTH];
- struct ScoreItem *score_list=NULL,*score_item_end=NULL,*score_item_tmp;
- gint item_num=0;
-+
-+ GtkWidget *dialog,*tree_view,*button;
-+ GtkCellRenderer *renderer;
-+ GtkListStore *store;
-+ GtkTreeIter iter;
-+
- /* load ini file,if it do not exist, make a new one */
- user = getpwuid(getuid());
- /*user home directory: user->pw_dir*/
-@@ -1676,6 +1683,7 @@
- if(!view) /* If not just view the score,then this function must be called by ui_game_over,so add the current player's score
- into the list,and then write to file if the list is modified,and at last,show the score list on a new window */
- {
-+ time_t t;
- gint insert_pos=1;
- for(score_item_tmp = score_list;score_item_tmp!=NULL;score_item_tmp=score_item_tmp->next)
- {
-@@ -1748,7 +1756,6 @@
- break;
- }
- sprintf(score_item_tmp->level,"%d",algorithm_game.level);
-- time_t t;
- time(&t);
- sprintf(score_item_tmp->time,"%s",asctime(gmtime(&t)));
- ui_input_string(score_item_tmp->name,score_item_tmp->nick,50);
-@@ -1775,10 +1782,6 @@
- }
- }
- /* Create a new window to show scores. */
-- GtkWidget *dialog,*tree_view,*button;
-- GtkCellRenderer *renderer;
-- GtkListStore *store;
-- GtkTreeIter iter;
- dialog = gtk_dialog_new();
- gtk_window_set_title(GTK_WINDOW(dialog),_("Top 10 Heros"));
- gtk_container_border_width(GTK_CONTAINER(dialog),5);
diff --git a/games/lianliankan/files/patch-src_pak_pak.c b/games/lianliankan/files/patch-src_pak_pak.c
index ef79dd622215..bb3a6bbaffb1 100644
--- a/games/lianliankan/files/patch-src_pak_pak.c
+++ b/games/lianliankan/files/patch-src_pak_pak.c
@@ -1,59 +1,29 @@
---- src/pak/pak.c.orig Sun Oct 23 04:36:59 2005
-+++ src/pak/pak.c Thu May 25 00:54:16 2006
-@@ -249,11 +249,7 @@
-
- /* Set the position in the PAK file for this file to be written at */
- /* If not GNU system,this should be Pos = Current->dwOffset */
--#ifdef WIN32
-- Pos = Current->dwOffset;
--#else
+--- src/pak/pak.c.orig 2007-07-30 17:17:44.000000000 +0800
++++ src/pak/pak.c 2007-07-30 17:19:23.000000000 +0800
+@@ -253,7 +253,7 @@
+ #ifdef WIN32
+ Pos = Current->dwOffset;
+ #else
- Pos.__pos = Current->dwOffset;
--#endif
-+ Pos = Current->dwOffset;
++ Pos = Current->dwOffset;
+ #endif
fsetpos( PAKStream, &Pos );
- /* Read in the file a byte at a time, encrypt it and write to PAK */
-@@ -410,11 +406,7 @@
- /* Set the offset in PAK to the beginning of this particular file
- to be extracted */
- /* If not GNU system,this should be Pos = Current->dwOffset */
--#ifdef WIN32
-- Pos = Current->dwOffset;
--#else
+@@ -418,7 +418,7 @@
+ #ifdef WIN32
+ Pos = Current->dwOffset;
+ #else
- Pos.__pos = Current->dwOffset;
--#endif
-+ Pos = Current->dwOffset;
++ Pos = Current->dwOffset;
+ #endif
fsetpos( ReadStream, &Pos );
- /* Loop through the file by it's size and read from the PAK
-@@ -453,6 +445,9 @@
- fpos_t Pos; /* Offset in to file */
- guchar Buffer = 0; /* A read buffer */
- guint32 Count;
-+
-+ gchar tmpstr[40];
-+
- /* Declare a temporary file table node to work from */
- struct sFileTableEntry* Current;
-
-@@ -476,7 +471,6 @@
- if( !ReadStream )
- return FALSE;
- /* Attempt to open the write stream for creating the file */
-- gchar tmpstr[40];
- sprintf(tmpstr,"/tmp/llk_%s",Current->szFileName);
- WriteStream = fopen( tmpstr, "wb" );
- if( !WriteStream )
-@@ -488,11 +482,7 @@
- /* Set the offset in PAK to the beginning of this particular file
- to be extracted */
- /* If not GNU system,this should be Pos = Current->dwOffset */
--#ifdef WIN32
-- Pos = Current->dwOffset;
--#else
+@@ -497,7 +497,7 @@
+ #ifdef WIN32
+ Pos = Current->dwOffset;
+ #else
- Pos.__pos = Current->dwOffset;
--#endif
-+ Pos = Current->dwOffset;
++ Pos = Current->dwOffset;
+ #endif
fsetpos( ReadStream, &Pos );
- /* Loop through the file by it's size and read from the PAK
diff --git a/games/lianliankan/pkg-plist b/games/lianliankan/pkg-plist
index bda76bf4934a..d1b688fdf2f7 100644
--- a/games/lianliankan/pkg-plist
+++ b/games/lianliankan/pkg-plist
@@ -1,16 +1,17 @@
bin/llk_linux
share/applications/lianliankan.desktop
-share/doc/llk_linux/AUTHORS
-share/doc/llk_linux/COPYING
-share/doc/llk_linux/ChangeLog
-share/doc/llk_linux/INSTALL
-share/doc/llk_linux/NEWS
-share/doc/llk_linux/README
-share/doc/llk_linux/TODO
+%%PORTDOCS%%share/doc/llk_linux/AUTHORS
+%%PORTDOCS%%share/doc/llk_linux/COPYING
+%%PORTDOCS%%share/doc/llk_linux/ChangeLog
+%%PORTDOCS%%share/doc/llk_linux/INSTALL
+%%PORTDOCS%%share/doc/llk_linux/NEWS
+%%PORTDOCS%%share/doc/llk_linux/README
+%%PORTDOCS%%share/doc/llk_linux/TODO
share/llk_linux/Cancle.wav
share/llk_linux/CanntLink.wav
share/llk_linux/Classical.pak
share/llk_linux/Click.wav
+share/llk_linux/Diamond.pak
share/llk_linux/GameOver.wav
share/llk_linux/Hint.wav
share/llk_linux/Link.wav
@@ -20,5 +21,5 @@ share/llk_linux/Win.wav
share/locale/zh_CN/LC_MESSAGES/llk_linux.mo
share/pixmaps/llk_linux.png
@dirrm share/llk_linux
-@dirrm share/doc/llk_linux
+%%PORTDOCS%%@dirrm share/doc/llk_linux
@dirrmtry share/applications