aboutsummaryrefslogtreecommitdiff
path: root/games/libdungeonmaker
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-24 16:08:39 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-24 16:08:39 +0000
commitb0c45bdec1ad6d159af7616abf9525a094f37b26 (patch)
treee079791916d2e56879803e7699c86fb45d04fb7f /games/libdungeonmaker
parentc72494a0240fbdc7adde07d5dcaf1a35f584e914 (diff)
include stdlib.h for rand(3) to fix build. While here, remove the profiled lib
from the plist. Its creation is changes with NO_PROFILE in src.conf, and it's pretty unnecessary, so I'm removing it from the plist altogether for simplicity.
Notes
Notes: svn path=/head/; revision=362816
Diffstat (limited to 'games/libdungeonmaker')
-rw-r--r--games/libdungeonmaker/Makefile1
-rw-r--r--games/libdungeonmaker/files/patch-DungeonMaker.h10
-rw-r--r--games/libdungeonmaker/pkg-plist1
3 files changed, 10 insertions, 2 deletions
diff --git a/games/libdungeonmaker/Makefile b/games/libdungeonmaker/Makefile
index acfa08459d79..7942344132b6 100644
--- a/games/libdungeonmaker/Makefile
+++ b/games/libdungeonmaker/Makefile
@@ -22,7 +22,6 @@ do-install:
${INSTALL_LIB} ${WRKSRC}/libdungeonmaker.a ${STAGEDIR}${PREFIX}/lib
${INSTALL_LIB} ${WRKSRC}/libdungeonmaker.so ${STAGEDIR}${PREFIX}/lib
${INSTALL_LIB} ${WRKSRC}/libdungeonmaker.so.2 ${STAGEDIR}${PREFIX}/lib
- ${INSTALL_LIB} ${WRKSRC}/libdungeonmaker_p.a ${STAGEDIR}${PREFIX}/lib
${INSTALL} ${WRKSRC}/DungeonMaker.h ${STAGEDIR}${PREFIX}/include
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/DM2_Manual/* ${STAGEDIR}${DOCSDIR}
diff --git a/games/libdungeonmaker/files/patch-DungeonMaker.h b/games/libdungeonmaker/files/patch-DungeonMaker.h
new file mode 100644
index 000000000000..037e3cb96690
--- /dev/null
+++ b/games/libdungeonmaker/files/patch-DungeonMaker.h
@@ -0,0 +1,10 @@
+--- DungeonMaker.h.orig 2014-07-24 11:55:26.000000000 -0400
++++ DungeonMaker.h 2014-07-24 11:55:51.000000000 -0400
+@@ -22,6 +22,7 @@
+ #include <list>
+ #include <string>
+ #include <assert.h>
++#include <stdlib.h>
+
+ ///* ATTENTION: In this version, the method DungeonMaker:: PutPlonkOnMap() puts MOBs and treasure on the map literally, by changing the SquareData of the Map square where the stuff goes. This is just for demonstration purposes to make it easier to show stuff without having an engine for rendering objects. If you use the DungeonMaker in your own program, you must refrain from calling this function, and instead write your own function that puts stuff on the map as objects and leaves the MapData as it is.
+
diff --git a/games/libdungeonmaker/pkg-plist b/games/libdungeonmaker/pkg-plist
index ee3bba2b8915..59fa99e6d7a9 100644
--- a/games/libdungeonmaker/pkg-plist
+++ b/games/libdungeonmaker/pkg-plist
@@ -2,7 +2,6 @@ include/DungeonMaker.h
lib/libdungeonmaker.a
lib/libdungeonmaker.so
lib/libdungeonmaker.so.2
-lib/libdungeonmaker_p.a
%%PORTDOCS%%%%DOCSDIR%%/Contents.gif
%%PORTDOCS%%%%DOCSDIR%%/Next.gif
%%PORTDOCS%%%%DOCSDIR%%/Prev.gif