aboutsummaryrefslogtreecommitdiff
path: root/games/libfov
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-01-13 16:21:15 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-01-13 16:21:15 +0000
commit8281c63cda23adb1f3cbc0e38c326eab0a0ab71a (patch)
treecda3db4485853fd2674615d8a7ba3f2bf367926b /games/libfov
parent48bdea7e8fc8e3f68f9c9b05b5ab04f2a2ee7291 (diff)
downloadports-8281c63cda23adb1f3cbc0e38c326eab0a0ab71a.tar.gz
ports-8281c63cda23adb1f3cbc0e38c326eab0a0ab71a.zip
Notes
Diffstat (limited to 'games/libfov')
-rw-r--r--games/libfov/Makefile22
-rw-r--r--games/libfov/distinfo3
-rw-r--r--games/libfov/files/Makefile.bsd10
-rw-r--r--games/libfov/pkg-descr8
-rw-r--r--games/libfov/pkg-plist5
5 files changed, 48 insertions, 0 deletions
diff --git a/games/libfov/Makefile b/games/libfov/Makefile
new file mode 100644
index 000000000000..f15f1e9c350e
--- /dev/null
+++ b/games/libfov/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: libfov
+# Date created: 12 Jan 2006
+# Whom: aaron@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= libfov
+PORTVERSION= 0.1.2
+CATEGORIES= games devel
+MASTER_SITES= http://members.optushome.com.au/puyo/dev/libfov/
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= This C library implements a course-grained lighting algorithm
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+INSTALLS_SHLIB= yes
+
+post-extract:
+ @${CP} ${PATCHDIR}/Makefile.bsd ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/games/libfov/distinfo b/games/libfov/distinfo
new file mode 100644
index 000000000000..102b2330ae02
--- /dev/null
+++ b/games/libfov/distinfo
@@ -0,0 +1,3 @@
+MD5 (libfov-0.1.2.tar.gz) = ef0e8ddee26433d219216d194c27926e
+SHA256 (libfov-0.1.2.tar.gz) = fa0ae16066cb736acf96f65c0a354f89125f74018912e59d50dc7e90c411c038
+SIZE (libfov-0.1.2.tar.gz) = 178220
diff --git a/games/libfov/files/Makefile.bsd b/games/libfov/files/Makefile.bsd
new file mode 100644
index 000000000000..a97515ecf004
--- /dev/null
+++ b/games/libfov/files/Makefile.bsd
@@ -0,0 +1,10 @@
+LIB= fov
+SHLIB_MAJOR= 0
+SHLIB_MINOR= 1
+SRCS= fov.c
+INCS= fov.h
+LIBDIR= ${PREFIX}/lib
+INCLUDEDIR= ${PREFIX}/include
+
+.include <bsd.lib.mk>
+
diff --git a/games/libfov/pkg-descr b/games/libfov/pkg-descr
new file mode 100644
index 000000000000..f424e8a24735
--- /dev/null
+++ b/games/libfov/pkg-descr
@@ -0,0 +1,8 @@
+This is a C library which implements a course-grained lighting algorithm
+suitable for tile-based games such as roguelikes.
+
+WWW: http://members.optushome.com.au/puyo/libfov.html
+Author: Greg <greg@puyo.cjb.net>
+
+- Aaron Dalton
+aaron@FreeBSD.org
diff --git a/games/libfov/pkg-plist b/games/libfov/pkg-plist
new file mode 100644
index 000000000000..88ce918dfbcf
--- /dev/null
+++ b/games/libfov/pkg-plist
@@ -0,0 +1,5 @@
+include/fov.h
+lib/libfov.a
+lib/libfov.so
+lib/libfov.so.0
+lib/libfov_p.a