aboutsummaryrefslogtreecommitdiff
path: root/games/libggz/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-19 17:54:49 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-19 17:54:49 +0000
commit4d86e99e2a57446237c8316143acb8b963732b65 (patch)
tree438952a0fd02885fc945695c384f3689426ead21 /games/libggz/Makefile
parent1c782a4ca9f489071d3951fd0f9c754e4367d09c (diff)
downloadports-4d86e99e2a57446237c8316143acb8b963732b65.tar.gz
ports-4d86e99e2a57446237c8316143acb8b963732b65.zip
Notes
Diffstat (limited to 'games/libggz/Makefile')
-rw-r--r--games/libggz/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/games/libggz/Makefile b/games/libggz/Makefile
index 130aba6552f8..043cf1b1250f 100644
--- a/games/libggz/Makefile
+++ b/games/libggz/Makefile
@@ -7,22 +7,20 @@
#
PORTNAME= libggz
-PORTVERSION= 0.0.8
-PORTREVISION= 1
+PORTVERSION= 0.0.9
CATEGORIES= games
-MASTER_SITES= http://ggzgamingzone.org/pub/ggz/%SUBDIR%/
+MASTER_SITES= http://ftp.ggzgamingzone.org/pub/ggz/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= The GGZ Gaming Zone - Base Library
-#LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt
USE_GNOME= gnomehack gnometarget
-USE_OPENSSL= yes
+USE_LIBTOOL_VER= 15
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --disable-debug --with-tls
+CONFIGURE_ARGS= --disable-debug
INSTALLS_SHLIB= yes
MAN3= ggz.h.3
@@ -30,4 +28,12 @@ MAN3= ggz.h.3
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gnutls.12:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+= --with-tls=GnuTLS
+.else
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-tls=OpenSSL
+.endif
+
.include <bsd.port.mk>