aboutsummaryrefslogtreecommitdiff
path: root/games/libshhcards/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-03 01:19:03 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-03 01:19:03 +0000
commitb3f827113dc3810bf7ec9d92fad50098ab124460 (patch)
tree8b038c5a2dd99a2c637e4f51bd1e620803ceb286 /games/libshhcards/Makefile
parent93d3a72f0ecfd8127f5b07dc633542b2e0f72cea (diff)
Notes
Diffstat (limited to 'games/libshhcards/Makefile')
-rw-r--r--games/libshhcards/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/games/libshhcards/Makefile b/games/libshhcards/Makefile
index 5ae32591e286..b5e375559ab8 100644
--- a/games/libshhcards/Makefile
+++ b/games/libshhcards/Makefile
@@ -16,14 +16,15 @@ MAKEFILE= ${FILESDIR}/Makefile.lib
USE_LDCONFIG= yes
MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/CREDITS ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+do-install:
+ ${INSTALL_LIB} ${WRKSRC}/libshhcards.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${WRKSRC}/libshhcards.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${WRKSRC}/libshhcards.so.1 ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL} ${WRKSRC}/shhcards.h ${STAGEDIR}${PREFIX}/include
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>